DM920 MultiRC, 2x

  • Hallo zusammen,



    meine beiden DM920er (nachdem ich die erste neu geflasht habe) laufen inzwischen reibungslos.


    Nach wie vor habe ich jedoch das Problem, dass eine der beiden FB beide Geräte anspricht, was durchaus lästig ist.


    Bei beiden, eine mit DIP oben/oben, die andere mit DIP oben/unten, lässt sich über MultiRC nichts verändern.

    Beim Aufruf erscheint immer das PopUp “Multi RemoteControl“ mit der ersten, erhellten Zeile “Auf Fernbedienung reagieren“.

    Diese Zeile lässt sich mit keiner Taste auf der FB verändern. Nur bei OK erscheint wieder das Plugin Menü.


    Auch deinstallieren von MultiRc und nach Neustart wieder installieren bringt keine Veränderung.


    Braucht MultiRC vielleicht noch ein anderes Plugin zur Unterstützung?


    Hat hier irgendjemand eine Idee?

    Oder bin ich der einzige mit diesem Problem?



    Ich bitte um Unterstützung, wofür ich mich schon jetzt bedanke.

  • Sagen wir Mal so, ich weiß warum ich mir meine eigene FB Ebenen Umschaltung ins Barry Allen gemacht habe. Das war nicht nur um auch das bootmenu sauber mit nur einer FB zu bedienen.


    Wenn ich selbst direkt ins /proc schreibe weis ich was ich bekomme ;)


    Plugin macht letztendlich ja auch nix anderes....

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Auch dieses Plugin ist ein Opfer von "seperation" geworden...


    Du kannst die plugin.py in einem Linux-konformen Editor (z.B. notepad++) öffnen und den vorhanden skin mit diesem ersetzen:


    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • das mit dem editieren der 'plugin.py' würde ich gerne versuchen.


    Habe dafür soeben die Unterpfade von /root durchgesehen. Leider erfolglos.


    In welchem Pfad ist denn diese Datei abgelegt?


    Danke schon jetzt für diesen Hinweis.

  • /usr/lib/enigma2/python/Plugins/Extentsions/MultiRC/plugin.py


    Ich habs auch auf github korrigiert, das wird allerdings erst mit dem nächsten Update von DMM bei dir ankommen.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • /root/ ist ja bereits ein Unterverzeichnis. Da musst du zuerst ein Verzeichnis nach oben auf / gehen. Beachte aber, dass die Änderung nur mit einem Linux-kompatiblen Editor gemacht werden darf. Unter Windows kann ich da Notepad++ empfehlen.


    Ich habe gerade auch mal getestet und mit den Skins "Default-HD" oder "Default-FHD" siehst du zumindest einen Bruchteil des eingestellten Wertes :D

    Einstellen musst du vermutlich "Illuminated RC layer 1" und "Illuminated RC layer 2", da du ja 00 = layer 1 und 01 = layer 2 eingestellt (evtl. aber auch 3 und 4, je nachdem wie man die Binärschaltung der DIP-Schalter liest :D). Damit du dich halb blind in der Liste zurecht findest, kannst du in der Plugin-Doku die Reihenfolge der Optionen nachlesen: https://board.dreambox.tools/i…rticle/36-plugin-multirc/

    Quote
    • Any RC
    • DM8000-RC layer 1
    • DM8000-RC layer 2
    • DM8000-RC layer 3
    • DM8000-RC layer 4
    • Illuminated RC layer 1
    • Illuminated RC layer 2
    • Illuminated RC layer 3
    • Illuminated RC layer 4
    • layer 1
    • layer 2
    • layer 3
    • layer 4


    Also blind auf Wert 1 bzw 2 mit "Illumina" im Bild navigieren, OK drücken und versuchen den dann erscheinenden Dialog mit "Ja" zu beantworten. Geht das nicht, hast du den falschen Wert getroffen und musst 20 Sekunden warten, bis die Einstellung zurück gesetzt wird.

  • Ich verstehe nicht was ihr für Probleme mit dem Plugin habt. :/


    Meine 7080/900/920 stehen alle nebeneinander, und jede Box kann ich seperat mit der jeweiligen Fernbedienung bedienen.


    Das funktioniert ohne Probleme mit dem original DP Image, sowie mit dem aktuellem OoZooN Image. :)

    mfg.


    schnubbel
    OoZooN Team

  • Nur hast du die Ebenen bereits geändert. Wie willst du aber wissen, welche Ebene du aktuell grad einstellst in der Config, wenn du den Wert gar nicht siehst???

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Wenn das Plugin einmal eingestellt ist, gibt es kein Problem. Seitdem Dream aber bei einem der letzten e2 Updates die Skin-Parameter für Config-Listen grundlegend geändert hat, ist der Config-Screen dieses Plugins (und die Screens vieler anderer Plugins) mit vielen Skins erstmal kaputt. Das sieht dann so aus:

    Kaputt mit Default Skin:


    Kaputt mit Default FHD:



    Mit dem Fix von oben im Default:


    Beim Testen des Fixs ist mir noch aufgefallen, dass man auf jeden Fall darauf achten muss, dass die Einrückung erhalten bleibt! Man muss ein Tab davor einfügen und 4 Leerzeichen durch je ein Tab ersetzen.

    AlterKerl : Wenn du dich damit nicht gut auskennst, würde ich die Einstellung eher blind mit dem Default FHD setzen oder auf das nächste Update warten.

  • Guten Morgen,


    leider keine Erfolgsmeldung.

    Habe die Datei plugin.py wie angegeben verändert und neu gestartet.

    Jetzt ist bei MultiRC wieder das PopUp mit den Auswahlmöglichkeiten “Illumina, level1, level2, level3, level4, beliebig und DM8000“ da.

    Reagieren geht aber nur auf beliebig. Und das ist dann die Situation wie bisher auch.


    Ich versuch‘s jetzt noch ein bisschen nur so.

    Ansonsten warte ich dann auf das versprochene Update.


    Danke dennoch allen.

  • Wenn du nun im Plugin alles sehen kannst (“Illumina, level1, level2, level3, level4) war deine Änderung ja erfolgreich.

    Da wird auch das Update nichts ändern.

    Aber ich kann dir da nicht weiter helfen, da ich MultiRC noch nie verwendet hatte.

    >> Wir Schweizer haben die Uhren, aber keine Zeit ! <<

  • Der Vorgang der Änderung als solcher war zwar erfolgreich, hilft aber nicht weiter, wenn in der Auswahl nur "beliebig" reagiert.

    Damit sprechen wieder beide Geräte an.


    Vielleicht erlaubt das angekündigte Update ja dann auch eine andere Wahlmöglichkeit, z.B. level1 oder so??


    Oder liege ich da ganz falsch?

  • Nochmals wenn die RC auf einen Level gejumpert ist dann muss man nur den Level einstellen damit der ins /proc geschrieben wird und dann reagiert E2 auch nur auf diesem Level oder bei FBs die alle Levels rausschicken weil ungejumpert.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • Guten Morgen nochmals,


    Erfolgsmeldung!!!


    Folgender Ablauf führte zum Erfolg:

    In der Datei plugin.py in der if-Abfrage in allen 3 Optionen seperation="400" zwischen size="1440,120" und scrollbarMode="showOnDemand" eingefügt.


    Dann in der Menü-Auswahl "Default-FHD" ausgewählt und Neustart.


    Jetzt erscheint beim Anclicken von MultiRC das PopUp mit den Auswahlmöglichkeiten “Illumina- level1, Illumina-level2 usw..

    Habe dann entsprechend den DIPs in den FBs die erfolgreiche Auswahl getroffen.


    Nun laufen die beiden DM920 so, wie ich es mir vorgestellt habe.


    Danke nochmals an Euch alle.