greenscreen bei Mediaportal

  • Hallo,


    leider habe ich seit einiger Zeit auf der Dream 920 mit NN2 im Mediaportal greenscreen. Ich hänge mal ein log an wäre super wenn mir jemand helfen kann.


    VG Wolfia

  • Ja eben was postest das dann hier schau mal auf das Topic!!!


    Wobei die source ist hier:


    https://github.com/opendreambo…aster/src/merlinmp3player


    Womit das eben NICHT unbedingt Dr. Best fixen MUSS wie ständig behauptet wird ....

    Das damit rein gar nichts zu tun (das ist der alte MMP), die genannte Lib-Sourcen hat NUR Dr.Best daher kann auch nur er es fixen wenn er denn mal Zeit dafür hat.

    Edited once, last by dhwz: Ein Beitrag von dhwz mit diesem Beitrag zusammengefügt. ().

  • Ich weis, dass Dr. Best mit seinen aktuellen sourcen genauso wie ich knausrig ist (was auch gute Grunde hat) aber wenn es NUR ums MP3 geht ginge das auch mit dem alten code eine auch im OE 2.6 funktionierende .so zu machen.


    Und ja ich weis das der Thread nicht ideal ist, aber ich kann mir nicht aussuchen wann es mir zu VIEL wird das Gleiche immer wieder zu lesen ;)


    Wenn also wer mit dem Player wieder MP3 hören will kann Ihm mit der plugin.py als Workaround leicht geholfen werden und dann warten wir vielleicht alle etwas entspannter....

    Two things are infinite: the universe and human stupidity; and I'm not sure about the universe.

  • Sorry du verstehst nicht, MMP2 != MMP das was im GIT liegt hat mit MMP2 rein gar nichts zu tun. Daher ist deine Hilfestellung überhaupt nicht zielführend, das ist ein völlig anderes Plugin. ;)

    Es crasht weil die Playerlib die MMP und auch das MP verwendet nach dem letzten DP Update kaputt ist und neu compiliert werden muss, da gibt es nichts zu fixen, außer dass man sie aktuell entfernt. Oder auf dem alten Core-Stand bleibt wie das Merlin.

  • Na gut dann BITTE verzeiht mir wenn ich meinen Frust hier abgeladen habe und verschiebt das in einen anderen Thread ... weil löschen soll ich ja nichts mehr ...


    Der alte Merlin Music Player ist halt im git und crashed damit in jedem Image auf der one/two AUCH vor sich hin - solange man nicht das Laden des darin enthaltenen *.so verhindert oder eben den alten cpp code anpasst.


    Ich habe jetzt dafür einen eigenen Thread eröffnet und meine unpassende Kommentare dorthin kopiert:


    Workaround damit der Merlin Music Player auf der one/two nicht crashed bis das merlinmp3player.so angepasst ist


    Und Ihr löscht brav weiter das python-merlinmusicplayer ;(

    Two things are infinite: the universe and human stupidity; and I'm not sure about the universe.

    Edited 8 times, last by gutemine ().

  • I installed the Media Portal plugin and most seemed to work OK


    But after reboot i got this error and my dm two went into a boot loop.

    Really did not now what started it. But since Media Portal was the last plugin i installed i just removed it and that brought my dm two out of the boot loop


    Latest DP Image 2021-02-18


    VIDEO_GET_EVENT - ok

    swig director exception (SWIG director method error.)

    0x8ddbd4 (sp = 0x7ffbfc2040) <SwigDirector_eSlot1I :: cb_func (int) +324>

    0x59fb2c (sp = 0x7ffbfc2070) <eDisplayManager :: eventRelay (int) +1260>

    0x730f30 (sp = 0x7ffbfc2100) <pNavigation :: navEvent (int) +216>

    0x72e718 (sp = 0x7ffbfc2180) <eNavigation :: serviceEvent (iPlayableService *, int) +312>

    0x6e69dc (sp = 0x7ffbfc2200) <std :: __ cxx11 :: _ List_base <eDVBSubtitlePage, std :: allocator <eDVBSubtitlePage>> :: _ M_clear () + 300>

    0x6da5a0 (sp = 0x7ffbfc2270) <eDVBServicePlay :: video_event (iTSMPEGDecoder :: videoEvent) +104>

    0x673398 (sp = 0x7ffbfc22b0) <eTSMPEGDecoder :: video_event (iTSMPEGDecoder :: videoEvent) +232>

    0x673e54 (sp = 0x7ffbfc2330) <eDVBVideo :: video_event (int) +1100>

    0x534824 (sp = 0x7ffbfc23d0) <eSocketNotifier :: activate (int) +260>

    0x536820 (sp = 0x7ffbfc2470) <eMainloop_native :: processOneEvent (int) +2248>

    0x7cbe00 (sp = 0x7ffbfc3700) <eMainloopQt :: processEvents (QFlags <QEventLoop :: ProcessEventsFlag>) + 176>

    0x7fa69eb49c (sp = 0x7ffbfc3860) <QEventLoop :: exec (QFlags <QEventLoop :: ProcessEventsFlag>) + 244>

    0x7fa69f4020 (sp = 0x7ffbfc38e0) <QCoreApplication :: exec () + 136>

    0x7cbd2c (sp = 0x7ffbfc3930) <eMainloopQt :: runLoop () + 28>

    0x7d25b0 (sp = 0x7ffbfc3950) <KeyEvent :: qt_metacall (QMetaObject :: Call, int, void **) + 7552>

    0x7fa632c2cc (sp = 0x7ffbfc3970) <PyEval_EvalFrameEx + 21052>

    Traceback (most recent call last):

    File "/usr/lib/enigma2/python/enigma.py", line 15723, in __call__

    return ret (* args, ** kwargs)

    File "/usr/lib/enigma2/python/Components/DisplayHardware.py", line 167, in contentFramerateChanged

    (port, mode, rate) = self.getConfiguredMode ()

    File "/usr/lib/enigma2/python/Components/DisplayHardware.py", line 150, in getConfiguredMode

    mode = config.av.videomode [config.av.videoport.value] .value

    -------

    KeyError: 'DVI'

    Everything in life that's any fun is either immoral, illegal or fattening

  • Sowas ähnliches hatte ich hier auch schon auf der One.

    Konnte dazu aber noch keine Ursache finden, da der Fehler nur sehr selten auftritt.


    Bei mir war es im AutoResolution-Plugin in folgender Zeile:

    rate = config.av.videorate[mode].value

    Da löst der mode den KeyError aus.


    Musste mir dann die obige Zeile in ein try: except: einpacken, damit die Box wieder startete.

    Sonst bliebt sie in einer Dauerschleife (auch Schalter an der Rückseite half nicht).

    Wo liegt eigentlich der aktuelle source-Code für das AutoResolution-Plugin im git ?

    der hier stimmt zumindest nicht mit dem auf meiner Box überein:

    enigma2-plugins/autoresolution/src at master · opendreambox/enigma2-plugins · GitHub

    (das auf der Box ist ganz normal über den Feed installiert - enigma2-plugin-systemplugins-autoresolution 4.4.1+git34+9f77205f79-r0.0)

    Gruß Sven (aka Dreamy)


    DM920 mit unstable OE2.5 DP
    One mit unstable OE2.6 DP

    Edited once, last by Sven H ().

  • Ok then we can conclude it has nothing to do with MP but the error is in the autoresolution plugin.

    I was just lucky to get out of the loop because i removed MP but the error is in fact in the autoresolution plugin?

    Everything in life that's any fun is either immoral, illegal or fattening

  • Hat einer eine Idee oder kann helfen?

    Beim Drücken der PVR Taste - Greenscreen.

    auch Zugriff auf Festplatte nicht mehr möglich - Greenscreen.


    Dreamone

    Crashlog im Anhang

  • Have to be the bringer of bad news .. Same crash after some use of MP and the boot loop is still there

    Just as a question here ... But is @gutemines feeds plugin and Media "Portal" compatible since there is a kill code for Portal Panel and so on ??

    Everything in life that's any fun is either immoral, illegal or fattening

  • I have now try and uninstall autoresolution plugin, guteines feeds plugin and MediaPortal


    Full reboot, the apt autoremove to clean up and new reboot.

    Reset the mediadatabase and to be safe another reboot


    Install MediaPortal and wham green screen so i give up.

    Everything in life that's any fun is either immoral, illegal or fattening

  • Well i don't have merlinmusicplayer installed


    opendreambox 2.6.0 dreambox



    dreambox login: root

    Password:

    root @ dreambox: ~ # apt-get remove python-merlinmusicplayer

    Reading package lists ... Done

    Building dependency tree

    Reading state information ... Done

    Package 'python-merlinmusicplayer' is not installed, so not removed

    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    root @ dreambox: ~ #

    Everything in life that's any fun is either immoral, illegal or fattening

  • Here is my first post with the crash info


    RE: greenscreen bei Mediaportal


    And as i also wrote in this post I was not sure it was Mediaportal causing the crash but since it was the last plugin I installed

    I removed the plugin and all works just fine.


    The later Svein H made the comment this issue could be related to the autoresolution plugin so i did try his suggested fix

    And then installed MP again. For sometime it looked like all was fine. But then out of the blue same crash.


    So my next step was to remove the Autoresolution plugin, MP, gutemines feeds

    Full reboot and only install MP back. Still the same crash.

    I also did like dre suggested and reset the media database.

    So I cant still 100% say it's MP causing the crash. But i can say 100% sure if i uninstall MP all works fine and i have no issues.


    But if you need the full crash log it's attached now

    Files

    Everything in life that's any fun is either immoral, illegal or fattening