8000 bootet aus DeepStandby nicht immer OE2.0 - Bootlog anbei

  • Wenn Du das so zuverlaessig reproduzieren kannst, solltest Du mal den
    Rat von Ghost befolgen und den ath-Treiber durch Umbenennen deaktivieren
    und dann nochmal versuchen den Fehler zu provozieren.

    DM900 SS, DM8000SSSS
    Kein Support per PN! Nutzt das Forum zum Fragen, dann haben auch andere etwas davon.

  • Hi,


    ich hatte nach dem Fix von Ghost auch keine Hänger mehr ABER ich hatte auch zu dem Zeitpunkt die WLAN Treiber deinstalliert. Vielleicht sind es doch die WLAN Treiber.

  • Der Fix hat nichts gebracht. 3 Tage kein Problem, heute Nacht wieder hängen geblieben. Ich werde jetzt auch die WLan-Treiber deinstallieren, ich nutze LAN.

  • Bei mir seit dem Löschen des WLAN-Treibers keine Hänger mehr, die Box startet einwandfrei aus dem Deepstanby !

  • Hab seit Dienstag Abend den WLAN-Treiber auch entfernt, bis jetzt ist die Box jedes Mal fehlerfrei gestartet. Aber ich will das Startverhalten mal noch 2-3 Wochen beobachten.

  • Hallo,


    ich habe den Treiber doch wohl noch nicht entfernt bekommen.


    find . -name ath* -print
    ./lib/modules/3.2-dm8000/net/ath_rate_amrr.ko
    ./lib/modules/3.2-dm8000/net/ath_rate_onoe.ko
    ./lib/modules/3.2-dm8000/net/ath_rate_minstrel.ko
    ./lib/modules/3.2-dm8000/net/ath_hal.ko
    ./lib/modules/3.2-dm8000/net/ath_pci.ko
    ./lib/modules/3.2-dm8000/net/ath_rate_sample.ko
    ./lib/modules/3.2-dm8000/kernel/drivers/net/wireless/ath
    ./sys/devices/pci0000:00/0000:00:01.0/net/ath0
    ./sys/bus/pci/drivers/ath_pci
    ./sys/class/net/ath0
    ./sys/module/ath_hal
    ./sys/module/ath_hal/holders/ath_pci
    ./sys/module/ath_hal/holders/ath_rate_sample
    ./sys/module/wlan/holders/ath_pci
    ./sys/module/wlan/holders/ath_rate_sample
    ./sys/module/ath_pci
    ./sys/module/ath_rate_sample
    ./proc/sys/dev/ath
    ./proc/sys/net/ipv4/neigh/ath0
    ./proc/sys/net/ipv4/conf/ath0
    ./proc/sys/net/ath0


    Ich bin mir nicht mehr so ganz sicher ob es ausrreicht ./sys/bus/pci/drivers/ath_pci umzubennen.


    Kann das einer bestätigen?


    mfg.


    freeman

  • /sys ist ein virtuelles vilesystem da bringt dir das umbenenen gar nichts. Entweder so wie Ghost geschreiben hat .ko file löschen oder z.B auf .noko umbenennen falls man es mit insmod später selber laden will.

  • ...


    Also eine Idee wäre nun einfach mal aus "/lib/modules/3.2-dm8000/net" das ath_pci.ko zu entfernen .. also am besten per ftp auf dem PC sichern oder sowas.. oder mit dem mc auf der Box auf die HDD schieben.. auf jedenfall muss er aus /lib/modules raus.


    ...

    How can we win, when fools can be kings?

  • Ghost,


    das ganze hat mir keine Ruhe gelassen.


    Also komplett noch mal neu und ich kann den Fehler wieder reproduzieren siehe Logs.


    Der Fehler tritt wie bereits vorher schon erwähnt sehr schnell bei mir auf wenn keine LAN Verbindung besteht und keine aktive DVI->HDMI Verbindung besteht.


    Es fängt damit an das beim herunterfahren in den Deep Stanby Mode folgende Warnung Auftritt:


    JFFS2 warning: ( 538 ) jffs2_sum_write_data: Not enough space for summary, padsize = -848


    nach ca. 10Min Deep Standby treten folgende Fehler auf:


    [ 9.369000] udevd[86]: starting version 182
    [ 10.332000] ath_hal: module license 'Proprietary' taints kernel.
    [ 10.339000] Disabling lock debugging due to kernel taint
    [ 10.361000] ath_hal: 2009-05-08 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, REGOPS_FUNC, XR)
    [ 10.722000] wlan: svn r3314
    [ 10.826000] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
    [ 10.834000] cdrom: Uniform CD-ROM driver Revision: 3.20
    [ 10.997000] ath_pci: svn r3314
    [ 11.001000] PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
    [ 11.007000] Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
    [ 11.654000] module ath_rate_sample: dangerous R_MIPS_LO16 REL relocation
    [ 11.654000] module alps_bsbe1_c01a: dangerous R_MIPS_LO16 REL relocation
    [ 11.670000] Rate control module "ath_rate_sample" not available
    [ 11.676000] No rate control module available
    [ 11.681000] ath_pci: ath_attach failed: 5
    [ 11.708000] module dreambox_rc2: dangerous R_MIPS_LO16 REL relocation


    gefolgt 50% Balken mit Blau leuchtender LED:


    Enigma2 v4.0.0 (revision: tarball-20120924-0-g1302a2a, date: 2012-09-24)


    Enigma2 is property of Dream Multimedia GmbH. All copyrights with regard to
    Enigma2 belong to Dream Multimedia GmbH only.


    The full license text is available at /usr/share/doc/enigma2/LICENSE.


    PYTHONPATH: /usr/lib/enigma2/python
    + (1) Background File Eraser
    + (8) graphics acceleration manager
    /dev/fb0: No such file or directory
    + (9) GFBDC
    /dev/fb0: No such file or directory
    framebuffer not available.
    FATAL: no framebuffer available
    Aborted


    INIT: Id "e2" respawning too fast: disabled for 5 minutes
    INIT: no more processes left in this runlevel


    Wird der ATH-PCI treiber nicht geladen Bootet das System bis jetzt einwandfrei.
    Allerdings treten bei dem einen oder anderen mal beim Herunterfahren die Summary Warnungen auf:


    [ 48.369000] JFFS2 warning: (611) jffs2_sum_write_data: Not enough space for summary, padsize = -1059


    Anhand der bestehenden Fehlermeldungen und Warnhinweisen beeinflusst zwar der ATH-PCI Treiber die Boot-Hänger,
    aber ich tippe eher auf :JFFS2 summary.o.preproc
    memory leak - leaving function without releasing memory
    in Kombination mit


    memory leak in apply_r_mips_lo16_rel module.c
    Aber das sind nur Vermutungen.
    Vielleicht helfen die Logs.
    mfg.
    freeman

  • scheinbar nicht, aber wenn freemann auch so wie ich vermutet habe bereits probleme hat die jffs2 summary sauber zu schreiben wäre es auch für Ihn einen Versucht wert.

  • Seit 5 Tagen ohne den WLAN-Treiber keine Boothänger mehr :)


    Ich denke so langsam kann man Bingo sagen.


    Imho macht es auch keinen Sinn alles durcheinander zu testen.


    Vor dem WLAN-Treiber hatte ich, wie Ghost schrieb, erstmal ohne USB-Gedöse getestet, jetzt


    wie schon geschrieben mit USB und ohne WLAN keine Hänger.

  • auch hier keine Hänger seitdem ich die WLAN-Treiber nicht mehr lade.
    Allerdings kam es bei mir nur relativ selten vor....manchmal erst nach 2 Wochen...

  • Ohne WLan-Treiber auch bei mir offenbar kein Problem mehr bei booten. Ich habe jetzt nur manchmal das Problem, dass die Box manchmal nicht runterfährt (Timer 01:00 -> Umschalten -> deep standby) sondern mit Spinner hängen bleibt.