• Hallo,


    habe im alten Board ein Thema bezüglich Cifs Mount gefunden, habe alles geanuso gemacht wie es dort beschrieben wurde, nur funktioniert das bei mir nich.


    also, in dem freigabe Menü unter Netzwerk/Kommunikation habe ich folgende Einstellungen:


    1) Ip: 192.168.1.1 <--- Ip meines Rechners (Cifs)
    2) Dir: e:/
    3) LocalDir: Eigene Musik/mnt
    4) Options: rw
    5) Extra: nolock.rsize=8192.wsize=8192


    \___\ will meine mp3's über den Rechner abspielen
    /


    kann mir jemand helfen?


    Dennisbert

  • hi floh,


    also, ich habe bei mir im Rechner ne 2. Festplatte eingebaut auf der die mp3's sind, die Festplatte heißt "Lokaler Datenträger E:/". Habe die gesamte Festplatte freigegeben!

  • Vielleicht kannst du mal versuchen,


    2) Dir: e:/


    Die Platte als mp3 freizugeben


    Dann würde das so aussehen.


    2) Dir: mp3



    Ich könnte mir vorstellen, dass der '/' am ende Probleme macht

  • Quote

    3) LocalDir: Eigene Musik/mnt


    Ist das richtig? Meinst du vielleicht /mnt/Eigene Musik?


    Wobei ich vom Leerzeichen abraten würde... Hast Du das Verzeichnis auf der Dream auch angelegt?

  • Um das nochmal zusammenzufassen:


    Quote

    1) Ip: 192.168.1.1 <--- Ip meines Rechners (Cifs)
    2) Dir: e:/
    3) LocalDir: Eigene Musik/mnt
    4) Options: rw
    5) Extra: nolock.rsize=8192.wsize=8192


    1) Ip des Rechners sollte ja OK sein, Methode CIFS auswählen
    2) Da muss nur e stehen, ohne :/ usw, dies gilt auch bei freigegebenen Ordenern: Freigabeordner in Windows ist z.B e:/dreambox, dann sollte unter 2) nur 'dreambox' stehen, nicht e:/dreambox!!
    3) man sollte im Verzeichnis /mnt erst einmal ein Unterverzeichniss musik erzeugen, dann also /mnt/musik, dies kann man per FTP machen oder auf der Box selber mit TuxBox Commander (Plugin, (auf mnt gehen, dann mit 7 "mkdir" und per Fernbedienung "musik" eintippen, dann OK))
    Der Eintrag unter 3) sollte dann so aussehen: /mnt/musik
    4) rw ist OK (read/write)
    5) kann als Default stehen bleiben


    ABER


    Nun kommen bei CIFS ja noch User und Passwort.
    Hier sollte der Benutzer eingetragen werden, der auch unter Windows benutzt wird. Am besten ist es einen neuen definierten Benutzer unter Windows anzulegen, also z.B: Benutzer: dream mit dem Passwort: dream
    Ich weiss nicht genau ob das im Mountmanager ganz ohne Pass geht??


    Sollte dann alles geklappt haben, also ein CIFS mount "'192.168.1.1/e /mnt/musik' OK!" kommen, kann man seine Dateien aus E im Dateimodus unter /root/mnt/musik sehen und auswählen.

  • Hallo,
    habe jetzt alles ausprobiert aber es kommt immer dieselbe Fehlermeldung:


    Cifs mount '192.168.1.1/e /mnt/Eigene Musik' FAILED


    bin langsam am verzweifeln, is vielleicht irgendwas mit meiner Dreambox nicht in ordnung?



    Dennisbert

  • Hallo ich habe es direkt über die Fernbedienung hinbekommen über das web Interface ging es einfach nicht


    In Zeile 2 Dir: gehört der Freigabename für das unter Windows Freigegebene Verzeichnis nicht der Pfad oder der Verzeichnisname


    Bei mir lautet der Pfad >> e:/box << und der Freigabename unter Windows >> box <<

  • hi,
    ich habe ja meine gesamte 2. Festplatte freigegeben unter dem namen "e"!!
    in Zeile 2 habe ich dann auch nur eingegeben "e" , sonst nichts!!!

  • ach habe vergessen dann musste unter var/mnt/ den ordner e anlegen auf der dream

    DM8000 OS-2.0 + Lüfter + HDD + DVD + DVB-T + RGB TFT Display
    DM520 S2 OS-2.5 = Aktiven USB hub / USB display
    Astra 19°, Hotbird 13°

  • Vielleicht liegt es ja an dem >> e << einen einzelnen Buchstaben ?


    Oder an einer Fierwall oder an deiner Windows Anmeldung


    Bei mir sehen die Verzeichnisse Pfade so aus
    e:/box/audio
    e:/box/Pic
    e:/box/video


    und auf der Dream var/mnt/box


    der Windows Freigabename für >> e:/box << lautet >> box <<

    DM8000 OS-2.0 + Lüfter + HDD + DVD + DVB-T + RGB TFT Display
    DM520 S2 OS-2.5 = Aktiven USB hub / USB display
    Astra 19°, Hotbird 13°

  • Freigaben mit nur einem Zeichen als Freigabenamen sind kein Problem, ich hab's grad mal ausprobiert - läuft ohne Probleme.


    Was aber nicht läuft, ist der Zufriff auf eine Freigabe mit "jeder" oder ein Benutzer ohne Kennwort. Auch das hab ich grad mal durchprobiert.


    Ich würde ohnehin keine ganze Platte freigeben, sondern nur Verzeichnisse. Also z.B. "Video" für die Filme und "MP3" für die MP3s. Auch würd ich mir für die Dreambox dann halt einen neuen Benutzer anlegen, z.B. "Dream" und das Kennwort der einfachheithalber (vor allem erstmal zum Testen) ebenfalls "Dream" und diesen neuen Benutzer dann in die Freigabe mit den Rechten "Lesen".


    Dir: Dream
    LocalDir: /var/mnt/video
    LocalDir: /var/mnt/mp3 ("video" und "mp3" müssen natürlich erst angelegt werden, z.B. per FTP)


    Options: leer
    Extra: default-Werte einfach mal stehen lassen
    User: Dream
    Pass: Dream
    Automount markieren


    Dann Speichern und mount.


    Dann sollte eigentlich der Status OK ausgegeben werden.


    Nochwas zum LocalDir: "/var" muss nicht zwingend davor stehen, es reicht auch z.B. "/mnt/video". "mnt" im root directory ist ein link.


    Wenn nicht Status OK kommt, liegt das meistens am falschen User/pass oder 'nem falschen (nicht angelegten) mount point.


    Mal ne grundsätzliche Frage: kommst Du denn überhaupt vom PC aus auf die Dream? z.B. WEBif?


    tussi4711

  • Hallo,


    ich glaube ich weiß jetzt woran es liegt, dass das cifs-mounte immer fehlschlägt. Und zwar liegt es an meiner anti-virensoftware, habe nämlich mal die Festplatte in meinem rechner neu formatiert und sofort, als noch keine Viren-software installiert war ausprobiert, "cifs-mount--> ok" funktioniert wunderbar, doch sobald ich die viren-software wieder drauf hatte, konnte er keine verbindung herstellen. Ich benutze zurzeit Kaspersky, habe auch schon mal versucht mit der dreambox zu verbinden als alle sicherungsprogramme von Kaspersky abgestellt war, hat jedoch auch nicht funktioniert! kann mir jemand sagen wie ich das einzustellen habe bzw, was ich änmdern muss?


    Dennisbert


    ps: danke nochmal für alle Antworten!! :]