Dauer Spinner nach Kanalwechsel --- mit journalctl enigma2.log

  • hi devs


    hab jetzt auch mal einen spinner mit log, ist zwar nur eine mit journalctl -b 0 aber evtl. sieht man ja was :)


    konnt per telnet auf die box , aber systemtl stop enigma2 dauerte sehr sehr lange und bei e2 start hängt er jetzt :(



    gruss

  • Hmm das waren noch nicht die aktuellen Treiber.. oder?


    Also zumindest sieht es laut dem Log so aus.


    Schau mal bitte auf der Box mit dpkg --list | grep dreambox-dvb-modules welcher Stand da ausgegeben wird.


    Aktuell ist 20180425-dm920 .. da habe ich eigentlich genau diesen Fehler behoben.


    Ist das der Stable oder der Unstable Feed den du verwendest? Auf dem Stable liegt noch ein älterer Stand.


    cu

  • Ghost : bei mir im log ist genau dieser Fehler auch ersichtlich (allerdings einige Zeit bevor ich den Fehler dann effektiv hatte). Ich hab die neusten Treiber drauf. Tuner Si2169C (DVB-T2 / DVB-C) und Si2166D (DVB-S2)

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • hi ghost


    ist das aktuelle update vom unstable


    root@dm920:~# dpkg --list | grep dreambox-dvb-modules
    ii dreambox-dvb-modules 3.14-1.17-dm920-20180 425-r0.0 armhf Hardware drivers for Dreambox
    ii dreambox-dvb-modules-lcd 3.14-1.17-dm920-20180 425-r0.0 armhf Hardware drivers for Dreambox
    ii dreambox-dvb-modules-stb-core 3.14-1.17-dm920-20180 425-r0.0 armhf Hardware drivers for Dreambox
    ii dreambox-dvb-modules-systemd 1.0-r0.4 all Hardware drivers for Dreambox - udev rules for systemd



    gruss

  • Dude7: hmm also als schnellen Workaround könntest Du mal das Puffern im Hintergrund im Teletext abschalten.


    Da gibts irgendwo ein Problem wenn der Teletext Daemon und enigma2 zur selben Zeit etwas am demux machen.


    Ich schau mir das aber an und fixe es dann im Treiber.


    cu

  • Dude7 :


    Ich finde das total komisch, dass e2 da den Tuner 1 verwendet.. und nicht den Tuner 0... und demux1 anstatt demux0 ...


    Ich wüsste gar nicht wie man das schafft wenn parallel keine Aufnahme läuft.. aber laut Logfile lief da eigentlich keine.


    Abgesehen davon habe ich das Gefühl, dass der eigentliche Fehler noch vorher im Log entstanden sein muss.


    Leider geht das Log nicht so weit zurück.


    Was man in dem Logfile aber auch noch sieht, ist dass nach dem e2 starten .. also weiss nicht ob du da nur irgendwie e2 gekillt hast... da ein Tuner Kanal vom FBC Tuner nicht zu öffnen war.. da kam ein EBUSY zurück.


    Vermutlich müsstest du da eher rebooten.


    Alles sehr merkwürdig.


    cu

  • Hi,


    @Ghost
    das mit dem Tuner 1 habe ich hier auch schon beobachtet. Ich schicke die Box auf sagen wir mal ZDFinfo in den Standby. Es ist eine Aufnahme auf einem anderen Kanal programmiert und die Box geht in den Idle.
    Jetzt schalte ich die Box ein und in der Infobar wird bei der Tuneranzeige das erste Kästchen gelb angezeigt und das zweite grün.
    Wenn die Aufnahme beendet ist kann ich umstellen bis ich schwarz werde es wird weiterhin nur das zweite Kästchen in grün angezeigt. Erst wenn ich die Box, 920er mit 2xFBC Tuner, die neuen mit Stream, komplett neu starte wird wieder das erste Kästchen der Tuneranzeige verwendet.

    MfG
    latte