Kurze Aussetzer bei Widergabe von einer internen HDD

  • Habe jetzt das neuste unstable frisch aufgesetzt. Leider schon bei der ersten 60 minütigen Aufnahme wieder einer dieser komischen Aussetzer.
    War noch eine Aufnahme von vor 2 Wochen, ich müsste nochmal mit neuen Aufnahmen testen.

    ---
    ...it`s a dream...
    ---

  • hmmm... Verständnisfrage von mir: Sind die Aussetzer in der Aufnahme oder der Wiedergabe? Wenn die Fehler bereits in der Aufnahme sind (das würde ich jetzt mal so erwarten), dann hilft es natürlich nichts, mit alten Aufnahmen zu testen, die haben den Fehler ja schon. Sind es nur Wiedergabefehler, dann müsste der Fehler ja auch für bestehende Aufnahmen gefixt sein...

  • Beim bereits behobenen Problem kamen die Fehler immer erst beim Abspielen. Das merkt man am schnellsten daran, dass die Ruckler immer an einer anderen Stelle in der Aufnahme waren.


    Wenn jetzt die Fehler in der Aufnahme sind, kann das ganz viele Ursachen haben. In den meisten Fällen sind Probleme mit Empfang oder Entschlüsselung an Fehlern in der Aufnahme schuld. Um dem gezielt auf den Grund gehen zu können, sollte @AD1 am Besten mal einen eigenen Thread mit ausreichend Infos (welche Box, welche Software, wie konfiguriert, welches Aufnahmemedium, wie und wo treten die Fehler auf, welche Sender sind primär betroffen, etc.) eröffnen. Das bringt ja nix, wenn hier jetzt komplett unterschiedliche Fehler verschiedenster User gemeinsam behandelt werden.

    so long
    m0rphU

  • Hallo!
    Nun poste ich hier auch mal:
    Ich habe auch diese besagten Ruckler in der Aufnahme.


    Tritt auf bei Wiedergabe von lokaler HDD in der 900er, und ebenso bei Wiedergabe von NFS auf.


    Aufnahme selber ist 100% fehlerfrei (geprüft mit TS-Doctor und einem Tool von Ghost...)


    Hab von Ghost einen neuen Tipp gekommen was zu probieren, bis jetz schauts erstmal gut aus (kann Zufall sein....)
    Mal sehen wie sich das entwickelt...


    mfg hk2k2

    Meine Dreamboxen:
    DM920 (1xSi21662D Dual DVB-S2X-MS + 1x 21692D Combo S2X-MS/C/T2)
    DM900 (1xSi21662B Dual DVB-S2)
    DM8000 (1xBCM4501 Dual DVB-S2 intern + 1x CU1216 DVB-C + 1xTU1216 DVB-T)
    DM800SE (BCM4505 DVB-S2)
    2x DM500HD (DVB-S2)

    DM800HD (BCM4505 DVB-S2)

    Leichen etc:

    DM5620S
    3x DM7020S
    DM600S

    .....

  • Nein, kein neues Thema,
    habe schon das richtige Problem. Habe ich früher auch schon gepostet.


    Wollte nur noch mal sicher gehen das es nicht doch mit der Aufnahme zu tun hat. Hat es aber nicht.



    Den Tip vom Ghost hätte ich auch gerne ;-)

    ---
    ...it`s a dream...
    ---

  • Der Tip.. bzw.. eher ist es ein Versuch ohne Garantie, dass es was hilft..


    Die Datei /usr/lib/libpagecache.so entfernen.. oder umbenennen. Oder aber alternativ in der Textdatei /usr/bin/enigma2-environment das $((512*1024)) in $((0*1024)) ändern.


    Bei beiden muss danach e2 neu gestartet werden oder besser mal rebooten.


    Und dann mal eine Weile testen. Und ggf. hier berichten, ob sich irgendwas geändert hat.


    Beides wird bei einem enigma2 update automatisch rückgängig gemacht.


    cya

  • Ok, Datei umbenannt, nachher testen.


    edit:...Test läuft, gucke Aufnahme.


    edit2: nach einer Stunde noch keine Auffälligkeiten. ...teste weiter...


    edit3: nach 2 Sunden immer noch alles ok. Teste morgen weiter.

    ---
    ...it`s a dream...
    ---

    Edited 3 times, last by AD1 ().

  • Bin wohl doch nicht der einzige. Aber ein paar Superschlaue wissen immer alles besser.
    An alle wo das Problem haben,benutzt ihr EMC ? habt ihr aktive Netzwerkmounts ?
    Ich habe Gestern in fast 4 Stunden keinen Fehler gehabt,kann natürlich auch Zufall sein.
    ( ohne EMC und Netzwerkmounts)


    Ich habe jetzt mal die libpagecache.so gelöscht mal sehen was passiert.

    Edited once, last by beno80 ().

  • Kein emc, keine Netzwerkmounts.
    Heut abend mal weiter testen, gestern ohne libpagecache.so keine Vorkommnisse.


    ...dann hoffen wir mal das beste.

    ---
    ...it`s a dream...
    ---

  • ja bitte, weil wir können es vor Anspannung kaum mehr aushalten X/

  • Es wäre toll, wenn beno80 das auch mal ausprobiert mit der libpagecache.


    Die libpagecache braucht man auf der dm900 denke ich eh nicht.


    Diese ist ein überbleibsel von den alten Boxen mit wenig RAM.


    Das Problem ist, dass Linux Standardmässig den gesammten RAM als I/O Cache verwendet.
    Und wenn der RAM dann voll ist, aber irgendein Prozess RAM anfordert, dann muss der Kernel alte Daten aus dem Cache entfernen, um
    den angeforderten RAM liefern zu können. Die Prozesse die den RAM angefordert haben müssen dann ggf. warten.
    Dieses war bei den alten Boxen mit wenig RAM ein Problem. Irgendwie kann Linux mit wenig RAM nicht gut umgehen. Das ganze umgeht
    die libpagecache dadurch, dass sie RAM der nicht mehr benötigt wird früher wieder freigibt.


    Wie dem auch sei, dass sollte und darf auf einer Box mit 1GB freiem RAM für den Linux Kernel kein Problem darstellen.
    Abgesehen davon, dass die CPU und der RAM bei der DM900 auch deutlich schneller sind, als bei den alten Boxen.
    Die CPU hat eh die meiste Zeit nichts zu tun.


    cya

  • Habe ich gemacht steht in # 190 ich werde jetzt mal alles Aufnehmen und zeitversetzt anschauen.