Unable to load a new image

  • Hi, I apologise that I don't speak german. I installed a bootlogo and bootlogo wait onto my dm920 ,(both MVI file type) and when I went to activate them my box restarted and went into recovery mode. I can only assume that the files were wrong or corrupt. Now I am unable to load a new image. What comes up when I try to load it is (fatal: target device '/dev/mmcblk0p2' is not writable ). Is there a way to fix this by me / Is it a hardware problem that can be fixed by sending it to Dreambox or is the box unrepairable?


    Thanks in advance ;(

  • Thanks Renard, but my box doesn't boot up anymore , it goes straight to recovery mode so I can't check or delete any files that may be the problem . Telnet connects but FTP doesn't . I don't know any other methods I can do that. The problem is my box won't load the image and I can't load a new one. thanks again

  • I would be grateful if any member of the dreambox team can advise me on this problem . I have a 7020hd which I've had for 6 or more years and it's indestructable, but I hope that this is the case for my DM 920 too

  • here is a other Way for recovery from newnigma2 Board. tanks gorgone


    PS: post a full bootlog for more Details ....

  • Hi Hilfsbereit,


    here is the log from telnet

    Link encap:Ethernet HWaddr 00:09:34:48:B0:4E

    inet addr:192.168.1.116 Bcast:192.168.1.255 Mask:255.255.255.0

    inet6 addr: fe80::209:34ff:fe48:b04e%lo/64 Scope:Link

    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

    RX packets:491 errors:0 dropped:0 overruns:0 frame:0

    TX packets:148 errors:0 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:1000

    RX bytes:34340 (33.5 KiB) TX bytes:16588 (16.1 KiB)


    Link encap:Local Loopback

    inet addr:127.0.0.1 Mask:255.0.0.0

    inet6 addr: ::1%1/128 Scope:Host

    UP LOOPBACK RUNNING MTU:65536 Metric:1

    RX packets:0 errors:0 dropped:0 overruns:0 frame:0

    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:0

    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

  • Hi , I downloaded VCP and did what it said , but no port was visible. I also tried the telnet method and this is a copy of the telnet window

    root@dm920:~# journalctl -fu enigma2

    -bash: journalctl: not found

    root@dm920:~# journalctl -f -u enigma2 > /tmp/enigma2.log

    -bash: journalctl: not found

    root@dm920:~#

  • As you can see from my previous post whenever I send certain commands by telnet , it comes up -bash (*****) not found. so trying to get a log isn't easy. It does however respond to dmesg and here is where in that message there seem to be errors [ 0.586097] Warning: unable to open an initial console.
    [ 0.646988] mmc1: BKOPS_EN bit is not set
    [ 0.653567] mmc1: new high speed MMC card at address 0001
    [ 0.653867] mmcblk0: mmc1:0001 8GME4R 7.28 GiB
    [ 0.653993] mmcblk0boot0: mmc1:0001 8GME4R partition 1 4.00 MiB
    [ 0.654110] mmcblk0boot1: mmc1:0001 8GME4R partition 2 4.00 MiB
    [ 0.654249] mmcblk0rpmb: mmc1:0001 8GME4R partition 3 512 KiB
    [ 0.655471] mmcblk0: unknown partition table
    [ 0.656505] mmcblk0boot1: unknown partition table
    [ 0.657158] mmcblk0boot0: unknown partition table
    [ 0.683827] systemd-udevd[95]: starting version 230
    [ 0.685874] random: systemd-udevd: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.686380] random: systemd-udevd: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.686440] random: systemd-udevd: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.686500] random: systemd-udevd: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.695979] random: udevadm: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.696153] random: udevadm: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.696188] random: udevadm: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.696438] random: udevadm: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.697125] random: udevadm: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.697423] random: udevadm: uninitialized urandom read (16 bytes read, 27 bits of entropy available)
    [ 0.853129] systemd-udevd[118]: failed to execute '/lib/systemd/systemd-sysctl' '/lib/systemd/systemd-sysctl --prefix=/net/ipv4/conf/eth0 --prefix=/net/ipv4/neigh/eth0 --prefix=/net/ipv6/conf/eth0 --prefix=/net/ipv6/neigh/eth0': No such file or directory
    [ 0.856616] systemd-udevd[102]: Process '/lib/systemd/systemd-sysctl --prefix=/net/ipv4/conf/eth0 --prefix=/net/ipv4/neigh/eth0 --prefix=/net/ipv6/conf/eth0 --prefix=/net/ipv6/neigh/eth0' failed with exit code 2.
    [ 0.892680] systemd-udevd[119]: failed to execute '/lib/systemd/systemd-vconsole-setup' '/lib/systemd/systemd-vconsole-setup': No such file or directory
    [ 0.893079] systemd-udevd[101]: Process '/lib/systemd/systemd-vconsole-setup' failed with exit code 2.
    [ 0.909157] bcmdriver: module license 'Proprietary' taints kernel.
    [ 0.909167] Disabling lock debugging due to kernel taint
    [ 0.909593] BCMDRV: Initializing bcmdriver version $ 8
    [ 0.909601] BCMDRV: Total intc words=4,Total Irqs=129
    [ 0.910388] BCMDRV: Initialization complete
    [ 1.273218] f0b00000.etherne:01: Broadcom BCM7439 (2) PHY revision: 0x10, patch: 1
    [ 1.274891] f0b00000.ethernet: configuring instance for internal PHY
    [ 1.274960] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 3.277327] libphy: f0b00000.etherne:01 - Link is Down
    [ 4.144897] libphy: f0b00000.etherne:01 - Link is Up - 1000/Full
    [ 4.144919] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 15.897558] random: nonblocking pool is initialized
    root@dm920:~#


    Also something has changed in telnet when I link to the box it comes up now as


    opendreambox 2.5.0 dm 920

    >>> your dreambox has booted into RESCUE MODE.

    >>>Please log in as user 'root' (no password is required)

    >>>then run 'help' to get further information.



    I was running the pure2 image when in crashed and tried online recovery with a opendreambox 2.5.0 image just before writing this post so it's strange as telnet is recognising it as opendreambox as it says this below when trying to load it.


    Code
    1. [*] Downloading 'http://dreamboxupdate.com/download/recovery/dm920/release/recovery.sig'
    2. [*] Downloading 'http://dreamboxupdate.com/download/recovery/dm920/release/recovery'
    3. [*] Verifying signature of 'recovery'
    4. gpgv: Signature made Mon Dec 11 21:41:43 2017 UTC using RSA key ID B3C5B1A3
    5. gpgv: Good signature from "Dreambox DM920 Recovery <dm920@recovery.dreambox.de>"
    6. [*] Running './recovery'
    7. [*] Options '-v'
    8. Fatal: Target device '/dev/mmcblk0p2' is not writable
    9. Fatal: Failed to execute './recovery'

    Anyway I sent the commands that I got from the 'Help, notification on telnet and the first line came up with bash not found but not with the other three lines.


    root@dm920:~# . : [ [[ alias bg break cd chdir continue echo eval exec exit
                                                                                  
    -bash: .: :: not found
    root@dm920:~# export false fg getopts hash help history jobs kill let local
                                                                                  
    root@dm920:~# printf pwd read readonly return set shift source test times trap
                                                                                  
    pwdroot@dm920:~# true type ulimit umask unalias unset wait



    please help :(