Posts by ni_hao

    und auch hier funktioniert es auf meiner dm920



    gutemine : Ich denke jetzt, wo OoZooN nicht (mehr) zu erreichen ist, hast du nach einem anderen Weg gesucht, um deine Plugins auf dem neuesten Stand an zu bieten. Aber wird es da im Zukunft auch eine Verlaufsdatei (history file) in jedem Plugin geben, denn sonst weißt man nicht was sich geändert hat.

    Danke. Ich bin Stunden damit beschäftigt gewesen und denke ich habe (fast) alles versucht, aber leider. Komische ist: wenn ich auf der FS bei Digitales Ausgabe Format "Mehrkanal (bypass) " wähle, sind NetFlix, YouTube usw. ist alles i.O. aberr wenn ich die dm 920 nutze ist der Ton verzögert.

    Seit kurzem habe ich einen Philips OLED TV gekauft, aber der Ton ist (überall) verzögert. Abgesehen von meinem Fernseher hat sich an der Hardware usw. nichts geändert d.h.


    dm920 => hdmi Kabel => FS

    FS => digital audio Kabel => Sonos Playbase und Sonos Lautsprecher. (Auf Sonos ist nirgendwo Verzögerung eingestellt worden)


    Mit dem vorherigen FS hat alles (mit der gleichen Konfiguration) gut funktioniert.


    Mit AC3 Ton ist die Verzögerung > 1 Sekunde

    Mit MPEG Ton ist die Verzögerung genau 1 Sekunde und habe ich auf der dm920 mittels Audio LipSync (Audio Taste - Blau) gut gekriegt (-1000ms). Aber ich denke,daß ist nicht die Lösung.


    Im FS habe ich:


    Ton => Erweitert => Audio Ausgang => HDMI Sound System

    Ton => Erweitert => Digitales Ausgabe Format => Mehrkanal (bypass) (wenn ich diese auf Stereo (unkomprimiert) stelle habe ich kein 5-1 mehr)


    Auf der dm920 habe ich im Menu bei Audio die Standartwerte, d.h. AC3 verzögerung 0 ms und PCM verzögerung 1000. Mit anderen Einstellungen hier merke ich (auch nach E2 neustart) keinen Unterschied.


    Was könnte ich versuchen um es i.O. zu kriegen?

    ah danke, aber habe es jetzt mittels ein Skript getan:

    Shell-Script
    1. #!/bin/sh
    2. f="/usr/lib/enigma2/python/Screens/InfoBarGenerics.py"; str="if len(self.field) >="; [ ! -f ${f} ] && exit
    3. grep -q "${str} 4:" ${f}; [ $? -eq 0 ] && sed -i "s/${str} 4:/${str} 5:/g" "$f"

    Im NameZap plugin sind (falls verwendet) die Kanalnummer max. 3-Stellig. Ist es möglich die max. 4 (oder 5) stellig zu machen oder gibt es da eine einfache Lösung pro gebraucher?

    D.h. wenn man zu Kanal 1000 zapt, sieht man nur 100 (statt 1000) auf dem Schirm

    i already found the solution to edit the bouquet its needed to stop enigma 2 with init 4 that was all.

    No it is not necessary to restart enigma2 on your box; you can also reload your settinglist (after editting/uploading your userbouquet file) by entering in a telnet/ssh session:

    wget -qO - "http://127.0.0.1/web/servicelistreload?mode=2"

    Without any details it is hard to give an answer which should lead to a solution.

    Probably there went something wrong during conversion. Please post the part of the appr. userbouquet-file (in /etc/enigma2), so with the lines of a Sender which give you that message.

    in der keymap.xml gibt es folgende tastenzuordnung:

    Code
    1. <map context="GlobalActions">
    2. <key id="KEY_MUTE" mapto="volumeMute" flags="mr" />


    In einem Plugin habe ich als code:

    Code
    1. self["GlobalActions"] = HelpableActionMap(self, "GlobalActions",
    2. {
    3.     "volumeMute": self.volumeMute, _("Audio on/off")),
    4. }, -1)


    Wenn ich dann im HelpScreen zur Mute-Taste gehe, kriege ich GS


    In der crashlog steht u.a.:


    Gibt es im Help-Screen keine Anzeige für die Mute-Taste ? Und wenn nicht, warum nicht denn für zb. die Tasten TV und Radio funktioniert es doch auch...?


    Habe es jetzt so abgefangen:

    Code
    1. self["GlobalActions"] = HelpableActionMap(self, "GlobalActions",
    2. {
    3. "volumeMute": self.ToggleMute,
    4. }, -1)
    5. def ToggleMute(self):
    6. self.volctrl = eDVBVolumecontrol.getInstance()
    7. vol = self.volctrl.getVolume()
    8. if vol:
    9. self.volctrl.volumeToggleMute()


    Dann funktioniert zwar die Mute-Taste, aber es ist dann ja immer noch nicht sichtbar im HelpScreen.

    Sven H

    Ja weil eben die HW die Lautstärke bei der Box regelt, da kannst im Alsa einstellen was du willst ;)

    Klar man kann für die Alsa-Wiedergabe die Lautstärke regulieren, aber wenn man die TV-Lautstärke mutet oder auf nahe 0 stellt dann ist halt alles stumm.

    In der Tat: ich habe es versucht auf der 920, aber auch beim starten von dem Stream funktioniert es leider nicht. Also hat Alsa volume kein Einfluss auf der Box.

    es gibt beim playbin doch parameter "volume". Werte dachte ich von 1-10. Also kannst du eine Taste dafür nemen um den Parameter"volume" hinzuzufügen
    also wenn du zb hast: cmd_audio = 'gst-launch-1.0 playbin uri=' + url1 + ' audio-sink="alsasink" flags=0x32'

    dann bei der Taste: cmd_audio+=' volume=1.0'

    vergiß bevor volume das Leerzeichen nicht ;)