Posts by Sendeschluss

    Hallo Bernard,


    ich bin erst jetzt wieder im Forum und sah Du hattest Leider keine Replies auf Deine Frage.
    Sollte es noch relevant sein, probier doch bitte mal /Public anstatt /Public/Fotos zu mounten.


    Wenn ich die Seagate Einstellungen richtig verstanden habe, hast Du /Public exportiert möchtest
    jedoch /Public/Fotos importieren bzw. mounten.


    Bin mir nicht sicher, ob das Seagate das zulässt (zum einen) und ob die Berechtigungen des Folders Foto
    in Ordnung sind.


    Also erst mal /Public mounten und dann weitersehen


    Grüsse
    Sendeschluss

    Wird die IP Adresse auch im Display an der Box beim Booten falsch angezeigt? Sollte nicht so sein. IMHO sollte ein Interface eine DHCP Adresse eh nur bedingt anzeigen, da je nach DHP Server Einstellungen (z.B. Lease-Time) die durch DHCP bezogene Adresse sich durchaus ziemlich schnell ändern kann.

    Ich bin gerade wegen der Möglichkeit mehere Images zu verwenden (Barry Allen) auf ein Ozzon-Image umgestiegen und der VNCPlayer läuft jetzt wieder wie gewohnt. Nachdem ich ein Multi-Boot Setup eingerichtet habe, werde ich in einem andreren Image auch gerne Deinen Patch testen (zwecks Infoaustausch).


    Herzlichen Dank schon jetzt für die tolle Informationen und Hilfe!

    Quote

    Original von Homey
    Ist es ein Release-Image von dreamboxupdate?


    Ja es geht (ausnahmsweise) mal um ein stable image. Hatte jetzt nicht
    erwartet, dass das stable image nach einer Menge von experimental-releases nicht
    auf diesen aufbaut (oder genauer nicht einem freigegbenen davon entspricht).



    Ja, danke für den Tipp. Hat bei mir zumindest nicht funktioniert. Das Problem war ebenfalls die ältere Enigma2 Version der stable Images. Ich habe dann noch ein enigma2--plugin-extensions-vlcplayer_2.5cvsXXX (Nummer/Datum weiss ich nicht mehr) installiert und wurde beim Starten des vlc-player mit einem "Bluescreen" bestraft.


    Ich teste jetzt ein Ozzon_image. Dort scheint der vnc wieder (so wie ich es kannte) zu funktionieren also filelist und playlist.


    Der Test mit dem Ozzon_image Datei version beinhaltet: 200811021032 ist erfolgreich. Der vlc-player funktioniert in dieser Version wieder.

    Moeglichweise bin ich nach dem Update des DM800 Image mit den Plugins etwas durcheinandergekommen. Vor dem Update auf das Image version=0150200810250228 von dreamboxupdate hatte ich ein vlc plugin installiert und konnte mit dem auf meinem Linux Server laufenden VLC verbinden. Ich konnte dann zwischen einer Filelist und einer Playlist mit den Bouquet-Tasten wechseln.


    Nach dem Image-Update habe ich via Plugin-Browser/Plugin-Install den vlc-Player installiert
    Paket/Version: enigma2-plugin-extensions-vlcplayer (2.4cvs20080417-r0)


    Nun verhält sich dieser vlc-player aber anders als von mir erwartet: Er bietet nun einen Dateibrowser für den Server an aber keine Playlist mehr. Wenn ich eine Datei im mpeg2-Format auswähle kommt jedoch weder Bild noch Ton - nur ein schwarzer Bildschirm mit Enigma-Fortschrittsbalken, der auch weiterläuft.


    Auf meinem Linux-Server habe ich den vlc in der Version 0.8.6 installiert:
    VLC media player 0.8.6f Janus


    Der vlc läuft natürlich mit HTTP-Interface.


    Kann mir jemand helfen? Habe ich das falsche plugin installiert?

    Ich habe auf meiner DM800 das neue Image (version=0150200810250228 von www.dreamboxupdate.com) installiert und dann das MediaCenter v0.8.7 plugin. Nach Neustart von Enigma2 beomme ich beim Plugin-Browser die Fehlermeldung:


    "Einige Plugins sind nicht verfügbar: Extentions/MediaCenter (can not import Name InfoBarBase)."


    Was muss ich noch installieren?

    Nur zur Vollständigkeit des Themas/Threads - es gibt ja inzwischen eine Lösung
    für das Problem im Forum. Ich möchte nur Suchende auch von diesem Thread aus
    zur Lösung verweisen:


    Im Thread FAT / CIFS für die DM800 ? wird beschrieben, dass es im experimental Image 2.7 die Module gibt. Ebenso
    gibt es Module zum nachinstallieren für das 2.6er Image.

    Ich habe im Internet nach ipkg-build gesucht und bin fündig geworden. Da der Link ausserhalb des Forums ist, weiss ich nicht, ob ich Ihn hier posten darf (einige Artikel wurden moderiert, wenn URLs enthalten waren).


    ipkg-build ist ein shell script, welches das erstellen erleichtert. Man kann es jedoch
    auch einfach mit tar machen, muss dann aber selbst einiges beachten...


    ipkg-build packt in das gepackte-tar-Archiv (tgz) die Dateien debian-binary, data.tar.tgz und control.tar.gz ein.

    In einigen Threads geht es immer wieder um das mounten von USB-Sticks oder
    SD/CF/..-Karten in einem USB-Kartenleser. Ich mag Linux und schätze ext3. Jedoch
    meine Foto-Kamera nicht. Die mag halt nun mal fat32. Gibt es ein File System Modul
    für die DM800, das die fat Unterstützung mitbringt? Wäre super, dann könnte man die
    USB-Ports auch zum Bilder-Ansehen verwenden.


    Im Board habe ich für andere Boxen etwas von fat-Unterstützung gesehen, IMHO ging es aber um eine 7xxx-Box.


    Ich möchte NICHT das original Image durch ein xx-Image austasuschen, eher nur das original Image ergänzen.


    Gibt es eine Build-Umgebung, die auf dem normalen x386-Architektur-PC oder x86_64-Architektur-PC läuft und für die DM800 baut?

    Quote

    Original von znib

    Code
    The most likely problem is that a kernel module is missing from your installation, however the symptom is typically just the error Invalid argument from mount:
    # mount /dev/sda3 /mntmount: Mounting /dev/sda3 on /mnt failed: Invalid argument
    logread will normally give some clue as to the nature of the problem - for example in the above case /dev/sda3 was not a FAT partition:
    kernel: FAT: bogus number of reserved sectorskernel: VFS: Can't find a valid FAT filesystem on dev sda3.


    Scheint also, dass mount die Invalid argument Meldung auch bringt wenn er das Filesystem nicht kennt.....


    Letzteres ist auch genau, was ich befürchte. Er kennt das fat nicht.
    Gebe ich den mount-Befehl nur als "mount DEVICE MOUNTPOINT", bekomme ich den
    Invalid Argument fehler und in der Ausgabe von dmesg erscheint eine Fehlermeldung,
    die besagt, dass er keinen validen EXT3 superblock gefunden hat - er scheint also das
    fat-FS nicht zu erkennen und es mit ext3 zu versuchen (dieses FS steht ja auch in der /proc/filesystems).


    Versuche ich es mit "mount -t fat DEVICE MOUNTPOINT" geht es leider auch nicht, diesmal jedoch mit der Fehlermeldung "No such device".


    Interessant wäre, ob es ein fat/vfat/msdos (mir reicht 8+3 Namensunterstützung für die
    Kamara-SD-Cards) für unser original(!) Enigna2 Image gibt...


    Wie sieht es denn inzwischen auf Deiner Box aus? Device vorhanden, Mount von fat?

    Quote

    Original von znib


    Wie lautet denn dein genauer mount Befehl? Die Fehlermeldung tönt eher nach einem Vertipper bei den Argumenten.


    root@dm800:~# mount /dev/scsi/host0/bus0/target0/lun0/part1 /media/stick
    mount: Mounting /dev/scsi/host0/bus0/target0/lun0/part1 on /media/stick failed: Invalid argument


    Quote

    Kein Probelm, dann besteht ja noch Hoffnung, dass es bei mir auch noch klappt. :) Werde das heute Abend gleich mal ausprobieren.


    Falls der zweite modprobe (sd_mod) hängen sollte kannst Du notfalls den Stick abziehen
    und wieder aufstecken. War leider bei mir mal notwendig, Problem danach nicht wieder
    aufgetreten.


    Quote


    Ob ein Linux, dass FAT32 kann automatischa auch FAT16 kann weiss ich nicht, aber du solltes eigentlich auch eine kleine Karte FAT32 formatieren können. Ob das deine Kamera noch lesen kann ist dann die andere Frage. Allerdings erstaunt es mich schon, dass deine Karte FAT16 formatiert ist, FAT32 ist ja auch schon relativ alt und alle Kameras die ich so kenne verwenden das schon.


    Zumindest meldet fdisk ein fat16 (parttion type) - muss aber nicht stimmen (also nicht dem FS entsprechen).

    Quote

    Original von znib
    Hmm, bist du dir da sicher? Ich denke CIFS, bzw. NFS abstrahieren das darunter liegende Filesystem. Jedenfalls scheinen es hier im Forum ja einige Leute gschafft zu haben windows shares zu mounten, und da heute unter Windows meistens NTFS verwendet wird denke ich nicht, dass ein CIFS client das Filesystem des Servers kennen muss, denn NTFS kann die Dream ziemlich sicher nicht.
    Aber vielleicht könnte jemand, der es geschafft hat mal etwas dazu sagen?


    Ich habe mich unglücklich ausgedrückt. Natürlich abstrahieren NFS und CIFS das
    Filesystems des Servers. Jedoch sehe ich in der /proc/filesystems nur nfs und nfs4 und eben nicht cifs. Auf meinem LAPTOP habe ich nach einem "modprobe cifs" einen cifs-Eintrag in der /proc/filesystems. Auf der Box habe ich jedoch kein cifs.ko gefunden.
    Da die /proc/filesystems cifs nicht listet scheint es nicht unterstützt zu sein. Ich vermute die Kollegen, die das mounten können müssen ein cifs modul haben.


    Quote

    Doch doch, ich denke schon, dass das gehen sollte. Was ich hier im Forum gelesen habe muss man den Stick nur ext3 formatieren, wenn man davon booten will, sonst sollte FAT32 schon gehen.


    Bei mir funktioniert das Mounten des Sticks (mit fat/vfat) nicht! Ich bekomme die Fehlermeldung:
    "Invalid argument."


    Quote

    Also modprobe usb-storage geht bei mir auch, danach gibts dann das Verzeichnis /dev/scsi/ aber darin sind dann keine weiteren Unterverzeichnisse mehr.
    modprobe sd-mod gibt bei mir aber "modprobe: module sd-mod not found.
    modprobe: failed to load module sd-mod". Hast du dieses modul irgendwie nach installiert? Oder hast du nicht das Enigma2 image vom 11.5.2008?


    Ich verwende auch das Enigma2 image vom 11.5.2008.
    root@dm800:~# cat /etc/version
    200805111400


    Nur ein Typo meinerseits, entschuldigung !
    modeprobe sd_mod (nicht sd-mod)
    Kommt davon, wenn man auswendig die Befehle zitiert.
    BTW die vorhandenen Module kannst du mit
    find /lib/modules/2.6.12-5.1-brcmstb-dm800/ -name '*ko'
    ermitteln (ggf die Kernel-Version im Pfad anpassen).


    Quote

    Hmm, komisch. Wie gesagt, ich denke FAT32 sollte wirklich gehen, ich glaube ein einfaches mount /dev/scsi/host0/..../part1 /media/deinverzeichnis sollte schon reichen. Hast du etwa noch eine andere Partition als part1?
    Moment du sagtest "SDKarte"? Wo kannst du denn an der DM800 eine SD-Karte anschliessen? Via USB-Adapter?


    Die SD Karte habe ich in einem Mini-Kartenleser, der wiederum am USB hängt. Ist
    also technisch aus Sicht des OS nahezu(?) das gleiche wie ein USB-Stick.
    Nurd as mounten eines FAT16 will mir nicht gelingen. Liegt es am fat16 anstatt fat32? Kann ja mal eine grössere Karte verwenden ;-)

    Bei mir funktioniert das mit dem /dev/scsi/host0/.../part1 Device. Eigentlich hatte ich
    nichts verändert womöglich hatte ich mich beim modprobe sd_mod vertippt und es bei
    der Hitze nicht bemerkt. Es funkltioniert also bei mir auch wie schon so oft in diesem Forum
    beschrieben.


    Gibt es denn ein vfat oder msdos Modul für die DM800? Das wäre iMHO die Lösung für das Problem, dass Sicks erst "umformatiert" werden müssen.


    Ich schätze seit langem die Vorteile von ext3 (arbeite schon lange professionell mit Linux), aber ich konnte meine Kamera allerdings noch nciht überzeugen ext2|3 anstatt vfat zu nehmen ;-)


    Mit einem SD/USB-Adapter (aka Kartenleser) könnte man ggf direkt von SD-Karten lesen und Bilder ansehen.

    Also, damit ein Linux ein Device, CIFS, NFS oder so mounten kann, müsste es
    auch das Filesystem kennen. Die vom Kernel (mit den zzT geladenen Modulen) unterstützen Filesysteme kann man unter /proc/filesystems sehen. Dabei fällt bei meiner DM800 auf, dass weder VFAT (also das typische einfache Windows-FS) noch CIFS oder SAMBA unterstützt werden. Ich habe gestern zumindest keine Module zu diesen Filesystemen gefunden - scheint also schlüssig.


    Daher kommt der Mount-Fehler beim Mounten vom CIFS-Server (bei Dir der Windows-PC).


    Ebenso kommt daher, dass man nicht-ext3-formatierte Sticks nicht einfach mounten kann (Schade, weil es schön wäre mit einem SD-Adapter direkt von der Kamera-Karte die Bilder zu zeigen)...


    Quote


    So wie ich das verstanden habe sollte es doch ein /dev/scsi geben, das gibts aber bei mir nicht... Den Befehlt lsusb scheint die Dreambox nicht zu kennen, muss das so sein? Ich befürchte, dass ich noch irgendwas zusätzlich installieren muss, aber was?


    Das funktioniert jetzt bei mir (ohne Änderung), wenn ich
    modprobe usb-storage
    modprobe sd-mod
    eingebe. Keine Ahnung, warum es vorher nicht ging ich habe nichts (bewusst) verändert - vermutlich habe ich mich beim letzten mal als es nicht ging vertippt ;-) Wenn ich dann das /dev/scsi/host0/..../part1 Device habe, könnte ich auch mounten, jedoch ist das File-System auf der SDKarte ein vfat und dass will ich nicht ändern, sonst kommt die Kamera ja nicht mehr an die SD-Karte...

    Quote

    Original von znib
    Hallo!


    So wie ich das verstanden habe sollte es doch ein /dev/scsi geben, das gibts aber bei mir nicht... Den Befehlt lsusb scheint die Dreambox nicht zu kennen, muss das so sein? Ich befürchte, dass ich noch irgendwas zusätzlich installieren muss, aber was?


    Ich habe zumindest das gleiche Problem. Ich bin dran und werdem falls ich eine Lösung
    finde die Antwort posten...


    Quote


    Als nächstes hab ich mit mount -t cifs //192.168.0.2/marco /media/windows -o username=marco,password=meinpasswort probiert ein Windows share zu mounten... dabei kam aber immer eine Fehlermeldung, das device existiere nicht... die Freigabe existiert aber und die Firewall im Windows hab ich auch ausgeschaltet.


    Ist denn das Verzeichnis /media/windows vorhanden? Ich habe das mit dem SMB-Client (also Box als Client nicht als Server) noch nicht probiert. Allerdings hatte ich keine smbclient-Befehle gefunden. Kann die Box denn SMB/CIFS client?


    Quote


    Dann bin ich noch etwas verwirrt im Bezug auf fstab und automount... Habe ich es richtig verstanden, dass die Geräte in der fstab beim booten gemountet werden und die im config file von automount beim anstecken? Für den USB stick müsste ich also automount verwenden, richtig? Oder brauch ich den Eintrag in fstab auch? Und wie sieht es dann mit dem Windows share aus, die Windows kiste läuft ja auch nicht immer, also auch ins automount?


    Die fstab ist für "statische" mounts. Diese werden entweder beim Botten oder durch einen
    Nutzer (root oder anderer berechtigter Nutzer) aktiv gemounted bzw. unmounted. Die
    fstab kann dann auch für CIFS mounts schon alle wichtigen parameter enthalten, sodass man mit einem kurzen Befehl wie z.B. "mount /media/mywindows" einen CIFS mount durchführen kann, ohne die Adresse und die Parameter einzutippen.


    Die automount-Dateien sind für "dynamische" Mounts. Diese werden vom automounter
    durchgeführt, wenn man auf bestimmte Verzeichnisse zugreift.

    Ich habe meine DM800 noch nicht lange, habe also noch nicht
    sehr viel evaluiert, aber womöglich mounted die Box das File-System nicht,
    das auf dem Stick verwendet wird? Ich meine womöglich kann die Box nicht mit dem
    File-System umgehen (um genau zu sein). Sollte zwar normalerweise eine andere
    Fehlermeldung sein, aber wer weiss (einige Befehle geben ja auch etwas anderes (Format)
    aus, als ich das von meinem Linux gewohnt bin.


    Ich werde das heute Abend mal testen. Bei mir kommt trotz der modprobes noch nicht
    einaml etwas unter /dev/scsi :-(