Posts by emanuel

    Wann, one :D


    und wem's so lange langweilig ist und der noch eine dm9X0 rumliegen hat kann ja so lange das probieren:

    kodi_19.0+gitr0+10ac461b66-r0.0_armhf.deb (auf meinem kodi-18 feed) :thumbsup:

    So wie es aussieht kann nur die lib (v3d) der mipsel Boxen (VC4) das nicht. Wenn ich das surface löschen kracht es.


    An der HW (VC4) liegt's wohl auch ned, weil die Himbeere das auch kann.


    P.S. Ich kann das zwar patchen im kodi, aber schön wäre es schon, wenn Ihr das richtig implementiert/fixt, so dass es wie bei euren VC5 Maschinen geht.

    Ghost : Ich habe den Fehler gefunden und es liegt an e2 "eDBoxLCD.getInstance().lock(True)":



    so geht es wieder.


    Es ist 100% reproduzierbar in jeder eConsoleAppContainer() Anwendung, die eDBoxLCD.getInstance().lock(True) nutzt ist nach beenden die GUI weg.


    (getestet mit geminiterm)


    Bitte reparieren.


    LG Emanuel

    Mit dem Menu hat es wohl auch nix zu tun, weil es beim Ausführen über das pluginmenu auch passiert.


    ist wohl nur so, weil kodi mit dem EGL läuft? Geminiterm (fb Grafik) geht ganz normal.


    Aber nach kodi beenden geht ab dem neuen rel wohl das:



    Code
    1. ...
    2. def __runFinished(self,retval):
    3. print "[XBMCMediaCenter] - __runFinished"
    4. eDBoxLCD.getInstance().unlock()
    5. eDBoxLCD.getInstance().update()
    6. fbClass.getInstance().unlock()
    7. ...

    nicht mehr??


    Ich hänge das plugin hier mal an, kodi habt Ihr ja im oe.


    Bitte schaut mal warum kodi mit dem neuen e2 rel die GUI/Display der Box weghängt.


    Danke

    Ist aber nicht nur hier so wenn man kodi startet.


    Ist bei jedem.


    Ich hier hab ja kodi-18. Aber das geht auch mit kodi-17 so. Man beendet kodi, das TV Bild kommt wieder man kann noch mit <<, >> umschalten, aber die e2 GUI wird nicht mehr sichtbar und das Display hängt auch. Geht erst so ab dem neuen Enigma2 rel.


    Ich habe gerade den Gegentest mit einer anderen binär Anwendung (geminiterminal) gemacht aus dem Bluepanel (Menu) und da geht es ganz normal.


    Das ganze ist komischer Weise nur bei kodi??


    k.a. warum


    Aber der Fehler läßt sich leider sofort reproduzieren.


    Ich habe jetzt eventuell was anders in Verdacht. Es hat sich doch was im Menu geändert (Radio oben in dem neuem Rel.) und mein plugin macht da einen Eintrag und startet von da.


    Ich hack mal noch ein bisschen nach.


    Danke schon mal für die Antwort.

    root@dm7080:~# kodi

    20:37:05.005 T:1929302016 NOTICE: CDreamboxUtils::GetNativeResolution mode: 1080p
    20:37:05.005 T:1929302016 NOTICE: CDreamboxUtils::SetFramebufferResolution width: 1920 height: 1080
    20:37:05.008 T:1929302016 NOTICE: CDreamboxUtils::GetNativeResolution mode: 1080p
    20:37:05.009 T:1929302016 NOTICE: Found resolution 640 x 480 with 640 x 480i @ 60.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 720 x 576 with 720 x 576i @ 60.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1920 x 1080 with 1920 x 1080i @ 60.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1920 x 1080 with 1920 x 1080 @ 60.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1280 x 720 with 1280 x 720 @ 60.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 640 x 480 with 640 x 480 @ 60.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1920 x 1080 with 1920 x 1080i @ 50.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1920 x 1080 with 1920 x 1080 @ 24.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1920 x 1080 with 1920 x 1080 @ 25.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1920 x 1080 with 1920 x 1080 @ 30.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1920 x 1080 with 1920 x 1080 @ 50.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1280 x 720 with 1280 x 720 @ 24.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 1280 x 720 with 1280 x 720 @ 50.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 720 x 576 with 720 x 576 @ 60.000000 Hz
    20:37:05.009 T:1929302016 NOTICE: Found resolution 640 x 480 with 640 x 480 @ 60.000000 Hz
    20:37:05.010 T:1929302016 NOTICE: Found resolution 800 x 600 with 800 x 600 @ 60.000000 Hz
    20:37:05.010 T:1929302016 NOTICE: Found resolution 1024 x 768 with 1024 x 768 @ 60.000000 Hz
    20:37:05.010 T:1929302016 NOTICE: Found resolution 1366 x 768 with 1366 x 768 @ 60.000000 Hz
    20:37:05.010 T:1929302016 NOTICE: Found (1920x1080@60.000000) at 19, setting to RES_DESKTOP at 16
    20:37:05.022 T:1929302016 NOTICE: EGL_VERSION = 1.4
    20:37:05.023 T:1929302016 NOTICE: EGL_VENDOR = Broadcom
    20:37:05.023 T:1929302016 NOTICE: EGL_EXTENSIONS = EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_vg_parent_image EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_lock_surface EGL_KHR_fence_sync EGL_BRCM_image_update_control
    20:37:05.023 T:1929302016 NOTICE: EGL_CLIENT_EXTENSIONS = NULL
    20:37:05.023 T:1929302016 NOTICE: Checking resolution 16
    20:37:05.027 T:1929302016 NOTICE: GL_VENDOR = Broadcom
    20:37:05.027 T:1929302016 NOTICE: GL_RENDERER = VideoCore IV HW (V3D-435)
    20:37:05.027 T:1929302016 NOTICE: GL_VERSION = OpenGL ES 2.0
    20:37:05.027 T:1929302016 NOTICE: GL_SHADING_LANGUAGE_VERSION = OpenGL ES GLSL ES 1.00
    20:37:05.027 T:1929302016 NOTICE: GL_EXTENSIONS = GL_OES_compressed_ETC1_RGB8_texture GL_OES_compressed_paletted_texture GL_OES_texture_npot GL_OES_depth24 GL_OES_vertex_half_float GL_OES_EGL_image GL_EXT_discard_framebuffer GL_OES_rgb8_rgba8 GL_OES_depth32 GL_APPLE_rgb_422 GL_OES_packed_depth_stencil GL_EXT_debug_marker GL_EXT_multisampled_render_to_texture


    hier crasht das



    kann mir ein developer einen Hinweis geben durch welche gl Funktion das benutzt wird? Ich tappe da im dunkeln.
    Auf armhf geht das mit GLES3.

    Es fehlt das kernel modul rfkill, wenn man es dazubaut geht schon mal eine
    "Microsoft Wedge Mobile Keyboard" BT