Posts by dehpeh

    die fstab ist auch die bessere lösung. allerdings die leute, die eine anleitung
    für die swaperstellung brauchen, zerstören sich eventuell schnell die fstab und somit
    bootet die box nimmer richtig ;)

    Quote

    Original von Olove
    Was dazu führt, dass die Platte dauernd läuft ... ziemlich blöde eigentlich, oder?


    *zustimm*


    für die, die trotzdem (auf der festplatte als datei, nicht als partition) swappen wollen:


    einmalig 128mb swap-file erstellen:
    dd if=/dev/zero of=/hdd/swap bs=1M count=128


    einmalig die datei als swap-datei initalisieren:
    mkswap -v1 /hdd/swap


    swap erstmal manuell starten:
    /sbin/swapon /hdd/swap
    und mit dem befehl free überprüfen


    wenn soweit geklappt, muss der befehl noch irgendwo
    eingebaut werden, damit der swap nach jedem reboot aktiviert wird.
    dafür kann man in die datei /etc/init.d/finish (gibt evtl. einen besseren ort dafür?!) diese zeile einfügen:
    test -e /hdd/swap && /sbin/swapon /hdd/swap


    bye

    Hu,


    es geht mir auch *nicht* darum, dass PiP nicht funktioniert, sondern das es beim
    Aktivieren bei mir das gleiche Kernelproblem verursacht, wie sporadisch beim
    Starten der Box.


    Interessant für mich wäre nun zu wissen, ob bei Dir oder anderen mit dem CVS das
    gleiche (Kernel-)Problem entsteht, wenn PiP gestartet wird. Vielleicht kann man
    dann bessere Rückschlüsse auf das Startproblem ziehen.


    Probier es bitte mal aus! Danke.

    Schade, das aktuelle CVS hat doch nicht geholfen,
    Box soeben gestartet und Absturz/hängt wie gehabt...


    Edit: Dies passiert übrigens auch jedesmal, wenn ich (im aktuellen CVS) die Picture-in-Picture Funktion starte. Bild geht weg und ich kann nur noch per telnet/ssh drauf und mir das unten gepastete bei dmesg anschauen. Vielleicht kann man ja durch diese Reproduzierungsmöglichkeit etwas mehr debug-Infos bekommen? Wenn ja, wie? ;)




    Starten von Picture-in-Picture

    root@dreambox:~# init 2
    root@dreambox:~# enigma2
    ...snip...
    action -> InfobarExtensions extensions
    action -> WizardActions ok
    [eDVBCAService] free slot 0 demux 2 for service 1:0:1:2F1C:441:1:C00000:0:0:0:
    [eDVBCAService] free slot 1 demux 0 for service 1:0:1:2F1C:441:1:C00000:0:0:0:
    [eDVBCAService] free service 1:0:1:2F1C:441:1:C00000:0:0:0:
    start release channel timer
    VIDEO CHANGED (to ffffffff)
    STOP
    VIDEO_STOP
    position is now ...
    position is 500 100 -> 160 120
    failed to open /proc/stb/vmpeg/1/dst_left - No such file or directory
    use cached_channel
    stop release channel timer
    allocate Channel: res 0
    no version filtering
    0012: 4e 2f 1c 00 00 00
    mask: ff ff ff 00 00 00
    mode: 00 00 00 00 00 00
    ok ... now we start!!
    no version filtering
    0000: 00 00 00 00 00 00
    mask: ff 00 00 00 00 00
    mode: 00 00 00 00 00 00
    eventNewProgramInfo 0 0
    have 1 video stream(s) (00a7), and 1 audio stream(s) (0088), and the pcr pid is 00a7, and the text pid is 0047
    allocate demux
    VIDEO CHANGED (to 00a7)
    new video
    Video Device: /dev/dvb/adapter0/video1
    demux device: /dev/dvb/adapter0/demux0
    Segmentation fault
    root@dreambox:~#


    dmesg

    eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
    state is idle, denying.
    CPU 0 Unable to handle kernel paging request at virtual address 00000034, epc == c00b7c14, ra == c00b9428
    Oops in arch/mips/mm/fault.c::do_page_fault, line 166[#3]:
    Cpu 0
    $ 0 : 00000000 00400f90 c00b7c00 20000000
    $ 4 : 00000000 85284c40 20006f16 00000000
    $ 8 : 00000000 ffffffe7 20006f16 fffffff8
    $12 : 804c0000 0000081d 00000000 00000022
    $16 : c00da500 c00dc600 00000000 20006f16
    $20 : 00000001 00000000 8074cc04 85284c40
    $24 : 00000001 c00c0000
    $28 : 813f2000 813f3da8 1000d0d8 c00b9428
    Hi : 000002c9
    Lo : 00001c1d
    epc : c00b7c14 xilleon_clip_reset+0x14/0x124 [xilleon] Tainted: P
    ra : c00b9428 xilleon_dvb_video_ioctl+0x288/0x2ec [xilleon]
    Status: 1000f803 KERNEL EXL IE
    Cause : 30800008
    BadVA : 00000034
    PrId : 00018448
    Modules linked in: rfmod dreambox_rc2 fp lcd xilleon avs stb_proc cu1216mk3 tu1216 alps_bsbe1 stv0299 mb86a15
    Process showiframe (pid: 1585, threadinfo=813f2000, task=80559810)
    Stack : c00dc600 c00da500 00000000 20006f15 c00da500 c00dc600 00000000 c00b9428
    00000000 00000000 00001fff 81267d84 00000000 00000000 802d6a14 802d6a48
    813f3df0 2aac38f8 00000001 00000000 83cef2ac 00000000 00030000 2ac29f30
    80777280 81267d84 00000000 00000000 1000d0d8 8016997c 813f3ec0 80194c4c
    00000003 7f83cda9 815000a4 83cef2ac 80198c18 00000003 80559810 2ac29f30
    ...
    Call Trace:
    [<c00b9428>] xilleon_dvb_video_ioctl+0x288/0x2ec [xilleon]
    [<802d6a14>] dvb_usercopy+0x80/0x1cc
    [<802d6a48>] dvb_usercopy+0xb4/0x1cc
    [<8016997c>] handle_mm_fault+0x2a0/0x728
    [<80194c4c>] permission+0x78/0xb0
    [<80198c18>] may_open+0x5c/0x290
    [<80110e30>] do_page_fault+0x320/0x3a0
    [<80110d00>] do_page_fault+0x1f0/0x3a0
    [<802d6b88>] dvb_generic_ioctl+0x28/0x34
    [<8017d9cc>] filp_open+0x5c/0x74
    [<c00b91a0>] xilleon_dvb_video_ioctl+0x0/0x2ec [xilleon]
    [<8019df84>] do_ioctl+0x54/0x90
    [<8019e1c0>] vfs_ioctl+0x200/0x3a4
    [<8017db3c>] get_unused_fd+0x158/0x214
    [<80194978>] getname+0x28/0xf8
    [<8019e3b4>] sys_ioctl+0x50/0x9c
    [<8017dd2c>] sys_open+0xac/0xec
    [<8010f600>] stack_done+0x20/0x3c
    [<801072cc>] work_resched+0x8/0x40



    Code: afb00010 afbf001c afb10014 <8c850034> 8c910000 24120006 8ca2003c 00808021 1052001b
    state is idle, denying.
    lnbp initialized

    Quote

    Original von almoss
    2. Problem mit abgestürzten Timern.
    Es passiert immer wieder, dass ein Timer oder Sofortaufnahmeversuch Enigma2 zum Reboot bringt.
    Das passiert auch, wenn die Festplatte noch eingeschaltet ist, weil man z.B. gerade die Filmliste angefordert hat.


    Ah, noch ein "Record-Opfer" ;)
    Zum Absturzproblem beim Record starten schau mal hier:
    http://www.dream-multimedia-tv…php?threadid=929#post5707


    Hast du eventuell auch manchmal Probleme, dass die Box nicht richtig startet?

    Was ist das "letzte release image"?


    Ich hatte zuletzt das Original Image vom 22.02.2006 aufgespielt
    und regelmäßig die Dreamville-updates gemacht.


    MemTotal: 43844 kB
    MemFree: 1412 kB
    Buffers: 96 kB
    Cached: 15684 kB
    SwapCached: 0 kB
    Active: 25864 kB
    Inactive: 7864 kB
    HighTotal: 0 kB
    HighFree: 0 kB
    LowTotal: 43844 kB
    LowFree: 1412 kB
    SwapTotal: 0 kB
    SwapFree: 0 kB
    Dirty: 0 kB
    Writeback: 0 kB
    Mapped: 26812 kB
    Slab: 4352 kB
    CommitLimit: 21920 kB
    Committed_AS: 29252 kB
    PageTables: 356 kB
    VmallocTotal: 1048560 kB
    VmallocUsed: 2120 kB
    VmallocChunk: 1046356 kB


    (derzeit läuft die box normal)




    Edit, bzw. Vermutung:
    hm, soll das heissen, mir fehlt (warum auch immer) etwas RAM? ;)
    Das könnte ja vielleicht auch mein Recordproblem erklären, nach einem sauberen
    Reboot kann ich innerhalb kurzer Zeit problemlos Aufnehmen.
    Aber wenn die Box bereits etwas länger läuft wird dann wohl mehr RAM in Anspruch genommen, und dann kommts zum Absturz...(zum Thread) *grummel*

    Hallo,


    ich habe schon seit Januar einige Probleme mit dem Kaltstart/Reboot
    der Box. Ich mache die Box jede Nacht komplett stromlos (mit sauberen Herunterfahren
    natürlich). Leider passiert es sehr oft, so ziemlich alle zwei bis drei Tage, dass
    beim Start (oder auch beim Reboot) kein Senderbild kommt. Es ist kurz etwas
    vom Enigma zu sehen, aber dann war es das. Schwarzer Bildschirm & kein Ton.
    Die Bedienung ist zwar per Fernbedienung sehr träge möglich (mit 5 sekunden
    Verzögerung), aber es kommt kein Sender. Nach einem Reboot und Aus-&Einschalten
    startet Sie ohne Probleme.


    Ich halte die Box immer per Dreamville aktuell. Derzeit:
    Enigma v2.0-2006-03-24
    Frontprozessorversion 2


    Ist vielleicht sogar die Hardware kaputt?


    Anbei die Ausgabe von logread als Textdatei.


    Vielen dank für eure Mühen.

    Files

    • logread.txt

      (16.24 kB, downloaded 643 times, last: )
    Code
    1. Package base-files (3.0.14-r45) installed in root is up to date.
    2. Configuring gst-plugins-good
    3. //usr/lib/ipkg/info/gst-plugins-good.postinst: 14: gconftool-2: not found
    4. //usr/lib/ipkg/info/gst-plugins-good.postinst: 14: gconftool-2: not found
    5. postinst script returned status 127
    6. ERROR: gst-plugins-good.postinst returned 127
    7. Nothing to be done


    nanu, was ist nun kaputt? ;)
    (dies kommt mehrfach beim update)

    Oh sorry, ganz vergessen.


    Information, Über: Enigma2 2006-03-11
    /etc/version: 200602222223


    Das Problem besteht allerdings auch schon einige Zeit.
    Und da es sehr oft auftritt, hoffe ich, es kann schnell
    gefixt werden. Aber bin ich der einzigste mit dem Problem? ;)


    Danke.



    Edit:
    Habs Gerade nochmal probiert. Die Box war seit heute Mittag komplett aus
    und vor 10 Minuten angemacht. Record gestartet und Absturz.
    Eine erneute Aufnahme stürzt danach nicht mehr ab, bis ich die
    Box herunterfahre.


    Hier wieder die letzten Zeilen:


    starting recording..
    RECORD: have 1 video stream(s) (00ff), and 2 audio stream(s) (0100, 0101), and the pcr pid is 00ff, and the text pid is 0020
    ADD PID: 0064
    ADD PID: 0101
    [eDVBCAService] add demux 1 to slot 2 service 1:0:1:382:21:85:C00000:0:0:0:
    [eDVBCIInterfaces] addPMTHandler 1:0:1:382:21:85:C00000:0:0:0:
    [eDVBCIInterfaces] gotPMT
    no ca_manager (no CI plugged?)
    demux 1 mask 03 prevhash 00640308
    [eDVBCAService] don't build/send the same CA PMT twice
    doing version filtering
    0064: 02 03 82 11 00 00
    mask: ff ff ff 3f 00 00
    mode: 00 00 00 3e 00 00
    Sequence header at f024, pts 15cf15ade
    enigma2: ewidget.cpp:112: void eWidget::show(): Assertion `root' failed.


    Auf der Platte sind dann folgende Files:

    -rwxr-xr-x 1 root root 546 Mar 21 18:33 20060321 1933 - ProSieben - Galileo.eit
    -rw-r--r-- 1 root root 192.0k Mar 21 18:33 20060321 1933 - ProSieben - Galileo.ts
    -rw-r--r-- 1 root root 57 Mar 21 18:33 20060321 1933 - ProSieben - Galileo.ts.meta

    Hallo,


    ich habe das Problem, dass enigma2 zu 90% immer abstüzt, wenn die Aufnahme
    beginnt (egal ob per Timer oder Manuell). Ich Drücke RECORD, die Festplatte
    läuft an und nach 5 Sekunden ist das Bild und LCD Display weg.
    Nach 10 Sekunden ist das Bild wieder da und die Aufnahme muss ich
    erneut starten, diesmal aber ohne Absturz.


    Ich habe in der /usr/bin/enigma2.sh folgende Zeile geändert, um an
    eventuelle Fehlerinfos zu kommen:
    /usr/bin/enigma2 >>/tmp/enigma.err 2>&1



    Hier nun ein Auszug von /tmp/enigma.err, hoffe hier kann ein Developer
    etwas damit anfangen.


    Danke!



    It's now Tue Mar 21 11:59:18 2006
    [TIMER] activating state 1
    begin_date: 20060321 1159
    service_name: ProSieben
    name: AVENZIO - Sch<C3><B6>ner leben!
    description: AVENZIO - Sch<C3><B6>ner leben!
    [TIMER] Filename calculated as: '/hdd/movie/20060321 1159 - ProSieben - AVENZIO - Sch<C3><B6>ner leben!'
    recording service: 1:0:1:382:21:85:C00000:0:0:0:
    record: 0
    use cached_channel
    allocate Channel: res 0
    RECORD service event 6
    tuned..
    ok ... now we start!!
    no version filtering
    0000: 00 00 00 00 00 00
    mask: ff 00 00 00 00 00
    mode: 00 00 00 00 00 00
    query epg event id 15009
    found event.. store to disc
    [TIMER] prepare ok, writing meta information to /hdd/movie/20060321 1159 - ProSieben - AVENZIO - Sch<C3><B6>ner leben!
    [TIMER] prepare ok, waiting for begin
    [TIMER] activating state 2
    [TIMER] start recording
    Recording to /hdd/movie/20060321 1159 - ProSieben - AVENZIO - Sch<C3><B6>ner leben!.ts...
    starting recording..
    RECORD: have 1 video stream(s) (00ff), and 1 audio stream(s) (0100), and the pcr pid is 00ff, and the text pid is 0020
    ADD PID: 0000
    ADD PID: 0020
    ADD PID: 00ff
    ADD PID: 0100
    waiting for thread start...
    waiting for thread start...
    FILEPUSH THREAD START
    [timer.py] next activation: 1142938858 (in 99668 ms)
    no version filtering
    0064: 02 03 82 00 00 00
    mask: ff ff ff 00 00 00
    mode: 00 00 00 00 00 00
    doing version filtering
    0000: 00 00 00 17 00 00
    mask: ff 00 00 3f 00 00
    mode: 00 00 00 3e 00 00
    RECORD service event 5
    starting recording..
    RECORD: have 1 video stream(s) (00ff), and 2 audio stream(s) (0100, 0101), and the pcr pid is 00ff, and the text pid is 0020
    ADD PID: 0064
    ADD PID: 0101
    [eDVBCAService] add demux 1 to slot 2 service 1:0:1:382:21:85:C00000:0:0:0:
    [eDVBCIInterfaces] addPMTHandler 1:0:1:382:21:85:C00000:0:0:0:
    [eDVBCIInterfaces] gotPMT
    no ca_manager (no CI plugged?)
    demux 1 mask 03 prevhash 00640308
    [eDVBCAService] don't build/send the same CA PMT twice
    doing version filtering
    0064: 02 03 82 11 00 00
    mask: ff ff ff 3f 00 00
    mode: 00 00 00 3e 00 00
    Sequence header at 18014, pts ca9dd23e
    Sequence header at 58a14, pts ca9e7afe
    enigma2: ewidget.cpp:112: void eWidget::show(): Assertion `root' failed.
    executing main
    Setvolume: 100 100 (raw)
    Setvolume: 0 0 (-1db)
    Setvolume: 50 50 (raw)
    Setvolume: 32 32 (-1db)
    eDVBCISlot::enableTS(0 0)
    ci removed
    + 1/1 TID 00
    done!
    -+ 1/2 TID 4e
    + 1/1 TID 02
    done!
    ++ 2/2 TID 4e
    done!
    + 1/1 TID 00
    done!
    + 1/1 TID 02
    done!
    +- 1/2 TID 4e
    ++ 2/2 TID 4e
    done!