SvenH-Feed-Plugin (DreamOS)

  • Das mag ja stimmen nur helfen solche Post dann auch niemanden weiter.

    So wie mit diesen Post hier nun die letzten 4 von 5 Post. ;)


    Man könnte einen ja auch eventuell mal freundlich da drauf hinweisen und nicht immer gleich los Poltern. :) Nur mal so als anregung. 8o


    Und außerdem konnte man SvenH seine ganzen sachen doch über den gutemine feed Installieren oder habe ich das mal falsch mitbekommen?

    Da könnte man ja schnell davon ausgehen das man hier richtig ist. :wacko:

  • Nein!

    Sven H plugin sind immer nur über sein eigene feed adresse zur Verfügung gewesen.

    Sven H feed adresse liegt/lag aber zusätzlich im gutemine-feed.list, was für viele nicht bekannt gewesen ist/war. Jetzt hat Sven H sein eigene feed.list und feed plugin mit passende feed adresse. Dadurch ist er jetzt sein eigene Herrn auf sein feed und plugins.

    E2 Box: Two, One, DM 8000, DM7080HD, DM 7025(+), DM 7020HD(v2), DM9x0, DM820HD, DM 800SE(v2), DM 800HD, DM52x, DM500HD(v2)
    E1 Box: DM 7020, DM 7000, DM 5620-S, TRIAX 272-S, DM 600PVR, DM 500+, DM 500-S

    Sonstiges: DM100, DM Tastatur
    Sat: WaveFrontier T90 23.5E <=> 30.0W

  • Wenn weiterhin gutemine Plugins , die noch auf der Box sind, genutz werden sollen,

    alles so lassen wie es ist. Der gutemine feed. muß nur , wenn nicht schon automatisch, im Setup deaktiviert sein.

    Image- und sonstige Pluginupdate gehen nach wie vor.


    Das SvenH feed Plugin gibt es im 1. Post

    und darüber gibt es dann auch weiterhin MetrixStyle updates :love:  ;)

    DM 920 UHD sss :love:

  • Dann will ich mal zusammenfassen ;)


    gutemine hat die Weiterentwicklung seiner Plugins für das OE2.5 (u.a. auch für die 920) eingestellt.

    Daher wird es dafür keine Updates mehr geben.

    Auch der Feed existiert dafür nicht mehr, so dass auch das bisherige gutemine-Feed-Plugin nicht mehr wirklich nutzbar ist.


    Wer auf den „alten“ Boxen (OE2.5) noch Plugins von gutemine drauf hat und nutzt, kann diese auch drauf lassen, bis sie ggf. wegen Zeitablauf nicht mehr funktionieren.

    Wer das gutemine-Plugin deinstalliert, läuft Gefahr, dass dabei dann auch viele gutemine-Plugins deinstalliert werden.


    Wer also im OE2.5 noch Plugins von gutemine nutzt, der sollte einfach im gutemine-Feed-Plugin im Setup die Aktualisierung (1.Option) deaktivieren und speichern, damit der nicht mehr verfügbare gutemine-Feed das normale Box-Update nicht blockiert.


    Hinweis:

    Wer nach dem Deaktivieren der Aktualisierung im Setup das gutemine-Feed-Plugin nochmal öffnet, sollte anschließend nochmal das Setup öffnen und wieder auf Speichern gehen, da der Feed trotz deaktivierter Option beim Öffnen des Plugins immer wieder neu erstellt wird und dann wieder das allgemeine Box-Update stört.

    Gruß Sven (aka Dreamy)


    DM920 mit unstable OE2.5 DP
    One mit unstable OE2.6 DP

  • Hi.

    Installed a previous version of plugin (v0.1-r9).

    Tryng to make an online update, GS.

    Thinking it might be a problem with an outdated version, I manually installed the latest one (v0.1-r11).

    The feed plugin opens without a problem, but any plugin I try to install from it causes a new GS.

    Dreambox Two, PeterPan "Into the darkness" image OE 2.6


    enigma2_crash_1649239050.log


  • Hello


    This is the real error from your crashlog

    This is on open the Plugin-Help-Screen by the audio-key.

    If you have this GS on open the Help-Screen, then you have most selected the wrong remote control in the system-plugin remotecontrolselection.

    (perhaps you have selected the RC 10 but you have the RC 20 IR/BT).


    This is not an GS on Update the Plugin inside the feed-Plugin.


    Perhaps you have another chrashlog ?

    Gruß Sven (aka Dreamy)


    DM920 mit unstable OE2.5 DP
    One mit unstable OE2.6 DP

  • The configured remote control is RC-20BT as you can see.

    The error is generated only by pressing the YELLOW key (Install), while all the others keys work fine.

    I also thought it might depend on the keymap I use (half-neutrino - I never liked the default mode and changing channels with the LEFT/RIGHT keys always seemed absurd and unnatural...) but even going back to standard mode the problem remains.

    However, I deleted the old crashlogs and re-generated the problem to get an updated one, which however seems identical to the previous one.


    I also made another "insane" attempt, trying to use the remote control of the dm920, obtaining exactly the same result: all the keys work, except for the yellow one that sends enigma2 crashing.

    I'll try with a different image, but I can't do it immediately.

    Here the new crashlog:


    enigma2_crash_1649262133.log


  • Ok, then you use a wrong keymap.

    On the new crash you have pressed the audio-key, but not the yellow.key.

    This open the help-Screen and there is an error with an unknown key in keyDescriptions.

    There is no keyDescriptions exist for index = config.misc.rcused.value

    Code
    [SvenHPlugins] AUDIO pressed
    [SvenHPlugins] NOW WRITES OUT: 138 = HELP
    action ->  HelpActions displayHelp

    With Original DP-Image no problem on install/update plugins with yellow-key.


    Please test the OK-Key to Update a plugin instead of the yellow-key.

    Perhaps on your system is the yellow.key maped to a wrong key.

    Gruß Sven (aka Dreamy)


    DM920 mit unstable OE2.5 DP
    One mit unstable OE2.6 DP

    Edited once, last by Sven H ().

  • Thank you.

    So it's just a wrong keymap issue.

    I've already tried using the OK key, which doesn't give any errors but only generates a refresh sel feed.

    Anyway no problem, now that I know how to handle it I'll provide for now with manual installations.

    Then I'll try again with other images.

    In the meantime I will submit the problem to seagen.... ;)


  • seagen

    There are two problems:


    1. wrong key map (use audio instead of yellow)

    2. missing keyDescriptions[config.misc.rcused.value] in the keybindings.py

    git.opendreambox.org Git - enigma2.git/blob - usr/lib/enigma2/python/Tools/KeyBindings.py


    In the original image there are 4 index-values for the keyDescriptions (0-3).

    If you have perhaps a value = 4 in config.misc.rcused.value, then you will get an GS on the HelpScreen, if this index is not exist in the keybindings.py


    Code
    File "/usr/lib/enigma2/python/Tools/KeyBindings.py", line 191, in getKeyDescription
        if key in keyDescriptions[config.misc.rcused.value]:
    IndexError: list index out of range

    Gruß Sven (aka Dreamy)


    DM920 mit unstable OE2.5 DP
    One mit unstable OE2.6 DP

    Edited once, last by Sven H ().

  • Hi


    Thanks for the info. Sven H

    I have found the problem. We have our own RC setup plugin that needs to be tweaked a bit.

    So for the moment just choose the RC-10 remote in the plugin and all works just fine.


    Update are on it's way

    Everything in life that's any fun is either immoral, illegal or fattening

  • Thanks for the info. Sven H

    I have found the problem. We have our own RC setup plugin that needs to be tweaked a bit.

    So for the moment just choose the RC-10 remote in the plugin and all works just fine.


    Update are on it's way

    Great, with the last image updates no more GS whatever button you press.

    Plugins on the Sven feed install/uninstall without any problems, and all other functions are available correctly. :thumbup:


  • Hallo ,


    das unverständlichste an der Geschichte , woher weiss das Plugin , dass es aktualisierungen gibt , wenn das ding noch nicht mal ind Netz kommt.

    Und wie bei dem Hamsterspiel mit dem Hammer steckt alle paar Monate eine neuer "Programmierer" seine Kopf aus irgendeinem Erdloch.


    Wie lange ist der denn dann aktuell , man man man , so langsam wird einem das schon lästig .


    Also am besten wird wohl sein sich den ganzen kram einzeln aus dem Netz zu holen und solche fadenscheinigen Pakete zu meiden , dann hat man weniger Probleme mit Leuten die nur Ihren Namen in der Box lesen wollen.

  • ja ja die Hitze ;(


    Natürlich kommt das Plungin "ins Netz"


    und nicht das Plugin sondern deine Box "merkt" wenn es auf dem Feed eine neuere Version eines installierten Plugins , wie die auf der Box, gibt.

    DM 920 UHD sss :love: