Dreambox two "no valid partition table for mmcblk0"

  • hello everyone,

    I am a new owner of a dreambox two ultra, and I faced this problem after a journey testing different images of the dreambox two.

    The device is solid and fast, but picture quality is not so, and channel editing and selection is a nightmare..

    Now I am facing this problem, the box doesn't boot and doesn't accept the online recovery as a solution., and after a long search I had this message "no valid partition table for mmcblk0".

    How do I restore the partition table for the device?

    Any help is welcome, and thanks in advance

  • no help.

    ok, can any one please having dreambox one or dreambox two give me the output of this command in telenet (or DCC E2)?

    fdisk -lu /dev/mmcblk0

    thanks in advance

  • root@dreambox:~# fdisk -lu /dev/mmcblk0

    Disk /dev/mmcblk0: 16 MB, 16777216 bytes

    255 heads, 63 sectors/track, 2 cylinders, total 32768 sectors

    Units = sectors of 1 * 512 = 512 bytes

    Disk /dev/mmcblk0 doesn't contain a valid partition table


  • Myshel, thank you for your reply, but it seems that your partitions have a problem, but not affecting your box.

    Anyway, the command output should give the partitions on your box's internal memory in order with stating sector, sector count, and approximate size in MB.

    So, I am still in need for that information.

    Reichi, I need help to operate my device, I am not interested in playing with disks, although I've been working with partitioning for more than 20 years.

    I expected support, and I hope I get it.


  • If you are the partitioning expert, then why deleting it at the First place?

    Why using/proposing fdisk when you we're told sgdisk is necessary?

    Finally Reichi is completely correct, If you don't know what you are doing STOP immediately!

    Edited once, last by gutemine ().

  • I didn't delete my partition table, I just uploaded a backup taken from my device.

    I don't waste my time on such things, all I've wanted it is to restore a backup that doesn't crash so often., and I was surprised when the box didn't startm and after trying to restore or apply other images,

    none has worked, so I am here, I just want the sizes of the partitions, and if I don't have I will throw my box.


  • How did you take your Backup, how did you Flash your device, where is your bootlog, why do you think you need to re-write you partitiontable,...

    You Just demand Help and pretend to bei innocent, without Any Proof or Infos to Support your Story...which is not consistent either.

    You and Most of the Others in this Thread are Not even understanding the difference between an MBR and GPT partitiontable and fdisk and sgdisk.

    Just because fdisk can't find a Partition Table because it searches for an MBR which the eMMC is NOT using, does NOT mean that you need to re-write anything as Reichi Tried to Tell you.

    If you ignore advice given and insist to know better....

    'No Image worked anymore" is normally Just the indication of "I insisted to Backup and restore my Brocken settings everytime I flashed a fresh Image" Just to make sure None of Them will Boot.

    Edited 7 times, last by gutemine ().

  • wow, I am now a criminal because the memory card lost its partition table, what could come next.

    I didn't delete the internal memory partition table, I don't know how to delete it, I never used debian before, I never used telenet before in my life, I don't know what happened and caused the problem.

    I don't beg for someone to fix my device, all I want to know is the size of partitions on a good dreambox two internal memory, I hope that is not a crime too.

  • Once more your fdisk Output ist NO Error!!!!

    Try sgdisk -p if I remember correctly and enjoy the difference.

    Flash Images without the settings Backup/restore Tick boxes ...and Listen to advice instead of complaining....

    Your threadtitel suggest that Recovery console and Flash Partition table is Alive because if you do not even know how to do a bootlog, from where did you geht the Error Message..... hence No need to Panic.

    Reichi and myself Just try to avoid that you do Further nonsense....

    Edited 3 times, last by gutemine ().

  • Recovery console has it included, on a Standard booted DreamOS you have to Install First from Feed.

    But such replies Just confirm what I Stated already, better Stop when you do not know what you are doing.

    And better Stop thinking that doctors are idiots If they don't give you a prescription for Ivermectin =O

    Edited 2 times, last by gutemine ().

  • @gutemine did I kill your father in a previous life?,

    I am a software engineer, not an idiot, and I think you don't want to help me regardless whatever I say.

    Please let other friendly people answer the only quesion I asked and I'll be so grateful for them, and after that I hope I never see you again or hear from you in my life and any supposedly coming lives.

  • It is NOT my fault if you are not taking any advice and want everything served on a plate with a silver spoon, even when what you ask for is nonsense.


    apt-get update 
    apt-get install gptfdisk-sgdisk

    Second from my fully working Dreambox two:

    fdisk -lu /dev/mmcblk0
    Disk /dev/mmcblk0: 15.6 GB, 15634268160 bytes
    4 heads, 16 sectors/track, 477120 cylinders, total 30535680 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Disk /dev/mmcblk0 doesn't contain a valid partition table

    Should I NOW also start reparing something which is NOT broken ????


    sgdisk -p  /dev/mmcblk0
    Creating new GPT entries.
    Disk /dev/mmcblk0: 30535680 sectors, 14.6 GiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): 09EB3761-0B88-4379-9C67-9CFB48C94E56
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 30535646
    Partitions will be aligned on 2048-sector boundaries
    Total free space is 30535613 sectors (14.6 GiB)
    Number  Start (sector)    End (sector)  Size       Code  Name

    Fourth get the root device:

    cat /proc/cmdline
    logo=osd0,loaded,0x7f800000 vout=1080p50hz,enable hdmimode=1080p50hz fb_width=1280 fb_height=720 console=ttyS0,1000000 root=/dev/mmcblk0p7 rootwait rootfstype=ext4 no_console_suspend

    List root partition

    Verify root partition:

    sgdisk -v  /dev/mmcblk0p7
    Creating new GPT entries.
    No problems found. 8388541 free sectors (4.0 GiB) available in 1
    segments, the largest of which is 8388541 (4.0 GiB) in size.

    Verfiy entire device:

    sgdisk -v  /dev/mmcblk0
    Creating new GPT entries.
    No problems found. 30535613 free sectors (14.6 GiB) available in 1
    segments, the largest of which is 30535613 (14.6 GiB) in size.

    The Creating new GPT entries message means ONLY that the values in Memory are checked and updated, NOTHING is written to the eMMC with the above commands as there is NOTHING to be fixed.

    For your other comments ....Maybe consider reading my signature ...

    Edited once, last by gutemine ().

  • hello.

    anyone that can make the command with sgdisk to partion the dreambox two.. need to reset all to get the box working again.

    like this for the dm920 sgdisk /dev/mmcblk0 -z -n 1:2048:65535 -c 1:kernel -t 1:8301 -n 2:65536:4194303 -c 2:rootfs -t 2:8307 -n 3:4194304: -c 3:data -t 3:8300.

    need for dreambox two.


  • This command does not overwrite the Dreambox two partition so that users do not mistakenly use it. Clearing this partition equals the breakdown of your device.