Krogoth branch not possible to build anymore

  • I would assume it has to go into python2.7.bb (or however it's called). The above error could be a consequence of their "blocker"

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Well after some heavy read up and help from the dark side i figure it out and now can build krogoth image on all Linux distros with VMWare and or Windows 10 (Ubuntu 18.04 lts) :)


    I have successfully built on Debian 9/10 Ubuntu 16.04/18.04/20.04

    And Windows 10 Ubuntu 18.04 LTS app


    No need for any complicated docker image

    Image that build fastes on my computer was Debian 9 stretch


    Thanks to dre for keeping me motivated and for always helping us less skilled but learning users

    Everything in life that's any fun is either immoral, illegal or fattening

  • Well issue is in the python-ioctl as we reported there was an issue with setuptools and setuptools-scm


    After lots of reading and some help from the darkside we manage to figure out that python-ioctl was trying to install setuptools/setuptools-scm but the package is already installed and the files are owned by that package.

    This caused the build crash. So if you re write the git file for python-ioctl then you can pretty much build in any linux distro of your choice.


    I even manage to build an image with the Windows 10 Ubuntu 18.04 lts addon/app but there you need to install the same recommended extra files as for pyro and the dpkg utils.

    Debian 9 strech only need your first 2 fixes and the tweak in the git file and then you can build without the need for any extra installation.


    Again thanks for your help i would never been able and figure this out without you advices :)

    Everything in life that's any fun is either immoral, illegal or fattening

  • Hallo,


    ich verstehe einfach nicht, wie man das setuptools-scm Problem löst.


    Ich habe die Datei python-setuptools-scm_3.3.3.bb erstellt, aber die Datei wird nicht bearbeitet. Was mache ich falsch ?


    Viele Grüße


    Axel Lanser

  • Ich würde einfach mal nur die setuptools-Version erhöhen. Vielleicht reicht das bereits.


    Pfad: <oe-root>/openembedded-core/meta/recipes-devtools/python

    Dort python-setuptools_32.1.1.bb reinkopieren und python-setuptools.inc


    python-setuptools_32.1.1.bb:

    python-setuptools.inc:

    Versuch doch bitte mal, ob das bereits ausreicht.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Problem is not the setuptools problem is that python-ioctl is trying to install setuptools. But since setuptools already is installed this fails.

    I have an ugly fix for but was hoping that DP then self would overhaul the repo and fix this issue

    Everything in life that's any fun is either immoral, illegal or fattening

  • Du sollst python-pip auf Version 8.1.2 anheben wie in Post 30 beschrieben. Wenn du den Link auf das recipe anklickst, dann kannst du unterhalb das recipe für morty sehen, welches 8.1.2 nutzt. Dieses kannst du einfach herunterladen ins gleiche Verzeichnis, welches /meta-openembedded/meta-python/recipes-devtools/python sein müsste. Dort solltest du schon das recipe für python-pip 8.1.1 finden.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Just unzip this file and move the .bb file from inside the zip file to the location described by dre
    opendreambox/meta-openembedded /meta-python /recipes-devtools /python


    Now backup the python-pip_8.1.1.bb by just rename it to python-pip_8.1.1.bak


    Re run the make of image and all should work just fine

    Files

    Everything in life that's any fun is either immoral, illegal or fattening

  • It's not required to rename the recipe for 8.1.1. The highest version will be built automatically.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource