CEC 2.0 > Test

  • Hallo,


    ich habe gestern das CEC 2.0 installiert und gestetet, die Deinstallation von HDMICEC (CEC 1.0) und installation von "CEC"2.0 lief problemlos, auch der Weg zurück. Der Ersteindruck war ein gänzlich aufgeräumtes Menü was irgendwo im 920 Forum schon beschrieben wurde was erstmal positiv ist. Leider funktioniert das CEC nicht wirklich an Denon X5200W AVR + LG 49SM9000 TV. Die DM erscheint nicht im Gerätemenü des TV, auch werde die Lautstärketasten nicht durchgereicht. Das Ausschalten der Wiedergabekette durch die DM resultiert im ausgeschalteten TV und ausgeschalteten + direkt wieder eingeschalteten AVR, irgendwie crazy und jederzeit reproduzierbar. Zum Glück war der Weg zurück zu CEC 1.0 ohne Probleme.


    ps.

    falls die Entwickler diesbezüglich was zum Testen habe, jederzeit gerne.

    Grüße

    -DM 920 2x FBC DVB-C Tuner / BT FB Aufrüstung / Aufahmen aufs NFSs / Samsung 850 PRO 512GB SSD für PermaTimeshift

    -DM One DVB-C / BT FB Edition / Aufahmen aufs NFSs / Samsung 860 PRO 512GB SSD in ICY Box Enclosure IB-247-C31 für PermaTimeshift

    Edited once, last by extrakt ().

  • " CEC 2.0 installiert und gestetet"


    Hast du mal ein Link wo man das runterladen kann?

    | Dreambox ONE inkl. 1TB Festplatte |
    | Astra 19,2 | Sky Komplett inkl. sportdigital.tv | HD+ | MTV Unlimited | ORF |

  • Heißt "cec", du musst "hdmicec" deinstallieren, beides bei den Systemplugins.

    -DM 920 2x FBC DVB-C Tuner / BT FB Aufrüstung / Aufahmen aufs NFSs / Samsung 850 PRO 512GB SSD für PermaTimeshift

    -DM One DVB-C / BT FB Edition / Aufahmen aufs NFSs / Samsung 860 PRO 512GB SSD in ICY Box Enclosure IB-247-C31 für PermaTimeshift

  • Also bei mir geht CEC2.0 überhaupt nicht, weder lässt sich der Samsung UHD TV damit einschalten noch die Samsung Soundbar. Direkt wieder deinstalliert, mit der vorherigen Version klappt alle perfekt. In der Liste unter Geräte taucht der Samsung TV auch nicht auf bei CEC2.0 obwohl ganz neues 2019er Modell.


    Wieso taucht mein TV bei CEC1.0 im Gerätemenu auf und bei CEC2.0 nicht? Braucht ihr da Logs oder weitere Infos?

  • Reichis Idee war eigentlich zurück auf Feld 1 gehen und dann über Zeit verbessern. Aber ihr erwartet schon wieder eine vollständig funktionierende Implementierung.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Nur kann damit keiner was anfangen. Da braucht es Logs

    Die Sache ist halt, wenn man nur CEC1.0 ODER 2.0 installieren kann, muss man ja ständig switchen. Wenn 2.0 nicht geht, installiere ich mir 1.0 da dort alles bestens klappt.

    | Dreambox ONE inkl. 1TB Festplatte |
    | Astra 19,2 | Sky Komplett inkl. sportdigital.tv | HD+ | MTV Unlimited | ORF |

  • Du kannst doch V.1 im Flash testen, und V.2 mit/auf BAXII.


    Wo ist das Problem? :/


    ps.


    Und bitte nicht immer einen Beitrag extra nochmal zitieren wenn du direkt darauf eine Antwort gibst!

    Wer will schon bitte immer alles zweimal lesen?

    mfg.


    schnubbel
    Schiller Fan

  • Moin,

    hab jetzt auch mal CEC 2.0 getestet, weil nach einem GUI Neustart die Weiterleitung der Lautstärke-Tasten nicht mehr funktionierte. Das Problem besteht auch bei dem CEC 2.0. Allerdings ist bei CEC 2.0 die Lautstärke-Anzeige aktiv wenn die Laustärke-Tasten an meine Soundbar weitergeleitet werden. Ist das so gewollt?


    Greetz gerry

  • Ja, das kann ich bestätigen.

    Da ist wohl beim Verbessern einer anderen Sache das Erkennen des Audio-Systems beim GUI-Neustart auf der Strecke geblieben ;)

    Und es hat mit dem CEC 2.0 definitiv schon funktioniert, weil es mich da genauso gestört hatte und Reichi da was eingebaut hatte.


    Ich hab auch schon eine (bzw. zwei) Lösungen ;)

    Muss Reichi mal schauen, was die bessere Variante ist.


    1. Variante - in der CEC.py die Zeile 29 ändern (war ursprünglich schon mal so, wodurch die Box aber nicht sofort ihre Adresse hatte):

    Code
    - self._physicalAddress = tuple(self._cec.physicalAddress())
    + self._physicalAddress = (0xff, 0xff)

    2. Variante - in der CEC.py in der def start in Zeile 55 bei self._onReady() ein firstInit-Param einfügen

    Code
    - self._onReady(self._cec.logicalAddress(), self._cec.physicalAddress())
    + self._onReady(self._cec.logicalAddress(), self._cec.physicalAddress(), firstInit=True)

    und dann in def _onReady() in Zeile 75 den Param aufnehmen:

    Code
    - def _onReady(self, logicalAddress, physicalAddress):
    + def _onReady(self, logicalAddress, physicalAddress, firstInit=False):

    und in Zeile 88 beim Erkennen des Audio-Systems in der Prüfung berücksichtigen:

    Code
    - if oldPhysical != self._physicalAddress:
    + if oldPhysical != self._physicalAddress or firstInit==True:

    Gruß Sven (aka Dreamy)


    DM920 mit unstable OE2.5 DP
    One mit unstable OE2.6 DP

  • Perfekt Variante 2 funktioniert. Vielen Dank.


    Edit: Nach zweitem GUI-Neustart ist das Soundbar wieder weg :S


    Weißt du ob die Anzeige der Lautstärke mit CEC2.0 absichtlich aktiv ist ?


    Schönen Feiertag noch

  • hmm, sobald ich im CEC 2.0 das Weiterleiten der Lautstärketasten aktiviert habe, kommt die Lautstärke-Anzeige von der Dreambox nicht mehr.

    Hast du da evtl. noch ein anderes Plugin für die Laustärke-Anzeige installiert ?

    Gruß Sven (aka Dreamy)


    DM920 mit unstable OE2.5 DP
    One mit unstable OE2.6 DP

  • Ok waren tatsächlich die alten CEC Einträge in den Settings dran Schuld. Enigma gestoppt alle alten und nicht mehr benötigen Einträge gelöscht :thumbsup:


    Ps: Vielen Dank für dein Settings Cleanup Tool, es hat die alten CEC Einträge nicht erkannt. Evlt. prüft es keine Systemplugins?

    Edited once, last by Gerry6n ().