AVI-Video lässt sich nicht abspielen

  • Hallo,


    habe eine IP-Cam, die permanent aufnimmt, den Livestream der Kamera habe ich erfolgreich in das Bouquet eingefügt und läuft. Nur leider die Aufnahmen (liegen auf einem NAS als AVI-Dateien) werden zwar angezeigt in der Videoliste, aber können leider nicht abgespielt werden. Muss ich evtl. die Aufnahmeeinstellungen anpassen (Bitrate, Bildwiederholungsrate)?

    Folgendes sagt Mediainfo dazu:


    Vollständiger Name : C:\Users\Gast\Documents\2020-02-29 11-54-00~12-00-00.avi

    Format : AVI

    Format/Info : Audio Video Interleave

    Dateigröße : 184 MiB

    Dauer : 6 min 0s

    Gesamte Bitrate : 4 276 kb/s

    VGN0 : Camera 1

    VGT0 : 3ÍËp

    VGT1 : [MÑp


    Video

    ID : 0

    Format : q264

    Codec-ID : q264

    Dauer : 6 min 0s

    Bitrate : 4 270 kb/s

    Breite : 1 920 Pixel

    Höhe : 1 080 Pixel

    Bildseitenverhältnis : 16:9

    Bildwiederholungsrate : 30,000 FPS

    Bits/(Pixel*Frame) : 0.069

    Stream-Größe : 183 MiB (100%)


    Audio

    ID : 1

    Format : ADPCM

    Format-Profil : U-Law

    Codec-ID : 7

    Codec-ID/Hinweis : CCITT

    Dauer : 6 min 0s

    Bitraten-Modus : konstant

    Bitrate : 64,0 kb/s

    Kanäle : 1 Kanal

    Samplingrate : 8 000 Hz

    BitDepth/String : 8 bits

    Stream-Größe : 2,75 MiB (1%)


    Danke für eure Hilfe im vorraus.


    MfG Martin

  • q264 scheint proprietär von QNAP zu sein. Hast du die Möglichkeit in h264 aufzunehmen?

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Ja, das habe ich auch gelesen. Einfach wieder mal unnötig propriertäre Anpassungen...


    Code
    f=open("<Filename>.avi","r+")
    f.seek(0x70)
    f.write('h264')
    f.seek(0xBC)
    f.write('h264')
    f.close()

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Hallo,


    danke für eure Antworten, @m0rphU es geht um eine DM920.


    es handelt sich bei der Kamera um eine Foscam, wenn ich in deren Stream-Einstellungen gehe, erscheint kurz bei "AV-Stream-Typ" h264, ändert sich aber in "HD-Modus" um. Bei QNAP Surveillance-Station kann ich nur die Auflösung einstellen.


    dre und gr1nd

    wie und wo müsste ich das Skript bzw. die Befehlsfolge eingeben und könnte das auch automatisiert auf dem QNAP laufen?


    MfG Martin

  • Fred hatte ein python script von github verlinkt, welches man offenbar auf qnap ausführen kann. Vielleicht kann Fred den Link wiederherstellen.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • war der gleiche link wie in Post #4


    oder einfach mit "q264 to h264" die Suchmaschine füttern, so habe ich u.a. auch den python code in post #5 gefunden


    Keine Ahnung wie so ein script am QNAP aussehen muss bzw. was da für software on board ist, dafür ist das hier vermutlich das falsche Forum.


    Vermutlich ist es egal ob man das am QNAP, der Dreambox oder einer Linux Maschine macht, die syntax wird ähnlich sein - der Umgebung angepasst.

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • Hallo,


    danke für die weiteren Antworten, habe ein Windows-Tool gefunden, welches die Metadaten umschreibt. Funktioniert auch sehr gut, ist aber leider bei der Menge an Dateien viel Handarbeit. jetzt habe ich es mal versucht, mit dem Skript aus #4 auf der DM920. Aber leider bekomme ich folgende Fehlermeldung, nachdem ich die Frage mit y bestätige. Ein Teil der AVIs wird aber umgeschrieben und sind dann abspielbar.


    Edit: habe die Ursache zum Abbruch gefunden, die AVI-Dateien sind unvollständig, da sie durch eine Alarmaufnahme unterbrochen wurden.


    Jetzt fehlt mir nur noch ein Startskript, könnt ihr mir da bitte auch noch behilflich sein?


    der Befehl zum manuellen umwandeln (die .py-Datei liegt in /usr/bin) lautet bei mir:

    Code
    root@dm920:~# cd /usr/bin
    root@dm920:/usr/bin# python q264toh264.py /media/MKoNAS/record_nvr/channel1


    Danke

    Edited 2 times, last by prof.gates ().

  • Hallo,


    habe jetzt folgendes Startskript, das auch soweit funktioniert, wenn ich es im Telnet aufrufe/starte. Gibt es noch Vorschläge zur Verbesserung/Anpassung des Skripts?


    Bin da leider absoluter DAU und habe mir das jetzt so im Internet zusammen gelesen und mit try and error probiert, bis es lief. :)


    Ansonsten erstmal nochmal Danke, für den Schubs in die richtige Richtung, bei den Stichwörtern zur suche und das Python-Skript.


    Bash
    #!/bin/bash
    python /usr/bin/q264toh264.py /media/MKoNAS/record_nvr/channel1/ -Y
    exit
  • Wenn Du "Startskript" schreibst, meinst Du dann etwas, was als Cronjob oder waehrend des Startups laufen soll?

    In solchen Skripten hat sich bewaehrt, dass man ALLE Applikationen mit VOLLSTAENDIGEM PFAD aufruft, da nicht immer sichergestellt ist, dass das Userprofil vor der Ausfuehrung des Skriptes geladen wurde.

    Also nicht nur "python" sondern den kompletten Pfad mit dazu.

    In einer bash auf der Kiste einfach "which python" absetzen und den dann ermittelten Pfad im Skript ergaenzen, dann bist Du auf der sicheren Seite.

    Ymmv.

    DM900 SS, DM8000SSSS
    Kein Support per PN! Nutzt das Forum zum Fragen, dann haben auch andere etwas davon.

  • Nein, ist kein richtiges Startskript, es soll nur zum anstoßen der Konvertierung dienen. es muss nicht beim Boxstart oder permanent im Hintergrund laufen. Ich starte es manuell, entweder gebe ich in der Konsole (per Laptop) nur avi-h264.sh ein, oder vom Sofa, mit Fernbedienung, per Dreamexplorer das Skript ausführen.