IPTV langsamer Streamingaufbau

  • Hi,

    mir fiel seit längerem auf, dass der Aufbau von m3u8/IPTV Streams durch die letzten Updates langsamer geworden sind.
    Als Beispiel nehme ich XITE Belgique was auf meiner DM920 10sek benötigt, während VLC am PC innerhalb 1 sek geladen ist.

    Am Internet kann es also nicht liegen


    Das Problem habe ich auch mit anderen Streams, am PC direkt geladen, auf der Dreambox dauert es erstmal.

    Betrifft auch http Streams, also nicht nur https.

    Kann man hier irgendwas tunen?

    gstreamer 1.6.4-r0.4 ist installiert.

    In Betrieb
    Dreambox 920uhd-S2X/C
    Ausser Betrieb
    Dreambox 7080HD-S2/C / 8000-S2

  • Ich hab hier nur udp:// und da kommt das Bild < 1sec auf der 920. Also ich habe da keine Veränderung feststellen können. Was war den vor den Updates die benötigte Zeit?


    Mit dem PC vergleichen, bringt imho wenig.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Mir ist grad in den Sinn gekommen, dass ich bei SRF play solche Streams habe. Ich schau mal, wenn ich zu Hause bin

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Habs performanter bekommen.

    Hab vereinzelt die Streams von TS auf eServiceURI geändert.

    Bei manchen habe ich jetzt aber das Problem, wenn hinter der m3u8 Datei diverse Auflösungsstreams verborgen sind, so nimmt sich die Dreambox zwar den besten, Ton kommt, Bild bleibt dann aber schwarz.

    Ne Idee für Lösung? ausser direkt die höchste URL zu nehmen, welche sich aber regelmässig ändern kann.

    In Betrieb
    Dreambox 920uhd-S2X/C
    Ausser Betrieb
    Dreambox 7080HD-S2/C / 8000-S2

  • Ich habe das bei mir so programmiert, dass ich mir immer die höchste Auflösung raussuche.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Also eServiceUri macht überhaupt keinen Sinn das ist für etwas völlig anderes gedacht, da muss man auch einen Resolver programmieren damit das überhaupt irgendwas tut.

    Also von 1 auf 4097 ändern würde ich noch verstehen das macht ggf. Sinn.

    Wie gesagt 8193 macht gar keinen Sinn das tut dann überhaupt nichts außer es einfach mit 4097 abzuspielen.


    Der beste Weg wäre 8739 (eServiceStream), das ist aber aktuell nur auf der One verfügbar (demnächst wohl auch für die anderen OE2.5 Boxen).


    Das eigentliche Problem ist dass du die Master-Playlist angibst das sollte man immer vermeiden und die finale Playlist direkt angeben, so wie es dre schon gesagt hat.

  • Ich habe ein ähnliches Problem ab Enigma2 4.3.2r8 oder 4.3.2r9 (bin mir nicht ganz sicher), mit Enigma2 4.3.2r7 ist alles noch OK.

    Nun das Problem...

    Wenn ich z.B. so ein Stream ins Bouquet einfüge:

    #SERVICE 1:0:1:0:0:0:0:0:0:0:http%3A//domain.com%3A8080/user/pass/1234.ts


    ist es so, als ob die Bedienung beim Umschalten für einen kurzen Moment, ca. 1 Sek. einfriert (Verzögerung).

    Aber wenn ich ein Fake Service Reference einfüge, z.B. so:

    #SERVICE 1:0:1:1111:AAA:1:C00000:0:0:0:http%3A//domain.com%3A8080/user/pass/1234.ts


    dann gibt es diese Verzögerung nicht, schaltet ganz normal sehr flüssig um.


    Alternativ könnte ich auch 4097 verwenden, aber dann erscheint beim Umschalten immer die blöde Meldung "Connecting..." :)

  • Ich weiß nicht ob das für dich relevant ist aber bei nn2 gibt es einen Menüpunkt wo man den (Non-)TS Streaming Buffer (ms) anpassen kann. Default ist hier bei beiden 500 ms.