Problem with NTFS formatted external drives

  • 1. Please post the output of the follwing command executed on the Dream One via ssh or telnet:


    Code
    1. cat /proc/mounts

    2. what blocksize did you use when formatting the NTFS - keep in mind that this is now a 64 Bit Linux and NOT 32 Bit anymore and recordings are BIG files, which means you should use the biggest possible blocksize and NOT the default one your PC might have proposed.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • 1. Please post the output of the follwing command executed on the Dream One via ssh or telnet:


    Code
    1. cat /proc/mounts

    2. what blocksize did you use when formatting the NTFS - keep in mind that this is now a 64 Bit Linux and NOT 32 Bit anymore and recordings are BIG files, which means you should use the biggest possible blocksize and NOT the default one your PC might have proposed.



    opendreambox 2.6.0 dreambox

    dreambox login: root

    Password:

    root@dreambox:~# cat /proc/mounts

    /dev/root / ext4 rw,relatime,data=ordered 0 0

    devtmpfs /dev devtmpfs rw,relatime,size=285884k,nr_inodes=71471,mode=755 0 0

    proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0

    /dev/mmcblk1p1 /media/ba ext4 rw,noatime,nodiratime,nodelalloc,data=journal 0 0

    sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0

    securityfs /sys/kernel/security securityfs rw,nosuid,nodev,noexec,relatime 0 0

    tmpfs /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0

    devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0

    tmpfs /run tmpfs rw,nosuid,nodev,relatime,mode=755 0 0

    tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0

    cgroup /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd 0 0

    pstore /sys/fs/pstore pstore rw,nosuid,nodev,noexec,relatime 0 0

    cgroup /sys/fs/cgroup/debug cgroup rw,nosuid,nodev,noexec,relatime,debug 0 0

    cgroup /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0

    cgroup /sys/fs/cgroup/devices cgroup rw,nosuid,nodev,noexec,relatime,devices 0 0

    cgroup /sys/fs/cgroup/memory cgroup rw,nosuid,nodev,noexec,relatime,memory 0 0

    cgroup /sys/fs/cgroup/cpu,cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpu,cpuacct 0 0

    cgroup /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0

    cgroup /sys/fs/cgroup/schedtune cgroup rw,nosuid,nodev,noexec,relatime,schedtune 0 0

    systemd-1 /data autofs rw,relatime,fd=11,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=544 0 0

    mqueue /dev/mqueue mqueue rw,relatime 0 0

    debugfs /sys/kernel/debug debugfs rw,relatime 0 0

    tmpfs /var/volatile tmpfs rw,relatime,mode=755 0 0

    tmpfs /tmp tmpfs rw,relatime 0 0

    configfs /sys/kernel/config configfs rw,relatime 0 0

    fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0

    /etc/auto.misc /misc autofs rw,relatime,fd=6,pgrp=454,timeout=300,minproto=5,maxproto=5,indirect,pipe_ino=18947 0 0

    -hosts /net autofs rw,relatime,fd=12,pgrp=454,timeout=300,minproto=5,maxproto=5,indirect,pipe_ino=18204 0 0

    /etc/auto.hotplug /autofs autofs rw,relatime,fd=18,pgrp=454,timeout=300,minproto=5,maxproto=5,indirect,pipe_ino=4519 0 0

    /etc/auto.network /media/net autofs rw,relatime,fd=24,pgrp=454,timeout=300,minproto=5,maxproto=5,indirect,pipe_ino=18953 0 0

    /dev/dreambox-data /data ext4 rw,relatime,data=ordered 0 0

    root@dreambox:~#




  • OK, you are using the minimal (!) 4k Blocksize which is optimal for storing lots of small files., but this is totally idiotic for doing PVR recordings.


    Format it with at least 64k, or up to the maximum 2048kB and you will see the difference.


    Seems also like you have not permanently mounted the stick, which means it will be mounted also from autofs - which then is a sync mount instdead of async - which is another nightmare for a PVR recording.


    Which means there is nothing to fix, except your understanding what you are actually doing =O

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

  • How to mount it correctly?


    I formatted the external HDD as ntfs and 64k. But the receiver didn't recognize the hard drive and following message is displayed👇👇

  • You should mount in telnet to see errors. Use blksize=xxxx mount option, but be aware that the ntfs drivers on Linux have limitations (due to the fuse architecture) and blocksize is not the same as cluster size. A binary like ntfsinfo would tell you the difference on a real Linux PC (or your could steal the ntfsinfo arm64 binary from Debian Stretch)


    Which brings us back that using NTFS for recordings is not a good idea at all ;)


    And you should have first fixed the mount to be permanent and avoid using autofs, because mounting USB with sync will even cause problems when recording on USB with ext4 filesystem.

    Bad mood, bad manners, bad Plugins, you have been warned :whistling:

    Edited 4 times, last by gutemine ().