Netzwerkpriorität

  • Bei meiner DM one konnte ich durch ändern der main.conf die Priorität des Lan einfügen.

    Das heißt, beim start fährt Sie mit wlan hoch, sobald mein Switch gestartet / bereit ist, wechselt die one von wlan auf lan. (Der Switch wird durch meine homeautomatisierung bei positivem Hostcheck der one gestartet)

    Nun möchte ich auf die 9x0 wechseln (da mir die 2 Tuner der one zu wenig sind), diese hat ja nur wlan per optionalem usb-stick. Funktioniert es bei der Box auch?

  • Was ist das den für ein Switch, das du den zwischendurch ausschalten möchtest ?

    Ein einfacher 1Gbit 8 Port Switch braucht im Leerlauf ja < 2 Watt.


    Mit einem WLAN USB-Stick vermute ich das der zu spät eingebunden wird .

    >> Wir Schweizer haben die Uhren, aber keine Zeit ! <<

  • Es ist ein 24 Port D-Link mit einigen POE Verbrauchern die Nachts nicht gebraucht werden, da kommen schon einiges an Leistung zusammen, die Sinnlos verbraten wird.


    Was meinst du mit zu spät eingebunden? Es muss ja nicht sonderlich schnell gehen. Die NAS muss ja nur vor Aufnahmebeginn gemountet sein und das natürlich per LAN.

    Bei der one funktioniert dieser automatische Wechsel perfekt.

    Bevor ich mir nun eine 9x0 kaufe weil die one nicht genug Tuner hat, würde ich schon gerne wissen ob ich mir dann nicht neue Probleme mache.

  • Je nach mount Option müsste das NAS eigentlich auch eingebunden werden wenn das Netzwerk erst etwas nach dem Booten vorhanden ist.

    Probiert habe ich das nicht, notfalls liesse sich sicher ein script machen das bei erkennen der LAN Verbindung die Einträge in der fstab nochmals mountet.

    Das müsstest du auch auf der ONE ausprobieren können, einfach WLAN mal aus machen.

    Ich empfehle nur manuell erstellte Mounts mit systemd über die fstab.

    Ich hatte schon genug schlechte Erfahrungen mit den (veralteten) mount Optionen vom Mountmanager. (Siehe hier ---> E2 hängt komplett weg, wenn NFS Zugriff ausfällt....)


    PS: Macht es den Sinn, nur für Aufnahmen mit der ONE den Switch mit den vielen POE Verbrauchern an zu machen, auch wenn die anderen Geräte gar nicht benötigt werden ?

    >> Wir Schweizer haben die Uhren, aber keine Zeit ! <<

  • Das mounten der NAS ist ja nicht wirklich das Problem, zumindest bis jetzt nicht.

    Das Problem ist, dass ich der Hausautomatisierung mitteilen muss, dass der PVR hochgefahren ist, dies erreiche ich durch einen Hostcheck der Der Dreambox die nach dem Start noch im WLAN ist, da der ggf. Switch noch nicht hoch gefahren ist.

    Ist die Dreambox per WLAN erreichbar = Dreambox an und der Switch wird gestartet


    --> Nach dem Start des Switches merkt die Dreambox, dass RJ45 verfügbar ist und soll von WLAN auf Kabel umstellen.


    Bei meiner DM One funktioniert das mit dem Eintrag in die main.conf (siehe erster Post) sehr gut. Die Frage für mich ist nun, ob dies auch in einer DM 9x0 mit USB W-LAN und OE 2.5 funktioniert.


    Naja, Sinn macht es schon den Switch für eine Aufnahme zu starten, denn sonst ist die Geschwindigkeit über W-LAN zu langsam um den Film auf die NAS zu speichern und zudem hat die NAS ohne Switch ebenfalls kein Netzwerk. Nach der Aufnahme (Wenn die DM aus ist fährt er ja wieder runter wie die Switch auch)

  • das könnte man ja einfach mit einer dm9x0 testen (LAN abziehen und wieder anstecken während WLAN verbunden ist sollte es auch auch tun, notfalls den switch stromlos machen und wieder einschalten)

    ich glaub nicht, dass sich connman wesentlich zwischen OE2.5 und OE2.6 unterscheidet


    hast du eth0 und und wlan0 mit der selben IP konfiguriert oder mit 2 verschiedenen IP's im selben subnet? Ich hab' sowas mit connman noch nicht konfiguriert. Ich kenne nur eine ähnliche Konfiguration in der /etc/network/interfaces mit if-up/if-down

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

    Edited once, last by Fred Bogus Trumper ().

  • Ich hab' das mal kurz getestet


    die Datei /etc/connman/main.conf gibt es auf der dm900 nicht


    in cat /var/lib/connman/settings sind Wired und WiFi enabled




    beide Adatper sind aktiv und über die jeweilige IP erreichbar


    eth0: statische IP

    wlan0: dhcp IP


    Wenn ich das Netzwerkkabel ziehe ist die Box die LAN IP nicht erreichbar, jedoch weiterhin über WLAN
    ein paar Sekunden, nachdem ich das LAN Kabel wieder anstecke ist die Box auch wieder fast über die LAN IP erreichbar

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • Danke, welche Verbindung wird denn dann genutzt?

    Bei der One steht dann rechts im Menü aktive Verbindung die IP vom LAN.

  • Es sind beide an und verbunden, nur in den LAN settings sind gateway und nameserver konfiguriert


    die wlan0 wird also nicht deaktiviert - ich habe dazu in den settings keine Einstellung gefunden, in /etc findet man keine connman Konfigurationsdateien - aber ich bin auch am Enigma2 Stand vom 31.05.2019


    Ich hab' mal das akutelle unstable image entpackt, da ist in /etc auch nichts zu finden, da scheint es doch einen Unterschied zwischen OE2.5 und OE2.6 zu geben


    wo findest du auf der one die main.conf?

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • (ich erstelle mal einen neuen Beitrag, die Boardsoft unterstützt in der Konfiguration nicht, dass man einen Beitrag nach einem EDIT als NEU und somit on top markiert)


    Jetzt weiß ich, was du meinst


    dm900 default Verhalten:

    - eth0 und wlan0 konfigiuriert

    - aktives Netzwerk: Wired

    - LAN Kabel abgezogen -> aktives NetzwerK SSID (Wireless) nach dem das WLAN online war

    - LAN Kabel wieder angesteckt: -> aktives NetzwerK SSID (Wireless) und switcht auch nicht auf Wired um



    Ich habe dann die /etc/connman/main.conf manuell mit folgendem Inhalt erstellt:

    Code
    1. root@dm900:~# cat /etc/connman/main.conf
    2. [General]
    3. PreferredTechnologies=ethernet,wifi
    4. root@dm900:~#


    und die Box neu gestartet.



    Jetzt switcht das aktive Netzwerk schön zwischen Wired und SSID hin und her wenn man das LAN Kabel abzieht und wieder ansteckt.


    Ist das das gewünschte Verhalten?

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

    Edited once, last by Fred Bogus Trumper ().

  • Ich habe mir das mal genauer angesehen:


    Wenn man noch SingleConnectedTechnology=true in die main.conf unter [General] einfügt, wird immer nur eine Verbindung verwendet, also WLAN oder LAN, default werden ohne diese Einstellung beide Verbindungen gleichzeitig genutzt


    Code
    1. [General]
    2. PreferredTechnologies=ethernet,wifi
    3. SingleConnectedTechnology=true


    In dieser Konfiguration ist das wifi ein fallback für ethernet und und entspricht etwa einem bond 1 (Ausfallsicherheit) - jedoch mit 2 IP's und 2 MAC Adressen

    nur eine Schnittstelle ist aktiv (ethernet) und connman switcht nur dann zu wifi wenn das ethnernet "ausfällt". Sobald ethernet wieder online geht, wird wifi wieder deaktivert. Kann ein Nachteil sein, wenn eine aktive wifi Verbindung besteht



    Für eine reine Client Box vielleicht interessant ...




    Verhalten in den Netzerkeinstellungen

    wifi ist im idle wenn LAN Verbindung besteht, zieht man das Kabel dauert es ein wenig bis wifi online ist

    steckt man das LAN Kabel wieder an, geht wifi sofort in den idle mode


    Die Aktive Verbindungsanzeige in den Netzwerkeinstellungen switcht dabei auch zwischen Wired und SSID

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • Vielen Dank für deine umfangreiche Mühen :-)


    So, jetzt ist die DM920 inkl. WLAN da und eingerichtet. (So ein Dreck, der WLAN Stick geht nur vorne, also muss es ein kleiner sein)

    Ich habe das so wie du gesagt hast auch eingerichtet, er switcht auch brav hin und her.

    In dem Menü der Dreambox steht, wenn beides verfügbar ist, bei "Aktive Verbindung" die "wired" Variante, was demnach auch korrekt ist.

    In der Fritzbox jedoch sind sowohl LAN als auch WLAN durchgehend aktiv, bei dir auch?

  • Puh, ich hatte das nur getestet.

    Ich hab' keine Fritz!Box. Am DD-WRT Router wird mir der DM900 WLAN Adapter als inaktiv angezeigt (keine DHCP IP), solange das LAN Kabel dran ist. Switcht auf aktiv, wenn ich das Kabel ziehe und swicht wieder auf inktiv, wenn ich das Kabel wieder anstecke.

    Allerdings mit dieser main.conf

    Code
    1. [General]
    2. PreferredTechnologies=ethernet,wifi
    3. SingleConnectedTechnology=true


    Stelle ich auf SingleConnectedTechnology=false in der main.conf um, wird am Router wlan0 der Box als inaktiv angezeigt, solgange das Kabel dran ist. Ziehe ich das LAN Kabel wird wlan0 aktiv und bleibt auch aktiv, wenn ich dass LAN Kabel wieder anstecke.



    Wenn du willst dass immer nur ein Adapter aktiv sein soll, ist das wohl diese zusätzliche Einstellung deiner Wahl in der main.conf: SingleConnectedTechnology=true

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox