[solved] DreamOS (OE2.5): Bug im Ausschalt-Timer?

  • Hallo Gemeinde,


    ich setze den Ausschaltimer-Timer auf der dm900 oder dm7080 z.B. auf 120 Minuten, Aktion: Idle Mode


    Das funktioniert auch - aber nur genau einmal, bzw. gar nicht, wenn Enigma2 inzwischen neu gestartet wird. Wenn man über Über Menü - Neustart/Standby den Ausschalt-Timer wieder aufruft, ist der Timer-Status auch wieder: Deaktiviert


    d.h. man muss den Timer immer wieder neu einrichten, in den settings bleiben die Werte aber weiterhin (auch nach Enigma2 Neustart bzw. reboot) gesetzt:

    Code
    1. root@dm900:~# grep SleepTimer /etc/enigma2/settings
    2. config.SleepTimer.ask=true
    3. config.SleepTimer.action=standby
    4. config.SleepTimer.defaulttime=120
    5. root@dm900:~#


    BTW: der Variablenwert wurde nie an die EU Bestimmungen angepasst, das war am Anfang auch etwas verwirrend ;-)

    config.SleepTimer.action=standby = idle

    config.SleepTimer.action=shutdown = standby


    Im OE2.0 richtete ich den Ausschalt-Timer einmal ein und nach der eingestellten Zeit führte die Box immer die gewünschte Aktion aus.

    Hat sich im DreamOS etwas geändert oder übersehe ich etwas?

  • Irgendwie verstehe ich deine Frage nicht ganz.

    Ein Ausschalttimer soll doch auch nur bis zur angegebenen Zeit laufen und die Aktion ausführen.

    Wenn das geschehen ist, muss ich den Ausschalttimer für die nächste Aktion wieder neu aktivieren/starten.


    Wenn ich während des aktiven Timers die Box neu starte, ist für mich eigentlich klar, dass der Timer sich damit auch beendet.


    Das ist doch die ganz normale Funktionsweise eines Standby-Timers, wie ich es auch von diversen TV's kenne.


    Oder habe ich dein Problem falsch verstanden ?

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Im OE2.0 hat die Box immer nach der eingestellten Zeit die Aktion (idle/standby) nach x Minuten inaktivität ausgeführt. Der Timer musste nie neu gestellt werden.

    Zumindest hatte ich das vor Jahren so einmal so eingestellt. Im OE2.5 dachte ich zuerst den Timer nicht oder falsch gestellt zu haben.

    Konnte/kann man den Ausschalt-Timer anders stellen? Ich bin mir eben auch nicht mehr gamz sicher - denke jedoch, das nur einmal im Standby/Neustart Menü eingestellt zu haben.


    Die DM7020HD habe ich nicht mehr, allerdings noch ein backup

    in den settings finde ich dort nur den Wert


    config.SleepTimer.defaulttime=1


    Die Box ging jeoch bis zur Entsorgung nach den eingestellten 180 Minuten Inaktivität in den idle mode.

    Entweder wurde etwas geändert oder ich stehe jetzt mächtig am Schlauch ...

  • Die Aktion für Inaktivität wird in den normalen "Einstellungen -> System -> Anpassen" festgelegt ;)

    Wobei dort glaub ich nur "Herunterfahren" möglich ist.


    Vermute, du verwechselt diese Option mit dem Ausschalt-Timer ;)


    Eine Option für Idle nach Inaktivität kenne ich noch nicht.

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Naja, er meint zumindest, dass diese Funktion unter OE2.0 über den Ausschalt-Timer lief.
    Aber dann kann ich mich nicht mehr erinnern ;)


    Im Endeffekt sucht er ja nur eine Lösung für die Inaktivität-Sache, was ja nicht unbedingt über den Ausschalt-Timer gehen muss ;)

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Nein, das verwechsle ich nicht - der Unterschied zwischen Ausschalt Timer bzw. Ausschalten nach Inaktivität ist mir schon klar.


    Aber jetzt, wo du es sagst: Mit dem User Script Plugin von gutemine kann man den Inaktivtätstimer auf IDLE "umbiegen". Ich bin mir fast sicher im OE2.0 das im Ausschalt-Timer eingestellt zu haben. "Ausschalten nach Inaktivität" war in meinem zuletzt genutzen Image Stand ca. 2014 glaube ich noch gar nicht vorhanden ...

  • Ich glaube du hattest enigma2-plugin-systemplugins-autoshutdown installiert. Damit geht genau das was du möchtest. Liegt bei uns auch auf den DreamOS-Feeds.



    Anzeige dort: Standby=Idle, DeepStandby=Standby

  • ... Ich bin mir fast sicher im OE2.0 das im Ausschalt-Timer eingestellt zu haben ...

    Naja, der Code der SleepTimerEdit.py im originalen OE2.0 ist fast identisch mit dem Code im OE2.5.

    Der Unterschied liegt lediglich in der nachträglichen Anpassung zur Bedienung bezüglich der Änderung der Ausschaltzeit mit den Hoch-/Runter-Tasten ;)

    Also wirst du im OE2.0 wohl ein anderes kleines Helferlein genutzt haben 8o

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Joey99


    guter Tipp - aber das hatte ich nicht installiert, extra nochmal im Backup nachgesehen


    Ich habe den idle mode jetzt mal über das User Script Plugin wie gewünscht eingestellt, das sollte eigentlich klappen


    Ich bin mir zu 99% sicher das ich im OE2.0 kein "Helferlein" benötigte - aber ich werde es noch rausfinden

  • Fred Bogus Trumper

    Changed the title of the thread from “DreamOS (OE2.5): Bug im Ausschalt-Timer?” to “[solved] DreamOS (OE2.5): Bug im Ausschalt-Timer?”.
  • Ich hab's jetzt doch mit enigma2-plugin-systemplugins-autoshutdown gelöst - ich kannte das Plugin gar nicht. Danke an Joey99 dafür


    Damit lässt sich die Inaktiviät auch in Minuten einstellen.


    Wie ich es auf der dm7020hd gemacht habe, konnte ich nicht mehr rausfinden - aber jedenfalls weder mit autoshutdown noch mit dem userscripts plugin und scheinbar auch nicht mit dem Ausschalt-timer.


    Egal, Ich hab' den Thread mal auf "solved" gesetzt.