Kann ich im python an eServiceReference getrennte Video und Audio urls übergeben?

  • Hallo,


    ist es möglich über python an eServiceReference

    Code
    1. ref=eServiceReference(4097, 0, url)
    2. self.session.nav.playService(ref)


    die audio suburl zusätzlich mit zu übergeben?




    Code
    1. Jun 17 19:13:48 dm920 enigma2[5732]: [eServiceUri] 8193:0:0:0:0:0:0:0:0:0:yt%3a//CQ5k-yE6-bY resolved to 4097:0:0:0:0:0:0:0:0:0:https%3a//r4---sn-4g5e6nz7.googlevideo.com/videoplayback?expire=1560813228&ei=TMoHXaX5GJflgAeX17jQBA&ip=93.227.6.116&id=o-AImM_u-VGo8_tNhtZUfPmnHwHI0rNCtlsmVS1H7fCbSy&itag=18&source=youtube&requiressl=yes&mm=31%252C29&mn=sn-4g5e6nz7%252Csn-4g5edne6&ms=au%252Crdu&mv=m&pl=26&initcwndbps=1052500&mime=video%252Fmp4&gir=yes&clen=12489441&ratebypass=yes&dur=208.422&lmt=1540628937376957&mt=1560791490&fvip=4&c=WEB&txp=5531432&sparams=expire%252Cei%252Cip%252Cid%252Citag%252Csource%252Crequiressl%252Cmime%252Cgir%252Cclen%252Cratebypass%252Cdur%252Clmt&lsparams=mm%252Cmn%252Cms%252Cmv%252Cpl%252Cinitcwndbps&lsig=AHylml4wRQIhAMIhvqc9JagNXta88T-5bP5xZywCU8NJXnJW2mvRVEVpAiBju8tYVESB97aOGbpVnH1s7Zi4QiMnz53vex-6ksdnUw%253D%253D&sig=ALgxI2wwRgIhAPhIiZqjE5GRVNj8jumMUUSxNjUfyj2dAmEHvGCdSkT-AiEAlSAhUZevIT2AX_AYLHmtaBTfRl4iSBpepwHI10YO7Xk= - with suburi
    2. Jun 17 19:13:48 dm920 enigma2[5732]: eServiceMP3::playbin uri=https://r4---sn-4g5e6nz7.googlevideo.com/videoplayback?expire=1560813228&ei=TMoHXaX5GJflgAeX17jQBA&ip=93.227.6.116&id=o-AImM_u-VGo8_tNhtZUfPmnHwHI0rNCtlsmVS1H7fCbSy&itag=18&source=youtube&requiressl=yes&mm=31%2C29&mn=sn-4g5e6nz7%2Csn-4g5edne6&ms=au%2Crdu&mv=m&pl=26&initcwndbps=1052500&mime=video%2Fmp4&gir=yes&clen=12489441&ratebypass=yes&dur=208.422&lmt=1540628937376957&mt=1560791490&fvip=4&c=WEB&txp=5531432&sparams=expire%2Cei%2Cip%2Cid%2Citag%2Csource%2Crequiressl%2Cmime%2Cgir%2Cclen%2Cratebypass%2Cdur%2Clmt&lsparams=mm%2Cmn%2Cms%2Cmv%2Cpl%2Cinitcwndbps&lsig=AHylml4wRQIhAMIhvqc9JagNXta88T-5bP5xZywCU8NJXnJW2mvRVEVpAiBju8tYVESB97aOGbpVnH1s7Zi4QiMnz53vex-6ksdnUw%3D%3D&sig=ALgxI2wwRgIhAPhIiZqjE5GRVNj8jumMUUSxNjUfyj2dAmEHvGCdSkT-AiEAlSAhUZevIT2AX_AYLHmtaBTfRl4iSBpepwHI10YO7Xk=

    Wie wäre für einen Tip dankbar....


    PS: ich möchte explizit nicht die Resolver 'yt' und 'mp_yt' nutzen!


    MfG.

    Die meisten Probleme macht man sich selber!

  • Moin dhwz , ich habe ein wenig gebastelt. Es funktioniert auch soweit. Aber.... ich bekomme keinen Ton. Hast du vielleicht noch eine Idee, woran es liegen kann?


    Edit: Problem gelöst :)


    PS: Das mit dem nicht spulen können ist natürlich blöd...X/

    Die meisten Probleme macht man sich selber!

    Edited once, last by Bobo71 ().