Fehlerliste / known Bugs (Dreambox One/Two)

  • Hi Leute,


    hab grade mal wieder 3 parallele Aufnahmen auf einen Nfs Mount laufen und die Two lässt sich nicht mehr bedienen. Laut top hat enigma2 102% CPU last? Entweder ist da der Wurm im Treiber oder die CPU läuft mit angezogener Handbremse.


    Und im Log steht


    — Logs begin at Wed 2021-01-27 16:55:43 CET. —

    Jan 27 20:39:02 dreambox enigma2[482]: wait for driver eof timeout



    Greetz gerry

    Files

    • enigma.log

      (856.89 kB, downloaded 34 times, last: )

    Edited 2 times, last by Gerry6n ().

  • Gerry6n: hmm da lief dann aber zusätzlich zu deinen 3 NFS Aufnahmen auch ein remote Stream..sprich du hast einen Netzwerkservice aufgenommen.. daher kommen diese wait for driver eof meldungen.. .oder live geschaut. Weiss nicht genau. Auf jedenfall lief da ein Netzwerk Sender...


    Im log sieht man aber nicht, dass e2 blockiert oder ähnliches. Müsste man vermutlich ein Kernel log sehen.


    cu

  • Gerry6n: hmm da lief dann aber zusätzlich zu deinen 3 NFS Aufnahmen auch ein remote Stream..sprich du hast einen Netzwerkservice aufgenommen.. daher kommen diese wait for driver eof meldungen.. .oder live geschaut. Weiss nicht genau. Auf jedenfall lief da ein Netzwerk Sender...


    Im log sieht man aber nicht, dass e2 blockiert oder ähnliches. Müsste man vermutlich ein Kernel log sehen.


    cu

    Ja stimmt eine der Aufnahme war ein Stream vom TVHeadend Server.


    Kernel log geht nur per USB?


    Dann teste ich am Wochenende mal


    Greetz gerry

  • Hi. There is a strange problem in Dream One and that is that after repeatedly restarting gui, the device does not come up anymore and I have to turn the button on the back of the device on and off .. Please check this

  • I can assure you that in no way this is a bug. There are several developers at this forum and others doing maybe 100 restart in just a few hours.


    But if you should have any chance to get som help why this happens to you. You should at least provide som more information.
    Like what do you do that require multiple restart of GUI?

    Does the box just freeze without any crash / greenscreen?

    Maybe put the box into logg mode with journalctl -f and get some info when this happens

    Try and traceback and see if there is a pattern of use that causes this behavior

    Most likely it's a plugin not compatible or bad written causing this problem.
    But without any logs nobody can help you:)


    And most important what image are you using

    Everything in life that's any fun is either immoral, illegal or fattening

  • I design the skin or install and remove a lot of plugins so I need to restart the gui. I use cvs image..but this problem only occurs sometimes and is problematic

    If you encounter a crash then you have log file on your HDD. Else you have probably already answer your own question;)

    This is life as a skinner and plugin developer / tester. We will always encounter strange behaviour and probably lots of leftover files from .deb installation files
    Not correct compiled with or even without any installation scripts to clean up an uninstall.
    Therefor your image get corrupted over time and a new fresh install is the solution.
    It's also good to test skins and plugins on a fresh virgin image to confirm that all works proper and any dependency files are proper installed.

    Lots of skins and plugins install dependency files that might not be in the feeds and therefore, You might miss something important.


    So i think it's time for you to do a fresh install or even better do your work in BarryAllen then you can always have a fresh image ready for testing. Skin and plugins one by one
    This give you a good view and you do a better work as plugin tester :)

    Everything in life that's any fun is either immoral, illegal or fattening

  • I doubt leftovers are the problem. It's rather a bug in the skin that prevents from starting e2. After several failed attemps the systemd service is left in status failed. You could still start e2 by entering enigma2 in telnet. It would still crash but you see why

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • I doubt leftovers are the problem. It's rather a bug in the skin that prevents from starting e2. After several failed attemps the systemd service is left in status failed. You could still start e2 by entering enigma2 in telnet. It would still crash but you see why

    When this problem occurs, starting the enigma is solved through talent, but there is no crashlog

    So every time I have to start the enigma through talent

  • Servus, heute mal den ganzen Tag geloggt.


    Zwei Aufnahmen einen Stream weil kein Tuner mehr frei war und zack nichts geht mehr. Kein Greenscreen nach einem kleinen Moment startet die Box neu.

    Also das umstellen auf UDP NFS Mount hat leider nichts gebracht.


    Hoffentlich ist der Log aufschlussreicher


    Greetz gerry

  • Hi Ghost,


    leider tritt der Fehler erst nach ca. einem Tag Laufzeit auf. Gestern Früh konnte ich den Fehler nicht auf die schnelle reproduzieren.


    Könnte es evtl. ein Speicherleck sein? Oder ein Netzwerktreiber Problem? Da es ja gefühlt erst nach 12-14h Laufzeit auftritt.


    Vorgestern ist leider ohne Log die Box im Abspielen einer Aufnahme von meiner NAS stehen geblieben.


    Erst nach einmal stromlos machen funktionierte die Box wieder.


    Evtl. schaffe ich es am Wochenende nochmal nachzustellen.


    Wenn dir noch etwas einfällt, was ich besteuern kann, melde dich einfach


    Greetz gerry

  • Hab gestern mal die Geschichte mit TOP überwacht und finde es seltsam wie schnell der freie Speicher verschwindet bei zwei parallelen Aufnahmen. Könnte es sein, dass irgendwann der Box der Speicher ausgeht?


    Kann es ja theoretisch mit einer SWAP mal gegentesten ;-)


    Greetz gerry