DM9x0 hängt sich seit letztem Update gelegentlich komplett auf

  • Ja...


    da bringt was die Berechnung durcheinander.


    Wird dann in den Treibern für den Feed noch behoben, wenn keine neuen Hänger mehr auftreten.


    Das ist aber keine echte Systemlast... laut top langweilt sich die CPU nach wie vor.


    Der kernel ist da ein wenig doof...


    cu

  • Ok, dann passt es ja :thumbup:


    Was mir noch aufgefallen ist, dass der enigma2-Prozess eine höhere CPU-Last im Idle-Mode hat, als im Betrieb.
    Auch beim vorherigen Treiber vom 09.03.2019.
    im Betrieb zwischen 0,3 - 1,7%
    im Idle zwischen 3,3 und 5,0%


    Sollte das nicht andersrum sein? ;)

    Gruß Sven (aka Dreamy)


    DM920 mit unstable OE2.5 DP
    One mit unstable OE2.6 DP

  • Das mit enigma2 habe ich nicht. Denke nicht, dass das von den Treibern kommt.


    Da müsstest du mal schauen ob irgendwelche Plugins im Standby loslaufen und irgendwas komisches machen ;)


    Soo.. hier nun die Treiber mit dem Load Average Fix:


    Bitte nicht vertauschen.. also den für die DM900 nur für die DM900... der andere nur für die DM920


    DM900 muss auf der Box nach /lib/modules/3.14-1.17-dm900/extra/
    https://ghost.dream-multimedia…k_test/dm900/2/bcm7439.ko


    DM920 muss auf der Box nach /lib/modules/3.14-1.17-dm920/extra/
    https://ghost.dream-multimedia…k_test/dm920/2/bcm7439.ko


    cu


    Wenn alles gut geht, pack ich Die dann morgen auf den Feed.

  • Hat es was mit dem SAT-Tuner zu tun?


    Ich frage, weil ich hier trotz neuer Aufnahmen (2x mit insgesamt ca. 180 Min.), Abspielen einer älteren Aufnahme (ca. 70 Min.) und stundenlangem Betrieb keinerlei Probleme hatte/habe.


    edit: auch Teletext und Digitaltext (RTL) laufen.


    Konfig: DM900 mit Triple (nutze Kabel), ohne BT.

    Grüße
    ...jp

  • Meine 920 scheint auch wieder zu laufen, gestern nach dem Update hatte ich keine Probleme mehr.


    Im IHAD gibt es aber ein paar gegenteilige Posts.


    z.B von gestern:


    Zitat Anfang:
    Selbe problem auf der 900 er, seit gestern, update heute geschoben.
    Problem weiterhin, bleibt ohne Ankündigung einfach stehen, wie eingefroren.


    oder


    Das letzte Update hat bei mir zumindest nix gebracht.
    Meine 900er friert immer noch ein ohne Vorwarnung...
    Hat eben noch auf syfy ne Aufnahme zerschossen...
    Es geht aber auch dann nix mehr. Kein Telnet , kein FTP...
    Hilft nur Schalter hinten...
    Dann werd ich wohl auch mal nen Backup von Februar wieder einspielen...


    Zitat Ende

  • Die "Paar" sollten auch mal mit einem frisch geflashten DMM-Image testen, ohne irgendwelche Plugins...ggf. dann aber auch hier melden...


    Ich für meinen Teil hatte zuvor wie auch jetzt keine deadlock-Probleme auf den 900ern...

  • ich hatte auch keine probleme mit deadlocks...


    jedoch ist mir aufgefallen, das es beim umschalten ab und an mal kurz bildstörungen gegeben
    hatte. (meisstens glaube zu RTLHD) (3/4 Bild pixelbrei) das hatte ich jetzt nach dem update noch einmal bis jetzt.


    also ganz würd ich das problem eventuell nicht als gelöst melden.

    DM920UHD/FBC/Newnigma²Daily

  • Es ist schade, dass trotz mehrfacher Nachfrage keinerlei Aussagen zur Problemursache - oder zumindest wo/was gefixt wurde - gemacht werden :(


    Da es durchaus User (z.B. deepblue2000, mich) gibt, die keinerlei Probleme hatten, muss es wohl mit einer bestimmten Konfig zu tun haben. Solange das nicht bekannt ist, kann man auch schwer sagen, ob das Problem tatsächlich behoben ist.


    Es macht doch wirklich keinen Sinn jetzt zu raten, was da Einfluss hatte. Ist es wirklich zuviel verlangt kurz zu sagen, was gefixt wurde? Irgendwie verstehe ich DP immer weniger.


    Und nein, ich habe kein frisch geflashtes Image ohne Plugins, sondern meine uralte Installation (immer alle Updates eingespielt) inkl. einer ganzen Latte an Plugins.


    edit: @deepblue2000: Verwendest Du Kabel oder SAT? Welcher Tuner?

    Grüße
    ...jp

  • Das Problem war ein Fehler im Demux Treiber der Box. Dabei ist es egal ob DVB-S/C oder T(2) ... es war einfach ein deadlock der vor dem Fix
    wohl früher oder später bei jedem auftrat.


    Und nein.. irgendwie glaube ich nicht, dass es das Problem noch gibt. Ich vermute eher, dass bei bei Leuten wo das Problem noch besteht die aktuellen Treiber nicht auf der Box sind. Eventuell weil vorher die Treiber hier aus dem Thread manuell auf die Box kopiert wurde.. aber die alten Treiber irgendwie im selben Pfad gesichert wurde... und die Box nach wie vor mit den kaputten bootet.


    Das kann man aber recht einfach rausfinden beim booten steht die Treiber Version da. Wenn man mit dmesg oder im seriellem Log schaut.
    Bei der DM900 sollte da "bcm7439: xvd 20160630, vdc 20160630, rap 20160630, xpt 20160630, driver version 20190311-dm900" das stehen.. bei der dm920 halt dm920 am ende.


    Fehler beim zappen kann das übrigens nicht erzeugen. Die Audio/Video Daten laufen nicht durch diesen Teil der Software. Das ist eigentlich nur für Aufnahmen oder Streamings zu anderen Boxen zuständig. Bzw. alle TS streams direkt in den Userspace.. also e2. Aber ohne laufende Aufnahme oder Streamings gibts da keine bzw.. imho nur den Audio Stream der nach RDS Daten durchsucht wird.


    cya