DM920 Uhrzeit nur ntp

  • Ist schon manches geschrieben über Zeit usw. aber habe nicht gefunden was ich gerne möchte.


    Habe original Exp. 4.3.2r3 drauf.
    Box wird nur als Partnerbox und IPTV genutzt, also keine Satkabel drann und die Box ist mit dem Heimnetzwerk bzw. Internet verbunden.


    Problem ist, daß nach reboot Datum und Uhrzeit immer falsch sind (1-1-1970 00:00)


    Habe schon in
    - e2 settings transpondertime auf falsch gesetzt;
    - time-sync.target disabled;
    - nachgeschaut in connman settings und da ist timerserver (de.pool.ntp.org) drinn.
    - reboot getan.


    Überigens nicht so wichtig, aber bei Netzwerkeinstellungen kann ich keine andere ntp server (wie zb us.pool.ntp.org) eintragen, denn nur 0.pool.ntp.org, 1.pool.ntp.org usw. sind erlaubt (Länge Problem nur 14 Zeichen sind erlaubt)


    Frage: WIe kriege ich es hin (am liebsten ohne extra Plugin), daß nach reboot Datum und Zeit wieder i.O. sind

  • Mein Patch war damals flexibler, was das angeht, leider hat den Reichi nicht so übernommen.


    In den settings direkt editieren bei gestopptem e2 sollte aber gehen. Und 15 Zeichen wären besser, weil dann kann man auch jede IP4 Adresse eintragen. 4x3+3=15 :D

  • oder muss man einen service anlegen ?


  • Habe jetzt:

    Code
    1. root@dm920:~$ systemctl status time-sync.target
    2. ● time-sync.target - System Time Synchronized
    3. Loaded: loaded (/lib/systemd/system/time-sync.target; static; vendor preset: enabled)
    4. Active: inactive (dead)
    5. Docs: man:systemd.special(7)

    mit "transpondertime=false" meinst du den Eintrag in e2 settings? Habe ich da auch auf falsch stehen


    connman time-server:
    Timeservers=de.pool.ntp.org;

  • config sieht hier auch so aus, allerdings habe ich alles manuell eingerichtet - noch bevor man den Timerserver über die GUI konfigurieren konnte


    Funktioniert es jetzt?


    Ich muss aber sagen, dass ich das letzte größere Update nicht installiert habe, ich bin vorerst auf einem älteren Imagestand stehengeblieben - etwa vom 18.12.2018.
    Vielleicht hast du noch einen bug im aktuellen Image gefunden ...

  • ich habe alles in der Konsole vor über einem Jahr eingerichtet


    config.misc.useTransponderTime auf false gesetzt
    den Timeserver in die connman settings eingetragen


    Ich hatte auch mal das time-sync.target deaktivert, dass lies sich nur mit einem workaround wieder enablen (letzen beiden mit # auskommentierte Zeilen hinzufügen - ohne #)
    Wenn das target wieder sauber läuft, die beiden letzen Zeilen wieder rauslöschen oder auskommentieren

    das habe ich wie gesagt vor über einem Jahr eingerichtet. Ich könnte ja mal testweise die dm900 auf aktellen Stand aktualisieren, mal sehen ob es dann noch immer klappt - bin am Stand Anfang 12/2018 ...

  • Danke Fred. Habe es getan wie du geschrieben hast und time-sync.target is wieder aktiv (mit den beiden letzten Zeilen auskommentiert).
    Leider ist die Zeit immer noch auf 1-1-1970 02:00.


    Habe ich vorher noch nicht gemeldet, aber ich nutzte die Box nur auf der Terasse (und ohne Satkabel). Abends hole ich die Box vom Stromnetz (aus der Steckdose). Und nächsten Morgen ist dann die Zeit falsch.
    Wenn ich die Zeit manuel gut gesetzt habe und fahre die Box runter (FB->menu->deep stand by) dann ist beim neustart (FB->Powerknopf) alles i.O. Also kriege ich die falsche Zeit nur wenn ich die Box vorher spannungslos gemacht habe.

  • wenn das das time-snyc.target wieder aktiv ist, die letzten beiden Zeilen wieder auskommentieren


    als workaround könntest du mal versuchen ob du mit rdate eine aktuelle Zeit über die rc.local beim bootup holen kannst - am besten über einen child process im Hintergrund über einer Funktion in einer Dauerschleife bis das Netzwerk erreichbar ist - dann mit rdate -s syncen


    Hast du schon mal testweise neu geflascht und alles neu eingerichtet?

  • Danke. Ja wie geschrieben die letzte beide Zeilen sind wieder auskommentiert.


    rc local habe ich noch nicht versucht, aber die wird funktionieren denn wenn ich während des Startens ein Skript starte, ist alles i.O.
    In das Skript wird:


    - erst mittels "ping 8.8.8.8" (usw) kontolliert ob es eine Internetverbindung gibt
    - wenn ja wird die Systemzeit wird mit der NTP-Zeit verglichen, und gegebenenfalls wird die Systemzeit mit rdate -s aktualisiert.



    Aber was ich will ist dat alles ohne das Skript i.O. ist.



    Werde morgen neu flashen und schauen was das bringt.

  • Neu flashen wird es auch keine Besserung bringen, habe hier das gleiche Problem und dann kommt sowas raus
    --> Active: active (running) since Thu 1970-01-01 01:00:07 CET; 49 years 2 months ago

  • naja, das service wird gestartet bevor die akluelle Zeit geholt wird - egal ob vom Transponder oder vom Timeserver




    Gerade eingefallen, ich hab' das hier auch noch am laufen: -> [DreamOS] fake-hwclock


    nach einem wakeup aus einem stromlosen Zustand bekomme ich derzeit damitdie richtige Zeit mit dem alten imagestand
    Ich hatte damit aber auch schon mal eine falsche Zeit


    falls es nicht so läuft wie gewünscht, einfach wieder deinstallieren ...

  • Kannst du wieder deinstallieren, im aktuellen Image hat DP image wohl einiges geändert


    ich habe die dm900 neu geflasht, ohne settings restore und nur das Netzwerk konfiguriert - dm900 hängt nur am LAN, keine Tunerkonfiguration


    • der 14 stellige über die GUI konfigurierte Timeserver wird nicht mehr in /var/lib/connman/ethernet_000934xxxxxx_cable/settings hinterlegt sondern in dem Ordner in einem data file
    • config.misc.useTransponderTime=false muss scheinbar in den settings nicht mehr konfiguriert werden, auch eine manuelle Anpassung der settings (Timeservers=) ist scheinbar auch nicht mehr unbedingt notwending
    • einfach default Zeitserver über die GUI eingestellt (0.pool.ntp.org), nach reboot war die aktuelle Zeit wieder da



    Ich habe dann testweise den Zeitserver über die GUI wieder gelöscht und manuell in der settings konfiguriert:

    Code
    1. Timeservers=de.pool.ntp.org;


    nach reboot hat die Box auch wieder die aktuelle Zeit, auch mit dem 15 stelligen Zeitserver





    Ergo: Timeserver über die GUI oder manuell über das Terminal in den settings setzen, sonst ist nichts mehr zu tun

  • Neu geflasht (unstable dm920-20190309), ohne settings restore und die dm920 hängt nur am LAN; also keine Tunerkonfiguration und kein Satkabel.


    Nach eingeben von den Netzwerkeinstellungen (dhcp aus) wieder reboot und keine (wired) Netzwerkeinstellungen aktiv.
    Habe versucht in connman ethernet_000934xxxxxx_cable settings: AutoConnect auf true zu setzen, aber wird nicht akzeptiert (auch nicht wenn enigma2 gestoppt worden ist)
    Also nach reboot wird nie das Netzwerk gefunden denn AutoConnect bleibt immer auf falsch stehen.


    1. Leider hat DP immer noch nicht den Fehler behoben und muß immer noch Fred seine Lösung mit "networkwd.sh" (angerufen in rc.local) genutzt werden (habe ich jetzt noch nicht getan).


    Dann ist die Systemzeit immer noch falsch; mit und ohne config.misc.useTransponderTime=false in E2 settings


    Übrigens kann man im GUI die useTransponderTime nirgendwo auf falsch setzen, daß muß immer manuel in settings eingetragen werden, oder...



    Auch im GUI gibt es


    - mit ntp auto und keine Timeserver eingegeben;
    - oder ntp auto und als Timeserver 0.pool.ntp.org;


    immer keine richtige Zeitangabe.


    Was mir aufgefallen ist, daß bei Netzwerkeinstellungen unter Timerserver stehen 2 einträge:


    - meine gateway bzw dns server (sind beide gleich hier) und
    - 0.pool.ntp.org


    k.A. ob das so gut ist, aber wie geschrieben keine richtige systemzeit.



    In /var/lib/connman/settings steht unter [global]:
    OfflineMode=false
    Timeservers=de.pool.ntp.org;


    2. Was bedeutet: OfflineMode=false ?


    3. Nach neu flashen leider immer noch nicht die richtige Systemzeit

  • flash noch mal neu oder mache einen system reset und richte das Netzwerk neu ein
    in den Netzwerksettings auf MENÜ -> NTP Zeit-Aktualisierungen auf "automatisch"
    mit GREEN einen Timeserver hinzufügen, es wird defalut "0.pool.ntp.org" vorgeschlagen


    speichern und rebooten


    mehr habe ich gestern nicht gemacht und es hat sofort funktioniert


    Alterativ einen Timeserver mit 15 Stellen wie de.pool.ntp.org über die settings hinzufügen war nur optional, um zu sehen ob es funktioniet

  • @Fred Bogus Trumper,
    danke für die Infos, habe es wie empfohlen wieder entfernt und auch mit GRENN den default hinzugefügt und somit hat es auch funktioniert.
    Habe zwar noch in der Anzeige zwei verschiedenen stehen, aber das kann ich ja noch ändern , da 15 (de) per Menü nicht geht.
    Hier sieht es im Moment so aus:

    Code
    1. [ethernet_000xxxxxxxx_cable]
    2. Name=Wired
    3. AutoConnect=true
    4. Modified=2019-03-09T23:27:17.226156Z
    5. IPv4.method=dhcp
    6. IPv4.DHCP.LastAddress=192.168.2.29
    7. IPv6.method=auto
    8. IPv6.privacy=disabled
    9. Timeservers=de.pool.ntp.org;

    wobei ich den Eintrag Timeservers=de.pool.ntp.org; manuell nach alten Vorgaben hinzugefügt hatte, dieser zwar in der Info angezeigt wurde aber scheinbar keinerlei Einfluss hat.


    und





    Code
    1. [global]
    2. OfflineMode=false
    3. TimeUpdates=auto
    4. TimezoneUpdates=auto
    5. Timeservers=0.pool.ntp.org;
    6. [Wired]
    7. Enable=true
    8. Tethering=false

    wobei ich diesen auch mal auf de.pool umändern werde.

  • also hier funktioniert das ohne einen Timeserver über die GUI in den Networksettings und manuell hinzugefügten de.pool.ntp.org in /var/lib/connman/ethernet_000934xxxxxx_cable/settings


    lass mal den Timerserver in den global settings in /var/lib/connman/settings weg - die habe ich noch nie angerührt, da ist alles default