SSD mit /media/ssd/movie einrichten

  • Hi,


    durch einen Thread im Ihad stell ich mir gerade die Frage bzw. Habe ich es vergeblich versucht meine Aufnahmen nach /media/ssd/movie zu bekommen.
    Hat mal jemand einen Tipp wie ich das am besten anstelle?
    Wenn ich die SSD Aushänge im Gerätemanager und dann wieder einhänge wird die SSD wieder under /media/hdd gemounted.


    Edit: Wäre es möglich im AufnahmePfade Menü als Standard Speichergerät ein SSD Auswahl einzufügen? In welcher *.py müßte das gemacht werden?

  • Hi,


    wenn ich schon eine SSD verwende wäre es doch angebracht das alles in /media/ssd landet.


    @dhwz
    hast du dich im ersten Satz verschrieben und meintest /media/ssd?


    @gutemine
    dann muss ich aber vorher im Verzeichnis /media noch das Verzeichnis /ssd erstellen?
    Das klappt nicht, ich bekomme immer nur /media/hdd als Auswahl. Wenn ich weiter hoch/runter gehe in den Verzeichnissen lande ich irgendwann bei Hard disk, Network mount und Internal Flash.

  • Hi,


    wie es aussieht geht das auch garnicht. Ich kann zwar manuell die ssd auf /media/ssd einhängen aber nach einem Neustart steht dort sofort wieder /media/hdd als Einhängepunkt.
    Es brauch ja keinen Vorteil geben aber von der „Optik“ wäre es schöner, zumindest für mich, wenn das /media/ssd/movie steht weil es ja so richtig wäre.
    Mit den Plugins hast du sicherlich recht aber versuchen wollte ich es trotzdem mal. Es geht ja nicht um den Pfad in der fstab der ist mit eigentlich egal, nur wenn ich schon eine SSD für Aufnahmen verwende sollte es auch die Möglichkeit geben die Aufnahmen nach /media/ssd/movie zu bekommen, schließlich könnte ich ja auch den Internen Flash oder einen Mountpunkt wählen.

  • Hi,


    schade wäre aber echt interessant gewesen, zumindest für mich, das zu lösen. In der Harddisk.py habe ich auch schon geguckt bin mir aber nicht sicher ob ich da was ändern sollte um die SSD bzw. /media/ssd mit anzuzeigen bzw. anzulegen.
    Den Symlink zu hdd gibt es bei mir schon lange nicht mehr. ;)


    Aber mir ist gerade noch was anderes aufgefallen und ich vermute das ist auch nicht so gut für die SSD. Ich habe es jetzt dreimal, auch mit verschiedenen SSD nachgestellt.
    Wenn ich die SSD mit dem Gerätemanager einrichte und initialisiere sollte man ja denken das alles in Ordnung ist. Weil ich zufälligerweise die SSD mit dem PC umlabeln wollte hat GParted auf einmal gemeckert und folgende Fehlermeldung ausgespuckt.
    „Invalid argument during seek for read on /dev/sde“ das habe ich dann ignoriert dann kam „The backup GPT table is corrupt, but the primary appears OK, so that will be used.“

  • Hi,


    gutemine das geht eben nicht. Ich habe dir doch genau beschrieben weshalb es nicht geht bzw. was angezeigt wird bei 2xpvr drücken. Natürlich kann ich nicht ausschließen noch einiges falsch zu machen.
    Im Ihad habe ich dazu gelesen das man den Gerätemanager nicht mehr verwenden soll da sonst wieder alles auf /media/hdd gemounted wird. Jetzt frage ich mich aber wie ich die ssd sonst Minuten soll.
    Ich hatte es ja wenigstens geschafft das ich per manueller Einstellung im Gerätemanger ein ssd Verzeichnis angelegt wurde. Ein mounten und anlegen des movie Ordners habe ich aber nicht hinbekommen.

  • einfach in den Expertenmodus wechseln, dann klappt das auch mit 2x PVR


    und wenn du tunlichtst den GP3 Geräte Manager ignorierst und nur den DM Gerätemanager verwendest kann auch nichts passieren
    lt. IHAD soll man nicht mischen, also für einen von beiden entscheiden


    Warum das so ist musst du im IHAD hinterfragen

  • Hi,


    so jetzt hat es doch geklappt. Es geht über das manuelle Einhängen, keine Ahnung weshalb es gestern einfach nicht wollte.
    Jetzt würde mich noch interessieren ob ich die Änderungen in der fstab einfach so setzen kann und wie ich das überprüfen kann. Die Änderungen werden doch sicherlich wieder überschrieben falls ich mal die ssd per Gerätemanager aus- und dann wieder einhänge?


    Edit: Es läuft doch noch nicht ganz so rund. Der Gerätemanager verliert immer den Mountpunkt wenn ich im AufnahmePfade Menü das Gerät wähle und neustarte. Ich vermute das Problem, siehe Screenshot. Kann ich das irgendwo anpassen?

  • verwendest du jetzt den DMM oder GP Gerätemanger?


    Im DMM Gerätemanager die Platte/SSD entfernen, dann" Einhängepunkt manuel"l zuweisen, OK drükcen und zu /media/ssd navigieren und mit OK bestätigen


    dann werden auch die fstab und settings Einträge korrekt geändert/gesetzt - sicherheitshalber die Aufnahmepfade prüfen


    mehr ist nicht zu tun

  • er hat doch geschrieben, dass er kein GP3.3 verwendet und mit GP4 funktioniert das wie von dir beschrieben, auch wenn man das entsprechende Gemini Plugin installiert hat., der User darf nur den Dream Gerätemanager nicht manuell blockieren.

  • Hi,


    @Fred Bogus Trumper
    soweit geht es ja aber sowie ich in dem Menü auf dem Screenshot die Crucial SSD auswähle und auf speichern gehe ist nach einem Neustart wieder alles mit /media/hdd gemounted.
    Da gibt es doch bestimmt eine *.py in der man zusätzlich einen Mountpunkt setzen kann oder zumindest es auf /media/ssd ändern kann. Ist es die Harddisk.py oder eine andere?

  • geh' in dem DMM Gerätemanger und entferne alle HDD's und SSD's und dann sicherheitshalber rebooten und dann alles neu machen
    das sollte funktionieren


    wenn du den GP Gerätemanager auch schon verwendet hast auch hier alles entfernen


    und wie @Klix schon geschrieben hat:


    notfalls enigma2 stoppen und alle config.storage Einträge rauslöschen
    das geht am schnellsten/einfachsten so:


    Code
    1. systemctl stop enigma2.service
    2. cp -a /etc/enigma2/settings /etc/enigma2/settings.bak
    3. grep -v "config.storage" /etc/enigma2/settings-bak > /etc/enigma2/settings
    4. systemctl start enigma2.service


    und auch in der /etc/fstab alle mounteinträge rausnehmen die die hdd bzw. ssd betreffen


    und wie im IHAD empfohlen: immer nur einen Gerätemanger verwenden - nicht mischen