Probleme mit Aufnahmen auf Server

  • Hi,


    ich habe aus meinen Boxen die hdds ausgebaut und mir ein kleinen Server gebaut.


    Nun habe ich jedoch Probleme, oft bleibt das Bild bei Aufnahmen hängen und es kommen ständig Zahnräder.
    Hat jemand eine Idee was da los ist?


    Der kleine Server basiert auf Debian 9.6 und NFS Freigabe. Gemounted habe ich die Freigaben per Netzwerkbrowser.


    Code
    1. root@Server ~ > cat /proc/fs/nfsd/versions
    2. -2 +3 +4 +4.1 +4.2


    Anbei ein enigma2 log.


    Edit: Gigabit LAN Netzwerk wird möglich sein zwei Sendungen Aufzunehmen und eine zu Schauen?


    Edit2: Hab noch was aus dem log:



  • An der HDD liegt es nicht. Sie ist nicht voll.
    Was mit aufgefallen ist, dass sich die Dreambox über protokoll vers=3 verbindet.
    Wenn ich vers=4 in den Optionen eingebe, dann verbindet sie sich nicht.


    Meiner Ansicht nach ist es ein Bug im DreamOS und das nicht seit gestern.
    Weshalb gibt es immer Probleme mit Dreamboxen und NFS, während mit SMB nicht. NFS "sollte" die bessere Wahl sein, ist es aber nicht. :(

  • Na gut, aber anscheinend gibt es Probleme mit NFS.


    Das hat auch wenig mit der Leistung des Servers zu tun. Samba läuft wie gesagt problemlos.


    Ok, in meinem Fall nicht weiter tragisch. Samba erreicht die volle Gigabit Geschwindigkeit und der prozi lacht darüber, trotzdem sollte NFS mindestens genausogut funktionieren und erste Wahl sein.


    Edit: Aktuelle Linux Distributionen können NFS Version 4.2. Wie veraltet ist der NFS Client im DreamOS? :(

  • Edit: Gigabit LAN Netzwerk wird möglich sein zwei Sendungen Aufzunehmen und eine zu Schauen?

    Da geht noch viel mehr. Ich hatte auch mit 4 HD Aufnahmen und gleichzeitig 1 HD Aufzeichnung abspielen keine Probleme.
    Mehr hatte ich noch nicht versucht.


    Und das alles über NFS auf mein Synology NAS. Also ein grundsätzliches Problem mit NFS auf der Dreambox gibt es nicht.

  • ich glaube auch nicht, dass es an der NFS Version liegt sondern eher an den mount Optionen, am Netzwerk oder ein bug im client oder server bzw. im Netzwerkbrowser (default options?)


    meine olle dm800hd se schafft 2 HD Aufnahmen pararell über nfs (v3) auf einen debian 6 server mit 2x1Ghz und nfs v3
    nfs v4 würde das auch nicht schneller machen ;)


    btw. DreamOS unterstützt NFS bis version 4.1


    hast du schon mal versucht über nfs v3 zu mounten?

  • @aladin25

    Code
    1. root@Server ~ > cat /etc/exports
    2. # This configuration file is auto-generated.
    3. # WARNING: Do not edit this file, your changes will be lost.
    4. #
    5. # /etc/exports: the access control list for filesystems which may be exported
    6. # to NFS clients. See exports(5).
    7. /export/Aufnahmen *(fsid=1,rw,subtree_check,insecure)
    8. # NFSv4 - pseudo filesystem root
    9. /export *(ro,fsid=0,root_squash,no_subtree_check,hide)

    @fred Bogus Trumper


    So sieht der mount über Netzwerkbrowser aus



    Code
    1. 192.168.178.50:/export/Aufnahmen on /media/Aufnahmen type nfs (rw,relatime,vers=3,rsize=8192,wsize=8192,namlen=255,soft,nolock,proto=udp,timeo=2,retrans=1,sec=sys,mountaddr=192.168.178.50,mountvers=3,mountport=40420,mountproto=udp,local_lock=all,addr=192.168.178.50)


    Über NFS brauch ich nur auf dem Server eine Datei zu Kopieren und schon gehen sogar die Aufnahmen kaputt. Über Samba läuft aber alles :thumbsup:

  • Wenn Du ohne Netzwerkbrowser arbeitest, sollte alles funktionieren.
    Einfach unter /etc/enigma2/automount.xml umbenennen.


    In die /etc/fstab eintragen:


    192.168.178.50:/export/Aufnahmen /media/Aufnahmen nfs x-systemd.automount,x-systemd.idle-timeout=360,noauto,timeo=30,retry=0 0 2


    Die Box booten, danach sollte es funktionieren...

  • Testweise auf dem Server den readonly export /export deaktivieren. Hatte mal Probleme mit verschachtelten exports.
    Beim /export/Aufnahmen no_root_sqash hinzufügen, weil die Dreambox als root arbeitet



    Auf der Dreambox den Server abmontieren und nur ein simples mount.nfs4 ausführen
    umount 192.168.178.50:/export/Aufnahmen
    mount.nfs4 192.168.178.50:/export/Aufnahmen /media/Aufnahmen


    und die resultierenden mount-optionen ausgeben.
    grep /media/Aufnahmen /proc/mounts

  • Hallo,


    bin zwar derjenige der kein Ahnung hat und kein English kann...

    @aladin25

    Code
    1. root@Server ~ > cat /etc/exports
    2. # This configuration file is auto-generated.
    3. # WARNING: Do not edit this file, your changes will be lost.
    4. #
    5. # /etc/exports: the access control list for filesystems which may be exported
    6. # to NFS clients. See exports(5).
    7. /export/Aufnahmen *(fsid=1,rw,subtree_check,insecure)
    8. # NFSv4 - pseudo filesystem root
    9. /export *(ro,fsid=0,root_squash,no_subtree_check,hide)





    Code
    1. 192.168.178.50:/export/Aufnahmen on /media/Aufnahmen type nfs (rw,relatime,vers=3,rsize=8192,wsize=8192,namlen=255,soft,nolock,proto=udp,timeo=2,retrans=1,sec=sys,mountaddr=192.168.178.50,mountvers=3,mountport=40420,mountproto=udp,local_lock=all,addr=192.168.178.50)


    Aber wenn ich mir so die Anleitungen vom Englisch anschaue und dann noch ein wenig nachlese und experimentiere kome ich zum folgenden Schluss....


    192.168.178.50:/export/Aufnahmen..... NFS=vers3 Verbindung
    192.168.178.50:/Aufnahmen...... NFS=vers4 Verbindung


    Wieder mal kleines Beispiel von mir und meinem OMV 4.1.8 NAS (Debian 9.7)





    Code
    1. root@dm7080:~# showmount -e OMV-NAS-i7-4770
    2. Export list for OMV-NAS-i7-4770:
    3. /export/Daten 192.168.1.0/24
    4. /export/Media 192.168.1.0/24
    5. /export/Serien 192.168.1.0/24
    6. /export/Musik 192.168.1.0/24
    7. /export 192.168.1.0/24
    8. /export/Filme 192.168.1.0/24
    9. root@dm7080:~#


    Meine Mounts vom PC mittels Autofs:




    Und von der Dreambox mittels systemd:





    Code
    1. # NFS - automounts per systemd für OMV-NAS-i7-4770
    2. 192.168.1.2:/Filme /media/omv-nas/OMV-Filme nfs x-systemd.automount,noauto,retry=0,x-systemd.idle-timeout=60,nolock,rw,timeo=2,retrans=1,x-systemd.device-timeout=2,soft,nofail 0 0
    3. 192.168.1.2:/Serien /media/omv-nas/OMV-Serien nfs x-systemd.automount,noauto,retry=0,x-systemd.idle-timeout=60,nolock,rw,timeo=2,retrans=1,x-systemd.device-timeout=2,soft,nofail 0 0
    4. 192.168.1.2:/Media /media/omv-nas/OMV-Media nfs x-systemd.automount,noauto,retry=0,x-systemd.idle-timeout=60,nolock,rw,timeo=2,retrans=1,x-systemd.device-timeout=2,soft,nofail 0 0


    Also lasst einfach mal das /export/ weg, dann klappt das auch mit NFS=vers4.x.


    zu anderen Dingen sage ich jetzt mal nichts, habe ehh keine Ahnung davon :thumbup:

    MfG EgLe



    Kernel : Linux 5.0.1-1-MANJARO
    GUI : KDE 5.56.0 / Plasma 5.15.2
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH (DRM 3.27.0, 5.0.1-1-MANJARO, LLVM 7.0.1)
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Guybrush2012 :
    Ansonsten kannst du mal folgende Option in der /etc/enigma2/settings probieren.


    config.usage.record_mode=cached_io


    Vorher muss e2 aber mit systemctl stop enigma2 beendet werden.


    Standard ist direct_io. Weil in der Vergangenheit Linux immer Probleme hatte bei Boxen mit wenig RAM. Aber die aktuellen Boxen haben ja doch schon deutlich mehr als die dm7020hd und co.


    Kann helfen.. muss aber nicht. Wobei ich die Meldungen dass der Server nicht antwortet schon komisch finde. Da würde ich den Fehler auch eher beim Server suchen.
    An der nfs version wird es bestimmt nicht liegen.


    Nach setzen der Option musst du wieder systemctl start enigma2 ausführen.


    cya

  • Habs hinbekommen, jetzt sind die Profis hier wieder gefragt :D


    Über Netzwerkbrowser mounten kommt es zu Aussetzer und Engpässe.
    Mount Ausgabe:


    Code
    1. systemd-1 on /media/Aufnahmen type autofs (rw,relatime,fd=57,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
    2. 192.168.178.50:/export/Aufnahmen on /media/Aufnahmen type nfs (rw,relatime,vers=3,rsize=8192,wsize=8192,namlen=255,soft,nolock,proto=udp,timeo=2,retrans=1,sec=sys,mountaddr=192.168.178.50,mountvers=3,mountport=40696,mountproto=udp,local_lock=all,addr=192.168.178.50)


    Wenn ich so Manuell Mounte, läuft es 1a.


    Code
    1. mount -t nfs -o nolock,nfsvers=4 192.168.178.50:/export/Aufnahmen /media/Aufnahmen/


    Getstet mit 3x Aufnahmen, 1x Aufnahme Abspielen, 1x Tablet Streaming, 1x Laptop zum Server Dateien Kopieren



    Mount Ausgabe:




    Code
    1. systemd-1 on /media/Aufnahmen type autofs (rw,relatime,fd=57,pgrp=1,timeout=60,minproto=5,maxproto=5,direct)
    2. 192.168.178.50:/export/Aufnahmen on /media/Aufnahmen type nfs (rw,relatime,vers=3,rsize=1048576,wsize=1048576,namlen=255,hard,nolock,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.178.50,mountvers=3,mountport=40696,mountproto=udp,local_lock=all,addr=192.168.178.50)


    :rolleyes:

  • Konnte sogar damit in nfs4 mouten. Läuft 1a


    4x Aufnahmen, 1x Abspielen über AMS und auf Server vom Laptop Kopieren.


    Code
    1. mount -t nfs -o nfsvers=4,rsize=8192,wsize=8192 192.168.178.50:/Aufnahmen /media/Aufnahmen/


    Code
    1. root@dm920:~# mount | grep 192.168.178.50
    2. 192.168.178.50:/Aufnahmen on /media/Aufnahmen type nfs4 (rw,relatime,vers=4.0,rsize=8192,wsize=8192,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.178.21,local_lock=none,addr=192.168.178.50)
    3. root@dm920:~#


    :thumbsup:



    Edit: Protocoll tcp ist die Rätsels Lösung.



    @Ghost
    Eventuell sollte über default "tcp" im Netzwerkbrowser nachgedacht werden.
    Die Option "nolock" ist ebenfalls nicht mehr Zeitgemäß und sollte weg gelassen werden.



    @all
    Vielen Dank für die Hilfe :)

  • Ansonsten kannst du mal folgende Option in der /etc/enigma2/settings probieren.



    config.usage.record_mode.value=cached_io

    Bist du sicher, dass das so korrekt ist, ich habe das vorhin mal ausprobiert und mit diesem Eintrag in der settings Datei startet die Box nicht mehr?!
    Ich habe es dann mal so probiert config.usage.record_mode=cached_io (also ohne .value) - damit startet die Box dann zwar wieder, aber ob die Einstellung jetzt greift, weiß ich nicht.