TS Panel for OE 2.0?

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • TS Panel for OE 2.0?

      I recently upgraded my Dreambox from OE 1.6 to OE 2.0 and the TS Panel 4.5 no longer works.

      I have obtained following packages.

      tspanel_3.7-r1_dm800se.ipk

      enigma2-plugin-extensions-tspanel_4.5_mipsel.ipk

      I used the second package with OE 1.6 and it worked. Now it doesn't install.

      Quellcode

      1. Unknown package 'enigma2-plugin-extensions-tspanel'.
      2. Collected errors:
      3. * pkg_hash_fetch_best_installation_candidate: Packages for enigma2-plugin-extensions-tspanel found, but incompatible with the architectures configured
      4. * opkg_install_cmd: Cannot install package enigma2-plugin-extensions-tspanel.

      I think this is due to different Linux version. What do you think?

      Does anyone here have a newer version of TS Panel? Do you recommend something else instead?
    • It installed. But it seems I ran out of memory. Now I'm stuck with a GSOD and I can't seem to remove the package. I can't even list installed packages...

      Quellcode

      1. opkg list-installed
      2. Collected errors:
      3. * opkg_conf_load: Could not create lock file /var/lib/opkg/lock: No space left on device.

      The GSOD also mentions space constraints being the problem. I can't even reboot or put it into standby without getting a GSOD.

      Help?...
    • Neu

      I think you should install TSimage_5.0 (OE2.5). It works well and your plugin is inside and works like it should. I think, here in this forum such paneels are displaced.
      Regards, Renard

      Sorry, now I saw, it is for OE2.0, so you should install TS-Image for OE2.0, this is also possible.
      1DB 920UHDs, 1 DB 8000 PVR HD

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Renard ()

    • Neu

      dhwz schrieb:

      Please reinstall it from command line. Copy the *.ipk to /tmp then do "opkg install /tmp/*.ipk" and post the log if you get an error.

      Quellcode

      1. root@dm500hd:/var/volatile/tmp# opkg install enigma2-plugin-extensions-tspanel_8.0_all.ipk
      2. Collected errors:
      3. * opkg_conf_load: Could not create lock file /var/lib/opkg/lock: No space left on device.
      4. root@dm500hd:/var/volatile/tmp#

      dhwz schrieb:

      I think you have actually not enough free space in flash?

      Quellcode

      1. Filesystem Size Used Available Use% Mounted on
      2. /dev/root 59.0M 58.4M 644.0K 99% /
      3. devtmpfs 65.9M 0 65.9M 0% /dev
      4. none 66.0M 3.1M 62.8M 5% /var/volatile


      dhwz schrieb:

      Use Flodder to extend your flash size on USB.
      Where do I get this and how does it work?
    • Neu

      I understand. But get this. I used the same box... with Enigma2 and TS panel before... physically... nothing has changed. What changed is that the OE 2.0 image is fatter than the 1.6. And so is TS panel 8.0 compared to 4.5. So yes, I am just speculating... but maybe... maybe e.g. TS panel 7.0 has a smaller footprint than version 8.0 but still works with OE 2.0. I wouldn't know for sure without testing. Before I can do that though I need to restore the box to its previous working state. Not sure how to go about with that though...

      What I'm getting at is squeezing in the TS panel despite the limited hardware capacity of the DM500 HD. I realize it may sound dumb to do this on an old box, but it should be just a matter to swapping out TS panel 8.0 and putting in 7.0 or whatever the first OE 2.0 compatible version is.

      Anyways... any suggestion how to restore the box to working state? I am now getting GSOD again when doing soft reset and I can't have that. I need to somehow clear the /dev/root.
    • Neu

      dhwz schrieb:

      you need to flodder your flash
      Such as?... flodder-boottool_0.1.3_all.rar?

      Just so I know what I'm looking for.

      There is also one called FlashExpander. Not sure if it's OE 2.0 compatible...

      enigma2-plugin-extensions-tspanel_8.0_all.ipk

      What does "all" mean here? All... dreambox models?... all architectures?...

      flodder-boottool_0.1.3_all.rar

      I keep seeing this naming convention... there it is again... "all".

      Notice how my file is named: enigma2-plugin-extensions-tspanel_4.5_mipsel.ipk

      It says "mipsel". Call me crazy, but doesn't that mean that this plugin only works with MIPS based boxes? And that its footprint is smaller? Of course, PPC has not been used since 2007 so most boxes will have a MIPS processor.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ssh ()

    • Neu

      Example...

      gnome-icon-theme_3.12.0-3_all.deb

      gnome-icon-theme-3.12.0-x86_64-1rl.txz

      I am no Linux expert but it looks like "all" indeed refers to all architectures and is used when compilation is not needed, otherwise the architecture is included in the name. This seems to be a common naming convention in Linux community.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ssh ()