Unable to step into Second Stage Loader

  • Hello again!


    I tried to step into Second Stage Loader as described on the following two pages.


    Flashing a new firmware by Browser


    Flash over the network


    I get a network link and I get a static IP from my gateway. I also get a nice confirmation on the TV. :thumbup:


    "Link: OK
    Mode: 100 Full"


    But when I go to the IP address in my web browser, it just keeps loading. I then get a reassuring "connection has timed out" message. :thumbdown:


    What's might be the problem? Static IP? I don't think this could cause this kind of problem, it should not matter if it's dynamic or static. Corrupted Second Stage Loader? Too old Loader? It's build "#84 (2011-09-01)". 8|


    I even tried to append "upgrade.dhtml" to the URL to no avail.

  • From the link above:


    "In some cases the IP number can cause problems. Therefore it's possible to enter a static IP number in the Bios of the boxor to use the tool DreamEnum."


    I don't know what DreamEnum is, but this seems to suggest that it is in fact a good thing that my Dreambox has a static IP. However this is set on the DHCP server, not on the Dreambox.


    Dreambox Bios
    "In newer Dreamboxes it's possible to enter the Bios to change or verify settings."


    I see that "DM 500 HD (v2)" is listed. Is it possible to enter the BIOS on my Dreambox? How do I know if I have "v2"?


    I don't think I have a v2, I think mine is v1, but I am not sure.


    How do you even enter the BIOS? If it is a v2 I should be able to enter its BIOS setup program, otherwise I will know it's a v1. No instructions are given on that page.

  • How do you even enter the BIOS? If it is a v2 I should be able to enter its BIOS setup program, otherwise I will know it's a v1. No instructions are given on that page.

    How do I get into the bios?
    "It's the same procedure which is used for flashing the box, take a look at DMM."


    So since I am at the said flashing stage already, I should be able to telnet into my Dreambox. Except I can't. Either because it's not reachable or because I have a v1 which does not support entering BIOS utility via Telnet.


    Is that right version 1 of DM500HD has no way of entering its BIOS?


    Not sure if this would be productive anyway. I guess this leaves me with only one option: DreamUp.


    There is no point in deleting boot files. My problem is not that I can't get into flashing mode, my problem is that I can't reach the Dreambox over the network despite having an IP address.


    Is there a way to flash over the web interface? Or maybe connect to the Dreambox with a network cable directly, P2P?

  • I said all old boxes have a BIOS including DM500HD and v2 is nothing special just other flash memory.

    Yes, I saw your post too late. Sorry about that.


    About portable app... would that be a Portable App app? I can't find any official release of portable Firefox 3.5. Just checking.


    https://portableapps.com/apps/internet/firefox_portable


    Because this download is a special PAF format that I assume requires the Portable App platform.


    On the other hand... I was able to get into BIOS by telneting into it just as described in the articles above. Since my Dreambox does not have built in WiFi support, I have it connected to a wireless AP. So what I did is I took a network cable and connected the Dreambox directly to the router. That way I was able to get into BIOS. Why does wireless link fail?... I still get the same IP and everything.


    Anyway... I am still unable to get to the flashing page. I will try a different browser and maybe an older version of Firefox if I can get it to work.

  • Never mind old Firefox, I got this working in latest Firefox DE. I got to the flash page. The tip is to use Private Browsing to get rid of old cached content.


    Problem solved!


    Still not sure why a wireless AP link would fail... any idea? Why does it have to be a wired connection?

  • WiFi is only working when the box is running, the Secondstage is no running OS -> no OS -> no drivers -> no WiFi

    Why would I need drivers though? I am not using a USB WiFi adapter/dongle if that's what you mean. I have a network cable between the Dreambox and a wireless AP device which connects to the router and hands over an IP to the Dreambox. The Dreambox thinks it's connected to the router directly.

  • If you're not using USB WiFi, you use wired Ethernet as the connector to your Dreambox. That's all that matters in this regard.


    As you pointed out yourself: for the Dreambox this is not WiFi then.