Windows Netzwerkfreigabe mit Samba

  • Habe ein DM525-Combo was unter 4.3.1 experimental lief. Die Box war unter Windows im Heimnetz zu sehen und konnte Dateien bearbeiten. Habe jetzt 4.3.1 stabil drauf geladen. Jetzt sagt Windows permanent 'Sie haben nicht die Berechtigungen um ..... blablabla'. Keine Ahnung warum das jetzt ist. Habe die /etc/Samba/samba.conf gleich gelassen d.h. nicht angepasst..

  • Nochmal samba.conf angesehen und da war tatsächlich ein Tippfehler drin.. reag-only = no statt read-only = no. Angepasst und neu gestartet. Jetzt kann ich wenigstens die Unterverzeignis öffnen aber schreibrechte gibt's leider immer noch nicht...

  • Alles nachgelaufen. Anscheinend ist nicht der Box sondern Windows 7 das Problem. Samba1 ist aus sicherheitsgründe ausgeschaltet. Bin jetzt von 12:00 Uhr damit beschäftigt es an zu passen in meinem Laptop. Leider ist die auf holländisch eingestellt und finde die Programteile einfach nicht. Auch das 'Control Panel' hat die eingaben einfach nicht die Microsoft anzeigt... Keine blasse Ahnung wie weiter zu gehen...

  • Ich habe auch noch Windows 7 im Einsatz und keinerlei Probleme auf den Zugriff des samba share der dm900/dm7080.


    Wie sieht den deine smb.conf aus?

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • Irgendwo hatte mal jemand aufgelistet, welches DreamOS (also je nach Modell) welchen Kernel hat.
    Die älteren Kernel können kein SMB2.
    Auf der DM9x0 ist das alles kein Problem, die kann SMB2.
    Ich meine aber mich zu erinnern, dass es schon bei der 7080HD nicht funktioniert.


    Unter Win7 SMB1:
    Mit regedit unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters
    den Wert 'SMB1' anpassen, wobei 0 = deaktiviert / 1 = aktiviert


    Evtl. sind auch die lokalen Richtlinien (gpedit.exe) verstellt.
    Im Zweifelsfall nachschauen unter:
    Computerkonfiguration > Windows-Einstellungen > Sicherheitseinstellungen > Lokale Richtlinien > Sicherheitsoptionen
    und dort alle Richtlinien die mit "Microsoft-Netzwerk" und "Netzweksicherheit" kontrollieren.
    Die Defauleinstellungen müssten wie auf dem Bild aussehen.



    Evtl. auch anders herum probieren, um die Kommunikation grundsätzlich zu prüfen.
    Freigabe auf Windows-PC anlegen und darauf achten, dass die Berechtigungen für die Freigabe UND für das freigegebene Verzeichnis ausreichend sind, so dass der verwendete Benutzer dort auch vollen Zugriff hat.

    Grüße
    ...jp

    Edited once, last by juanito_perez ().

  • die smb.conf sieht eigentlich gut aus


    Auf meinem Windows 7 Rechner habe ich bzgl. Samba eigentlich nichts verändert und ich hatte auch mit Widnows 10 nie Probleme wie andere


    Könnte daran liegen, dass mein linux Homeserver als Samba Master Browser definiert ist, sonst reisst sich ein Windows Rechner den Master unter den Nagel ....


    Die Box in die gleiche Arbeitsgruppe wie den/die Windowsrechner konfigurieren und als master definieren und zumindest einen guest user account erstellen

    Code
    [global]
    workgroup = Arbeitsgruppe
    preferred master = yes
    local master = yes


    sieh auch z.B. hier: http://www.linux-praxis.de/linux3/samba6.html


    Wichtig: nur einen sambaserver im Netzwerk als Masterbrowser definieren!


    danach box und PC neustarten


    wenn das nicht hilft, kannst du es ja wieder rausnehmen

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • Im ersten war die SMB1 Wert überhaupt nicht drin. Neues DWORD eingefügt und auf '1' gesetzt.
    Rechner neu gestartet. Hat nix getan. Immer noch Schreibefehler...


    Am Box Samba.conf angepasst wie im Beitrag. Auch neu gestartet. Kein unterschied..


    Das Fenster wie im gpedit.exe habe ich nicht (finde es einfach nicht). Gpedit.exe existiert einfach nicht auf dem laptop...

  • Das bringt dir jetzt zwar nicht viel, aber an der smb.conf wird es nicht liegen.
    Da bist du nun auf dem richtigen Pfad bei Windows zu suchen.


    Denn diese smb Freigabe hatte bei mir immer funktioniert, auch dazumal unter Windows 7 und jetzt unter Windows 10.


    Ich hatte bisher eher den umgekehrten Fall, das ich diese Freigabe nicht will, weil sonst jeder im Netz über die Dreambox auf das gemountete Aufnahme Verzeichnis am NAS schreibrechte hat.
    Wenigstens habe ich durch diesen Trend endlich mal die smb.conf geändert das kein Zugriff mehr besteht. :D

    >> Wir Schweizer haben die Uhren, aber keine Zeit ! <<

  • kein GPEDIT => Ist eine Home Version.


    Da wüsste ich jetzt leder auch keine Möglichkeit, wie das bei dieser Win-Edition die lokalen Richtlinien bearbeiten kann.


    edit: Probier' mal Ausführen-->secpol.msc

    Grüße
    ...jp

  • Hallo,


    ich hatte soetwas mal bei meiner Fritzbox, die nur SMB1 versteht.


    Hier die Anleitung von deren Seite:



    Falls Sie SMB 1.0 auf Ihrem Windows-Computer deinstalliert haben, können Sie das Protokoll so wieder installieren:

    • Tragen Sie im Suchfeld der Windows-Taskleiste sys ein und wählen Sie dann "Systemsteuerung" aus.
    • Wählen Sie rechts oben unter "Anzeige" den Eintrag "Kategorie" ([Blocked Image: https://service.avm.de/support/media/de/269.png]).
    • Klicken Sie auf "Programme" und dann auf "Programme und Features".
    • Klicken Sie auf "Windows-Features aktivieren oder deaktivieren".
    • Aktivieren Sie im Fenster "Windows-Features" die Option "Unterstützung für die SMB 1.0/CIFS-Dateifreigabe" und klicken Sie auf "OK".
    • Klicken Sie zum Abschluss der Installation auf "Jetzt neu starten".

    Grüße

    bendszke Fan

  • Auch versucht, leider gibt's die Einträge bei mir überhaubt nicht....

  • Kann ich bestätigen.


    Auf aktuell gepatchten Home Premium und Ultimate gibt es diesen SMB-Eintrag nicht (mehr?).


    Irgendwo habe ich das aber schon mal gesehen. Könnte aber auch sein, dass es Win10 oder WinServer war.


    Zur Home Premium findet man sehr wenig zum Thema SMB1.


    Bisher habe ich nur das gefunden, was ich oben geschrieben habe:
    Mit regedit unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters
    den Wert 'SMB1' anpassen, wobei 0 = deaktiviert / 1 = aktiviert


    Dazu gab es den Hinweis, dass der Key ggf. erstellt werden muss (wenn nicht vorhanden).
    Nach der Änderung muss der Rechner neu gestartet werden.


    Ich nehme aber mal an, dass du das alles gemacht hast?


    Weil ich zufällig gerade ein Win 7 Home Premium PC da habe, habe ich den Zugriff auf die Dream (dm900) ausprobiert.
    Bei mir klappt es mit der Windows-Standardinstallation sofort. Ja, auch schreiben.


    Meine smb.conf

    Grüße
    ...jp

  • mal schauen ob das hilft ?

    Code
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
    "AllowInsecureGuestAuth"=dword:00000001

    >>>>>>>>>>>>>>>>>>>>>>>>>
    MfG Unique

    DM 920 ultraHD OE 2.5

  • Leider. Hat auch nix gebracht... Habe Windows 7 gelöscht und ein altes Windows XP installiert. Laptop wird nur für Dreambox installationen/verwaltung genützt... Habe absolut kein Bock um damit rum zu fummeln. Hat immer gearbeitet, automatische Update drauf und nix geht mehr... Na prima, dann eben nicht...

  • Das war der einzige Eintrag, den ich gesetzt habe,unter Windows 10 und keinerlei Probleme.

    >>>>>>>>>>>>>>>>>>>>>>>>>
    MfG Unique

    DM 920 ultraHD OE 2.5

  • Die habe ich auch.. Kein Problem.. Öffnen (lesen geht bestens) aber schreiben geht nicht. Problem mit berechtigungen oder was... Samba v1 ist ausgeschaltet und daher geht's nicht mehr. Microsoft Technet lösungen ändern da nix. Die aufgelistete Bildschirm Bilder gibt's bei mir einfach nicht. Windows Teile installieren/löschen SMB1/CIFS gibt's auch nicht.... Da bin in dann weiter übervordert. 3 Tage mit Google das inet befragt.. Kein Lösung...


    Na dann eben nicht mehr... Habe besseres zu tun...

  • Also ich kann hier auch schreiben, ohne Probleme, wechsle meine *.bins oder *.py bearbeiten geht ohne Probleme.
    Wenn du da nicht schreiben kannst ist es doch eher eine Berechtigung von der Box, als von Windows.

    >>>>>>>>>>>>>>>>>>>>>>>>>
    MfG Unique

    DM 920 ultraHD OE 2.5

  • Vielleicht kannst du dein samba.conf hier mal posten? Zur vergleich...