DM920 worng winter time ( same timezone )

  • @Reichi
    still no joy :(


    after update things went only worse, time diff now is two hours not one as before


    first is GMT+1 (Berlin), last is GMT+3
    all between are each GMT+2


    what is wrong here?

  • no update YET


    writing again just to write something?


    before update

    Code
    1. root@dm900:~$
    2. root@dm900:~$ grep "GMT+02:" /etc/timezone.xml
    3. <zone name="(GMT+02:00) Athens, Istanbul, Minsk" zone="Europe/Istanbul" />
    4. <zone name="(GMT+02:00) Bucharest" zone="Europe/Istanbul" />
    5. <zone name="(GMT+02:00) Harare, Pretoria" zone="Africa/Harare" />
    6. <zone name="(GMT+02:00) Helsinki, Kyiv, Sofia" zone="Europe/Istanbul" />
    7. <zone name="(GMT+02:00) Riga, Tallinn, Vilnius" zone="Europe/Istanbul" />
    8. <zone name="(GMT+02:00) Jerusalem" zone="Asia/Jerusalem" />
    9. root@dm900:~$



    after update



    also why "Riga, Tallinn, Vilnius" were split when all of then live together in the same EET ?

  • writing again just to write something?


    Unlike you, I can read.


    Read the commit text completely it's required to update tzdata Europe.
    Just changing timezone.xml will not fix anything. So please wait till OE Feeds get updated before complaining.


    timezone.xml: fix european timezones (requires tzdata-europe)

  • just install tzdata-europe and you're fine... But going only half way is kinda pointless ;).


    EDIT: You may have to RE-select the timezone after tzdata-europe is there, i guess it's currently broken (but i'm not sure).

  • @Reichi
    THANK You very much!
    after execute `apt install tzdata-europe` time for Riga is corrected now
    and all other GMTs+2 too, except Kyiv shows GMT+0
    my guess, filename `/usr/share/zoneinfo/Europe>Kiev` doesn't match
    to `<zone name="(GMT+02:00) Kyiv" zone="Europe/Kyiv" />`


    got again network = none after first reboot,
    but in case box were recently reflashed
    i didn't restore network watchdog script from rc.local yet
    and can't show any logs :(



    @dhwz
    where else i have to ask such kind of questions?
    i have made apt update + upgrade, saw there is waited fix in the timezone.xml
    but result were completely opposit