[DreamOS] fake-hwclock

  • Ich hab' mir fake-hwclock aus den debin sourcen gefisht und ans DreamOS angepasst.


    Warum?

    • Wenn die Zeit über die Transponderzeit geholt wird, bekommt die Box recht spät eine aktuelle Zeit und das journal spuckt ewig 1970-01-01 aus, wenn man einen log oder einen journal dump mit Zeitstempel in ein file schreiben will, ist die Zeit oft nicht aktuell, weil die Box noch keine aktuelle Zeit erhalten hat. Wenn man später die logfiles auswerten will, ist das schwierig wenn die Zeitstempel nicht stimmen ...
      siehe auch -> DreamOS - DM900: Manchmal kein Netzwerk nach einem reboot
    • Wenn die Transponderzeit deaktiviert ist und die Zeit von einem Zeitserver geholt wird und das Netzwerk beim booten offline bleibt startet die Box mit der Zeit 1970-01-01 00:00 Uhr im Display - auch nicht schön ...


    fake-hwclock schreibt die aktuelle Zeit über einen systemd timer alle zwei Minuten und bei einem shutdown in ein file. Eine Einrichtung eines cronjobs ist nicht notwendig.
    Beim reboot holt sich die Box dann recht früh die Zeit aus dem file und die Abweichung ist dann so um die 15-20 Sekunden bei einem reboot

    Code
    1. Jan 01 01:00:01 dm900 kernel: usb usb1: Manufacturer: Linux 3.14-1.17-dm900 xhci-hcd
    2. Jan 01 01:00:01 dm900 kernel: usb usb1: SerialNumber: f0471000.xhci_v2
    3. Oct 01 00:00:47 dm900 kernel: hub 1-0:1.0: USB hub found
    4. Oct 01 00:00:47 dm900 kernel: hub 1-0:1.0: config failed, hub doesn't have any ports! (err -19)


    die Zeit wird dann später nochmal vom Zeitserver oder vom Transponder von enigma2 aktualisiert



    Ich habe das mit get time vom Transpoder und get time vom Zeitserver mit "config.misc.useTransponderTime=false" in den settings getestet, aber wenn es mit der fake-hwclock doch Probleme geben soll, hier berichten und das plugin einfach deinstallieren und rebooten.