Speichern der letzten Abspielposition (Marker) auch beim Abspielen über nfs-Freigabe möglich?

  • Hallo


    Ich bin immer noch am Einrichten meiner 2. Box ;)
    Da geht es nun auch mal an die Netzwerkfunktionen, die mich bisher nicht tangiert haben.


    Nach einigen Versuchen habe ich nun das ruckelfrei Abspielen über eine nfs-Freigabe hinbekommen.
    Hatte das allgemein bekannte Problem mit "async".
    Warum nimmt man das dann eigentlich nicht als Standard, wenn das ohne meist nicht sauber funktioniert ??


    Nun stelle ich fest, dass dabei die letzte Abspielposition nicht gespeichert wird.
    Beim Beenden und Neustarten einer Aufnahme startet diese immer wieder vom Anfang.
    Wenn man das auf der Server-Box mit direktem HDD-Zugriff macht, klappt das mit dem Speichern der letzten Abspielposition.


    Geht das beim Abspielen von der Client-Box generell nicht, oder ist das ne Einstellungssache ??


    hier mal meine Angaben zur nfs-Freigabe:
    Server etc/exports: /media/hdd/movie *(rw,no_root_squash,async,no_subtree_check)
    Client etc/enigma2/automounts.xml: rw,nolock,udp,async (hdd_replacement=False)

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Ich habe eine SMB Freigabe zu meinem Windows PC und dort funktioniert das Speichern der letzten Position. Es wird ja eine "<aufnahme>.cuts" (oder so ähnlich) Datei erstellt.
    Da du ja die Freigabe mit "rw" gemacht hast, sollte ja geschrieben werden dürfen.
    Aber evtl. ist bei NFS noch etwas anderes zu beachten.

  • smb hab ich auch noch, aber da ruckelt es extrem.
    Deshalb bin ich auf nfs gewechselt.

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Stimmt, bei smb geht das mit dem Speichern der letzten Abspielposition :S
    Nur da ruckelt es bei mir extrem.


    Da muss es offensichtlich bei nfs noch irgendeinen Parameter geben ;)

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Also bei mir geht das über NFS schon Jahre problemlos, auf mein Synology NAS.
    Funktionierte vorher sogar mit einer USB-Platte am Router, war glaube ich sogar cifs.


    Verwendest du nicht systemd zum mounten ?
    Mit dem NetworkBrowser den du erst entdeckt hast, müsste das problemlos gehen
    Damit hatte ich das auch gemacht.
    Lief zwar vorher unter DreamOS auch noch mit automount, das machte dann aber irgend wann plötzlich Probleme.
    Automount wird ja offiziell von DreamOS nicht mehr unterstützt.


    Aber ich meine irgendwer hatte im EMC Tread im IHAD das selbe Problem, aber meinst du ich weiss noch an was das lag. ?(
    Es könnte aber sein, das es was mit den mount pfaden war. Glaube er hatte ein root verzeichniss gemountet und nicht ein Unterverzeichnis...oder so was in der Art ? ?(
    Vielleicht da mal etwas rum probieren. Wenn es dir hilft kann ich mal meine Mounts raussuchen.
    Bin aber auf Arbeit, kann das aber naher mal mit dem Handy über VPN machen.

    >> Wir Schweizer haben die Uhren, aber keine Zeit ! <<

  • Den Datenträger als RW mounten!
    Du hast keinen Schreibzugriff...

    Was soll ich denn da noch ändern ? (ist doch bei beiden rw drin)


    hier mal meine Angaben zur nfs-Freigabe:
    Server etc/exports: /media/hdd/movie *(rw,no_root_squash,async,no_subtree_check)
    Client etc/enigma2/automounts.xml: rw,nolock,udp,async (hdd_replacement=False)

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Puhh, der Netzwerkbrowser hat mir dann die automount.xml angelegt.


    Wie mache ich das mit systemd ???
    Ist wie gesagt totales Neuland für mich :)


    Das steht beim Client bisher in der automount.xml

    Code
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.xxx.xxx.xxx</ip>
    <sharename>dm920_movie</sharename>
    <sharedir>/media/hdd/movie</sharedir>
    <options>rw,udp,nolock,async</options>
    </mount>

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Puhh, der Netzwerkbrowser hat mir dann die automount.xml angelegt.

    Wird schon stimmen, steht am Ende dann in der fstab mit systemd drin.

    >> Wir Schweizer haben die Uhren, aber keine Zeit ! <<

  • Hab jetzt nochmal alles nochmal neu gemacht und jetzt klappt es ;)


    Dein Hinweis zur fstab war da wohl goldrichtig :thumbup:
    (dachte bisher, da stehen nur physische Laufwerke drin)


    Da stand tatsächlich ein doppelter Eintrag für die gleiche Freigabe nur eben mit "ro" drin.
    Warum es dort einen doppelten Eintrag gab, kann ich mir nicht erklären.


    Egal, hab die fstab bereinigt und nun funktioniert das Speichern der letzten Abspielposition :)


    Danke nochmal an alle Helfer :thumbsup:

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Super das du den Fehler gefunden hast.
    Vielleicht eine Leiche vom rumprobieren im mountmanager?


    Mein mount ist ohne async, aber wenn es läuft passt es ja. Vielleicht handelt das mein nas dann anders aus, weil das darf async mounten.
    Da ich den aber eben schon vorher von der box kopiert habe poste ich ihn doch noch.


    >> Wir Schweizer haben die Uhren, aber keine Zeit ! <<

  • Ja, ich werde da bestimmt noch etwas rumspielen, da es gelegentlich immer noch ruckelt.
    Kann aber auch am Netzwerk selbst liegen.
    Wechsle testweise gerade immer zwischen WLAN-Bridge und DLAN ;)
    Kann mich noch nicht so richtig festlegen.

    Gruß Sven (aka Dreamy)


    (DM920 mit unstable OE2.5 DMM)

  • Es geht eben nichts über ein LAN Kabel. :D
    Ich kann mit beiden Dual Tuner Dreamboxen aufzeichnen und gleichzeitig abspielen so viel ich will, ruckler gibt es da glücklicherweise nicht. Beide haben Boxen haben keine Platte verbaut, sondern zeichnen ausschliesslich zentral auf das NAS auf. ;)
    Dann musst dual channel mit DLAN und WLAN zusammen machen. :D:saint: *duckundweg*

    >> Wir Schweizer haben die Uhren, aber keine Zeit ! <<

  • Es gibt Beiträge in anderen Foren, bei denen die "gelegentlichen Ruckler" von günstigen Switches kommen, die nicht alle Protokolle verstehen. Dies aber nur in 1000Mbps LANs, in 100Mbps LANs laufen diese Switches anstandslos.


    Voraussetzung ist natürlich, dass deine WLAN-Bridge oder DLAN-Verbindung genug schnell ist, um wenigstens EIN Sender aufzunehmen oder abzuspielen. Aber dazu müssten ja schon etwa 10-15Mbps (FullHD + ein paar Audiospuren) reichen.


    Bei mir sind alle Boxen/NAS/etc am LAN Kabel. Ausser der Büro-PC: da habe ich eine 5GHz WLAN-Bridge. Da erreiche ich etwa 300-400Mbps.