Dreambox 4K - How to get the correct date and time automatically

  • Hello,



    I use the Dreambox 4K just to get the IPTV programs.I don’t have any satellite dish as it is forbidden where I live.



    Everytime the Dreambox crashes or when I restart it, the system loses the date and hour (it always starts at 01:00) and rarely start with the correct time (Brussels).


    Is it a solution to get the correct date and time automatically ?



    Thank you very much for your help.

  • In Newnigma2 there is a setting (Blue Key - Newnigma2 Services - System Tools;
    Use Transponder Time to No) so that the dreambox gets its date and time from an NTP server and not from any transponder.

  • Then use latest UserScripts Plugin - there in the settings Menu of the Plugin you now can also change the Transponder Time setting ;)

    Edited once, last by Lost in Translation ().

  • Then use latest UserScripts Plugin - there in the settings Menu of the Plugin you now can also change the Transponder Time setting ;)

    Thank you very much for your answer.
    Is the latest version the 5.9.5 ? (enigma2-plugin-extensions-userscripts_5.9.5_all) ?
    I search on the web but almost of the forums I found require an activation code that I never get ( although my mail address is correct).

  • Hello,


    Plugins is now installed, I changed the Transponder Time setting to NO.
    I saved this information.


    if I restarted the Dreambox (OFF/ON), transponder Time setting is set automatically to YES and the time is still 01:00.
    If the Dreambox is in stand by, the Transponder Time setting is still NO.


    I give up but thank you very much for your help.

    Edited once, last by turner6 ().

  • You should not restart dreambox with off on button, do a simple enigma2 restart or reboot from e2 menu then setting should be correctly written to settings file.

  • I followed your instruction but still no sign of a correct hour and it keeps all the settings except the Transponder Timer Time back to YES. Best way is to put the date and hour manually ...

  • Maybe there is something wrong with the configured time server. It should be shown in the network settings. In my Dreambox the IP address of the internet router is used also for the time server, which works fine for my network. I propose that you check the time server settings.

  • did you change the ntp settings at all?


    the are hidden in network settings when you press menu button on remote.

  • Yes I did, default was "automatic" (it didn't work) then I changed it to manual, it didn't work either.


    I simply restarted enigma2 after changing the transponder Time setting to NO (and saved this option).


    When the Dreambox has been restarted, the transponder Time setting is back again to YES.


    Are there information's on the web about the pluging and how to configurate it ?

    Edited 3 times, last by turner6 ().

  • there was an error in versiomn 5.6.9 - please try 5.9.7 now it should work to be set persistent if you save with green in UserScripts configuration.

  • i will try the new version today again. Thank you very much for giving your time :)


    I confess I am a litte confused about the ntp setting: which value is the correct one to get the plugin working, automatic or manual ?

  • Plugin has been updated. I tried both values (automatic and manual). Unfortunately, time is still wrong: starting at 01:00.


    But ALL the values are now correctly saved :)

  • Now you turn off the box, remove power, wait 30 seconds and then you plug in power and rebooot. If NTP is still not giving correct time you fix your NTP server ....

  • Now you turn off the box, remove power, wait 30 seconds and then you plug in power and rebooot. If NTP is still not giving correct time you fix your NTP server ....

    Gutemine, there's nothing wrong with my NTP server. I connected a DUNE HD machine to the same connection I use from the Dreambox (same cable) and I got the date and hour immediately.

  • As Fred wrote you defining correct NTP server so that it is used is not so easy.