OE2.5 Uhrzeit wird nicht mehr von DVB-Time oder ntp bezogen

  • Ist auf -ab und wieder aufgedreht. Weil es keinerlei Auswirkungen hat. Genausowenig wie das dvbtime Plugin.


    Selbst wenn das Abdrehen funktionieren würde: Es ist bestimmt nicht im Sinne einer funktionierenden Box, sie erst auf diese Weise zur eminent wichtigen richtigen Uhrzeit überreden zu müssen.

  • Die box nimmt was gesendet wird - ist es falsch ist es falsch.


    Und bitte beschreibe wie du die Transpondertime abgedreht hast ...


    Und das aktuelle DVB Time Plugin ist nicht von mir, ich habe nur das von JD auf DreamOS angepasst und das dvbdate binary auch noch für armhf compiliert.


    Nachdem da aber ausser geht nicht - und das meiste nicht mal in seinem Plugin und Support Thread - kein Input kommt bleibt das auch so.


    Und der Thread dort ist von 2016 und hat wenn man von meinen absieht genau 3 Replies ....

    Edited once, last by Lost in Translation ().

  • ich weis eh das die Leute die Einstellung bei laufendem enigma2 in die setings machen und sich dann wundern das es nicht greift oder vergessen das ihr Router keinen NTP support hat, etc ...

  • DMM bräuchte nur disable Transponder Time und ein Zeitserver Setup in die Netzwerkeinstellungen basteln dann wäre vieles einfacher


    z.B. wenn ein Zeitserver hinterlegt wird - nicht automatisch die Router IP, die nicht in den connman settings gesetzt wird - die Transpondertime automatisch disablen ...

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox


    • Netzwerkeinstellungen -> NTP Server auf "manuell geschaltet -> Uhrzeit 2 Minuten in der Zukunft
    • config.misc.useTransponderTime=false -> funktionslos. Nach Setzen und Kaltstart -> Uhrzeit 2 Minuten in der Zukunft


    • dvbtime: "Überprüfen und aktualisieren über Zeitserver" - Erfolgsmeldung, aber die Uhrzeit ist weiterhin 2 Minuten in der Zukunft


    • dvbtime: "Systemzeot ändern" -> Uhrzeit ist 2 Minuten in der Zukunft


    • Shell: date hh:mm eingegeben -> Uhrzeit ist 2 Minuten in der Zukunft


    Alle Varianten mit Tunen auf jeweils einen Sender im DVB-T Bouquet, DVB-C Bouquet und DVB-S Bouquet mit jeweiligem Kaltstart dazwischen. "Böser Kabelprovider" fällt damit schon mal flach.



    Ich habe an keiner Stelle behauptet, dvbtime stamme von dir? Du liest manchmal selektiv :D

  • Hallo Fred:


    weiter geforscht. Box ausgeschaltet und ohne Netzwerk hochfahren lassen. Nach Tunen auf einen ARD Kanal synchronisiert sich die Uhrzeit KORREKT. Ok, also der ntp Server.


    Nach Editieren von /var/lib/connman/ethernet_000934xxxxxx_cable/settings und dem von Dir vorgeschlagenen Einfügen eines Timeservers scheint nun der Spuk erst einmal vorbei. Alle vorherigen Methoden (Netzwerkeinstellunegn -> Menü->NTP Server auf manuell, NTP Sync mit dvbtime Plugin ...) haben nicht funktioniert.


    Danke für die Hilfe! Jetzt inspiziere ich erst einmal den ntp Server der Fritte. Die hat nämlich angeblich die ganze Zeit die korrekte Zeit.

  • @dreamer-flt


    das funktioniert leider so nicht


    entweder den Zeitserver wie verlinkt in die connmann settings machen oder, wenn du manuell die Zeit ändern willst bzw. kannst:


    systemctl disable time-sync.target
    reboot



    das time-sync.target verhindert das manuelle setzen der Zeit


    wenn man das time-sync.target wieder aktiverten will, muss man /lib/systemd/system/time-sync.target manuell editieren, sonst klappt das enable nicht


    Code
    1. + [Install]
    2. + WantedBy=multi-user.target

    wenn das time-sync.target wieder erfolgreich enabled ist, kann man die beiden Zeilen wieder rausnehmen



    btw. diesen Workaround hat mir auch @gutemine in einem anderen Threat vor die Nase geschubst ;)
    saber ist das aber auch nicht ...

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • Es geht nicht darum ob der Router die korekte zeit hat sondern ob er auch als NTP Server aktiv ist. Und wenn du die use transponder Time Einstellung in die settings schreibst wenn enigma2 läuft ist es völlig nutzlos, das funktioniert nur bei gestopptem enigma2.


    Und wenn du das rICHTIG abdrehst ist jeder Kaltstart nutzlos weil die Transponderzeit des startsenders dann ignoriert wird.


    Wenn du das Netzwerk abängst damit ntp auch nicht greift bleibt die box dann sogar brav auf 1.1.1970

  • Ich kann nur lesen was du auch schreibst. Und wenn man es richtig macht funktioniert es auch das die Transponderzeit ignoriert wird - nur sind dann Kaltstarts völlig nutzlos (der ntp funktioniert warm genauso), insofern darf ich schon auch wenigstens annehmen das du nicht 100%ig weist was du da tust.


    Ich sage ja nicht das es problemlos funktioniert, sondern nur das nicht alles was du probiert hast auch korrekt gewesen sein muss.


    Ich habe damals das DVBTime kaum gestestet, sondern (falsch) angenommen das die user das erledigen werden. Bei abgedrehtem ntp und abgedrehter Transponderzeit konnte ich aber mit date in telnet, dvbdate oder einem expliziten ntpdate Befehl die Zeit der box setzen, und nach e2 restart war das auch die e2 Zeit.

  • dann mach die Fritten IP in die connman settings, dann sollte das eigentlich klappen


    E2 schreibt die IP bzw. die FQDN nicht automatisch rein - auch wenn die GUI sagt, das die Router IP als Zeitserver hinterlegt ist ...

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • dann mach die Fritten IP in die connman settings, dann sollte das eigentlich klappen


    E2 schreibt die IP bzw. die FQDN nicht automatisch rein - auch wenn die GUI sagt, das die Router IP als Zeitserver hinterlegt ist ...


    Ja, das war der entscheidende Fingerzeig von dir. Der Zeitserver wird zwar im GUI angezeigt, wird aber in besagtem Setting nicht hinterlegt. Sobald dies geschehen ist (oder man mit deaktiviertem Netzwerk bootet so das Enigma gezwungen wird sich die Zeit über DVB zu holen), ist bei mir die Uhrzeit korrekt.


    Danke nochmals.


    Testequipment war übrigens eine 920UHD. Insofern vielleicht interessant, da das Netzwerk dort erst ein paar Sekunden NACH dem Start von Enigma überhaupt up ist.

  • wie gesagt, mit vom Timeserver gesetzter Zeit bootete die dm900 damals bei meinen Tests gut 5 Sekunden schneller, bzw. hatte ich auch schneller ein Bild (Free TV)


    Ich hatte damit rumgespielt, weil ich im journal so früh wie möglich eine Systemzeit wollte, aber das hat weder mit NTP Time noch gebastelter fake-hwclock funktioniert, die relevanten Systemdienste starteten lt. systemctl status immer am 1.1.1970 und ein paar Sekunden

    Gruß Fred

    Die Dreambox ist tot, es lebe die Dreambox

  • ...Wobei man sagen muss, dass ich auf Astra 19.2 die Zeiten der deutschen Sender okay finde. Da weicht nicht viel ab.. +- 5 sekunden.. das ist alles im Rahmen...

    Ich wollte mal schauen, welche Sender betroffen sind und habe meine 50 häufigsten durchgezappt. Die Infobar braucht jenachdem ein bis fünf Sekunden, bis sie die vom Sender kommende Uhrzeit neu anzeigt. Zu meiner Überraschung waren die zwei Ausrutscher in Sachen genaue Uhrzeit ausgerechnet bei deutschen Sendern auf Astra 19.2 zu finden:


    - ZDF HD: 35 Sekunden Abweichung!!
    - 3Sat HD: 7 Sekunden Abweichung


    Alle anderen Sender zeigen bei mir nur ein oder zwei Sekunden Abweichung.


    Aufgrund dieser Ergebnisse bin ich nun doch motiviert, für die Zeiteinstellung auf der Dreambox nicht DVB sondern einen Zeitserver als Quelle zu nehmen. Der Thread lässt mich momentan ein wenig ratlos zurück. Wie kann ich am einfachsten auf Zeitserver umswitchen?

  • in /etc/enigma2/settings die transpondertime disablen, wenn es im Image keine GUI Einstellung dafür gibt:


    enigma2 stoppen:


    systemctl stop enigma2.service


    settings editieren

    Code
    1. config.misc.useTransponderTime=false


    timeserver als IP oder FQDN in den connman settings hinterlegen und rebooten oder das connman.service neu starten und dann wieder enigma2 sollte auch reichen


    die Lösung ist auch in Post #63 verlinkt

  • @Ghost
    Wird die Systemzeit eigentlich regelmäßig durch die Transponderzeit korrigiert?
    Ich habe meine DM900 seit März und seitdem zwar jeden Abend abgeschaltet aber nie komplett vom Strom getrennt. Seit einigen Wochen habe ich das Phänomen, dass die Uhrzeit mehrere Sekunden (ca. 30 Sekunden) abweicht. In der Nähe der Box steht ein Internetradio das auch die Uhrzeit anzeigt und das ist dann immer nervig, wenn beide Uhren unterschiedliche Zeiten anzeigen.
    Zudem wird durch die falsche Uhrzeit die Aufnahme meiner Daily Soap einige Sekunden zu früh beendet und mir fehlen am Ende immer die Cliffhanger.
    Ich habe mir jetzt heute damit beholfen die Box für einige Minuten komplett vom Strom zu trennen, danach war die Uhrzeit wieder synchron mit meinem Internetradio.