OE2.5 Uhrzeit wird nicht mehr von DVB-Time oder ntp bezogen

  • Intern musst du doch eigentlich eh immer mit UTC rechnen. Z.B. bei Timern von Sendungen aus unterschiedlichen Zeitzonen. Und dann gibt es auch keine Sommerzeit.

    Gruss
    Dre


    Boxen (im Einsatz): DM920, DM900, DMOne
    Developer Project Merlin - we are OpenSource

  • Ich bin auch für eine eingebaute ordentlich funktionierende Zeiteinstellung. Auch wenn DP kein ntp will, sind die meisten Boxen doch in einem Netzwerk. Von mir aus soll immer ntp-Update probiert werden und nicht vom Transponder. Wenn KEIN ntp funktioniert, dann soll der Transponder herhalten.

    Kann man das nicht als Auswahl machen, entweder Transponderzeit nutzen oder die Zeit aus dem Netzwerk beziehen? Hmmmm,ntp kann man ja ganz versteckt bei den Netzwerkeinstellungen über die Menü-Taste automatisch/manuell umstellen.

  • Übrigens .. nur um es nochmal klarzustellen. Wenn bei Unitymedia die Uhrzeit um 2 Minuten falsch gesendet wird, dann ist das definitiv ein Problem von Unitymedia. Und man sollte es ihnen mal mitteilen.


    Also wenn irgendein Hinterweltsender auf Hotbird,Türksat was auch immer für ein Sat eine falsche Uhrzeit sendet..... was meistens noch irgendwelche temporären Feeds sind.. dann ist das ja noch okay.... aber wenn eine deutsche Kabelgesellschaft es nicht schafft eine ordentliche Uhrzeit zu senden, dann ist das einfach sehr Arm.


    Und man sollte sich bei denen beschwerden, die es verbockt haben!


    cya

  • Habs denen ja schon mitgteilt, mein Problem ist aber eher das DreamOS, das die Uhrzeit nicht mehr zurücksetzt. Für was gibt es eigentlich die Option den Zeitserver manuell zu definieren, wenn der eh somit überflüssig ist?

    In Betrieb
    Dreambox 920uhd-S2X/C
    Ausser Betrieb
    Dreambox 7080HD-S2/C / 8000-S2

  • Ich glaube die Option "NTP Zeit-Aktualisierungen" wurde eingebaut, um per DHCP propagierte NTP-Server stumm zu schalten. Da gab es ja ein paar Fälle mit blöden Provider-Routern, die es nicht geschafft haben die richtige Zeitzone per UTC auszusenden.
    Ich würde "manuell" also so interpretieren, dass NTP nicht genutzt wird.


    In deinem Fall sollte es also korrekt sein "Automatisch" zu nutzen, denn die Fritzbox macht das ja anständig mit der Zeit.
    Die Frage: Was passiert in dieser Einstellung, wenn UM Mist sendet? AFAIK überschreibt NTP doch DVB oder nicht?

    so long
    m0rphU

  • Nein... DVB hat immer Vorrang.


    Sprich spätestens beim zappen wird die Zeit vom Transponder wieder genommen.


    Es sei denn man deaktiviert halt DVB. Was man ja kann.. eben für Leute die den DVB Kram nicht benutzen möchten.


    Da der Normaluser aber DVB nicht deaktivieren will gibts momentan keine Möglichkeit das übers Menü zu machen ohne extra Plugin.


    Man kann es aber in /etc/enigma2/settings eintragen.


    Ich denke ich werde aber einen Menüpunkt mal unter Anpassen einbauen der als Experte sichtbar ist.


    Ist ja nur eine Zeile in der XML.


    cya


    muelleimer321:


    das verstehe ich nicht. Wenn Du es mitgeteilt hast, und Unitymedia es gefixt hat... sprich die Zeit wieder korrekt ist.. dann musste halt die Box einmal auf einen Sender schalten wo es okay ist und die Box runterfahren und Stromlos machen. Solange sie aber die kaputte Zeit weiter senden wird das halt nichts bringen
    Ich mag da aber gerade auch nicht diskutieren.. ich fands nur doof, dass wir für einen Fehler verantwortlich gemacht werden den Unitymedia gemacht hat. Es ging ja Jahre lang.


    cu

  • Falsch Ghost, ich habe Unitymedia es mitgeteilt, korrigiert ist es aber bisher nicht.

    Quote

    Sprich spätestens beim zappen wird die Zeit vom Transponder wieder genommen.

    Genau da liegt ja das Problem, die Zeit ändert sich gar nicht mehr, die bleibt konstant auf 2min voraus stehen. Egal was die Fritzbox zurückliefert, der gute DVB-S2 Transponder oder das DVB-Time Plugin meint.
    Das ist ja gerade das Ärgernis, wenn wenigstens die Zeiten sich ändern/korrigieren würde und nur bei falschen Transponder-Zeiten falsch


    Finde es aber schon mal gut, dass du das Einstellbar machst, Transponder Zeit oder Zeitserver (hoffe mit Fallback, wenn Netzwerk nicht erreichbar, dann nehm DVB-Time)

    In Betrieb
    Dreambox 920uhd-S2X/C
    Ausser Betrieb
    Dreambox 7080HD-S2/C / 8000-S2

  • Ghost hat das doch erklärt, sobald du mehr als 2 min Unterschied hast, egal aus welchem Grund wird e2 es nicht mehr automatisch korrigieren, dann geht nur mehr ihm durchs stromlosmachen die Zeit wegzunehmen damit es neu und richtig geladen wird.


    Und wenn man den ignore Transponder Time Parameter sichtbar einstellbar macht, warum nicht auch einen zweiten machen wo man die 2 min ändern kann zwischen 1 und 30 min mit 2 min als default?

  • das Problem ist aber das die Kabelanbieter oft nach einem Tag drauf kommen das sie >2 min bei der Zeit falsch waren und DANN wenn sie endlich wieder die richtige Zeit senden e2 verweigert die zu nehmen wenn man die box nicht stromlos macht. Dann würde ich auf 5 min stellen bis wieder alles gut ist und dann halt wieder auf 2 min zurück weil sie versprochen haben das es nie nie wieder passieren wird ^^

  • @arki


    Das ist aber wohl eher eine Ausnahme im Bereich "1 von 1000"? Entweder bezieht die Box die Zeit vom DVB oder NTP, da beisst die Maus keinen Faden ab.
    Und wenn die Provider mist senden...naja wurde ja schon erörtert...


    Man könnte auch zusätzlich den NTP Server in GUI definierbar machen, somit könnte man - wenn man einen "kaputten" Router hat - Einen bestimmten im Internet setzen.

  • Hi,


    ich greif das Thema mal auf, da ich es auf meiner DM 7080 (NN2) auch habe und es irgendwie nervt. Ziemlich genau 2 Minuten geht die Box immer wieder vor.
    Und ich habe ausschließlich SAT und habe auch kein Kabelanschluss! Ich schaue nur "normale" deutsche Sender und kein Sky. Der einzig nicht deutsche Sender in meinem Bouquet ist MTV HD.
    Den schaue ich eigentlich nicht, aber EPGRefresh sollte ihn mit ansteuern.


    Kann man sich irgendwo die DVB Zeit der Sender anzeigen lassen oder findet man die nur im log und wenn ja im welchen?
    Würde gern rausbekommen, welcher Sender/Transponder schuld ist... :evil:


    Danke!

  • Hier ebenso.


    • Egal ob mit oder ohne ntp
    • Kaltstart auf einen DVB-C Sender (Primacom)
    • Kaltstart auf einen DVB-S Sender (Astra19°E, Hotbird 13°E, 9°E ...)
    • Kaltstart auf einen DVB-T Sender


    ...


    Resultat ist immer, das die Dreambox (920UHD) Zeit um zwei Minuten in die Zukunft versetzt ist




    Feb 26 17:40:42 dm920 enigma2[4799]: [eDVBLocalTimeHandler] Receiver time is 'Mon Feb 26 17:40:42 2018'
    Feb 26 17:40:42 dm920 enigma2[4799]: [eDVBLocalTimeHandler] Transponder time is 'Mon Feb 26 17:38:19 2018'
    Feb 26 17:40:42 dm920 enigma2[4799]: [eDVBLocalTimeHandler] diff is -143
    Feb 26 17:40:42 dm920 enigma2[4799]: [eDVBLocalTimeHandler] we have correction 143
    Feb 26 17:40:42 dm920 enigma2[4799]: [eDVBLocalTimeHandler] diff after add correction is 0
    Feb 26 17:40:42 dm920 enigma2[4799]: [eDVBLocalTimeHandler] use stored correction(<5 min)
    Feb 26 17:40:42 dm920 enigma2[4799]: [eDVBLocalTimeHandler] not changed




    Sehr irritierend bei EPG, Timeraufnahmen etc ....

  • und warum drehst du dann nicht endlich auf das die transponderzeit ignoriert wird?