Kodi 17 Allgemein

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Kodi 17 Allgemein

      Hallo zusammen,

      ich habe nach heutigem update im Krogoth Branch folgendes Problem beim kompilieren von Kodi:

      Quellcode

      1. NOTE: recipe kodi-17.0+gitrAUTOINC+a10c5048f2-r0: task do_patch: Started
      2. ERROR: kodi-17.0+gitrAUTOINC+a10c5048f2-r0 do_patch: Command Error: 'quilt --quiltrc /home/makaveli/opendreambox/build/dm900/tmp-glibc/sysroots/x86_64-linux/etc/quiltrc push' exited with 1 Output:
      3. Patch 0001-EGL-Port-to-Dreambox.patch is already applied; check your series file
      4. ERROR: kodi-17.0+gitrAUTOINC+a10c5048f2-r0 do_patch: Function failed: patch_do_patch
      5. ERROR: Logfile of failure stored in: /home/makaveli/opendreambox/build/dm900/tmp-glibc/work/cortexa15hf-neon-vfpv4-oe-linux-gnueabi/kodi/17.0+gitrAUTOINC+a10c5048f2-r0/temp/log.do_patch.4989
      6. NOTE: recipe kodi-17.0+gitrAUTOINC+a10c5048f2-r0: task do_patch: Failed
      7. ERROR: Task 1427 (/home/makaveli/opendreambox/meta-openembedded/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb, do_patch) failed with exit code '1'
      8. NOTE: recipe jsonschemabuilder-native-16.0+gitrAUTOINC+b587e98911-r0: task do_configure: Succeeded
      9. NOTE: Tasks Summary: Attempted 5769 tasks of which 5467 didn't need to be rerun and 1 failed.
      10. Summary: 1 task failed:
      11. /home/makaveli/opendreambox/meta-openembedded/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb, do_patch
      12. Summary: There were 2 ERROR messages shown, returning a non-zero exit code.
      13. Makefile:212: recipe for target 'image' failed
      14. make: *** [image] Error 1
      15. Build step 'Execute shell' marked build as failure
      16. Finished: FAILURE
      Alles anzeigen
      Ich vermute da stimmt noch was nicht richtig.
      Wenn ich den patch entferne aus der bbappend, dann meckert er beim nächsten Patch
      (Falls ihr den log braucht bitte bescheid geben und ich hänge den hier dann an)
      Hab es bei allen OE2.5 Boxen schon versucht und kommt derselbe Fehler.

      @DreamDev's
      habt ihr evtl. den Bug schon gehabt ?
      Kann man nicht auf Kodi 17.1 updaten, da es ja nun seit kurzem die finale Version ist ?
    • Bei mir ist es problemlos durch gegangen.


      Quellcode

      1. Package: kodi
      2. Version: 17.0+gitr0+a10c5048f2-r0.0
      3. Description: Kodi Media Center
      4. Kodi Media Center.
      5. Section: base
      6. Priority: optional
      7. Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
      8. Architecture: mipsel
      9. OE: kodi
      10. PackageArch: mips32el
      11. Depends: libgcc1 (>= 5.3.0), libssl1.0.0 (>= 1.0.2h), libpython2.7-1.0 (>= 2.7.11), libpcrecpp0 (>= 8.38), libxml2 (>= 2.9.4), libdbus-1-3 (>= 1.10.6), libz1 (>= 1.2.8), libudev1 (>= 230+git0+3a74d4fc90), libavahi-client3 (>= 0.6.32), libtag1 (>= 1.9.1), libavahi-common3 (>= 0.6.32), libyajl2 (>= 2.1.0), libasound2 (>= 1.1.0), libxslt (>= 1.1.28), libssh (>= 0.7.3), libatomic1 (>= 5.3.0), libgpg-error0 (>= 1.21), bluez5 (>= 5.37), libsqlite3-0 (>= 3.11.0), libstdc++6 (>= 5.3.0), libswresample2 (>= 3.0), libswscale4 (>= 3.0), libpostproc54 (>= 3.0), libtinyxml2.6.2 (>= 2.6.2), libavformat57 (>= 3.0), libpcre1 (>= 8.38), libsmbclient0 (>= 4.4.5), libfribidi0 (>= 0.19.2), libc6 (>= 2.23), libavutil55 (>= 3.0), libfreetype6 (>= 2.6.3), libavfilter6 (>= 3.0), libgcrypt (>= 1.6.5), libmicrohttpd10 (>= 0.9.34), libavcodec57 (>= 3.0), libcrypto1.0.0 (>= 1.0.2h), liblzo2-2 (>= 2.09), libvc5dream (>= 1.0.4), libexpat1 (>= 2.1.0), libuuid1 (>= 2.27.1), libbz2-1 (>= 1.0.6)
      12. Recommends: glibc-charmap-ibm850, glibc-gconv-utf-32, glibc-localedata-en-us, python-shell, python, python-json, python-html, python-ctypes, python-difflib, glibc-gconv-ibm850, glibc-gconv-unicode, libcurl4, libcec4, python-compression, python-zlib, python-sqlite3, python-re, python-lang, python-netclient, glibc-charmap-utf-8
      13. Provides: xbmc
      Alles anzeigen
      Bei bitbake kodi-addon-pvr-hts
      Configuring incomplete, errors occurred!

      Bei bitbake kodi-startup
      missing required distro feature 'x11' (not in DISTRO_FEATURES)

      und bitbake kodi-platform
      Configuring incomplete, errors occurred!

      [18:47 root@dm820 ~] > kodi --help
      Usage: kodi [OPTION]... [FILE]...



      Arguments:
      -d <n> delay <n> seconds before starting
      -fs Runs Kodi in full screen
      --standalone Kodi runs in a stand alone environment without a window
      manager and supporting applications. For example, that
      enables network settings.
      -p or --portable Kodi will look for configurations in install folder instead of ~/.kodi
      --legacy-res Enables screen resolutions such as PAL, NTSC, etc.
      -l or --lircdev LircDevice to use default is /dev/lircd .
      -n or --nolirc do not use Lirc, i.e. no remote input.
      --debug Enable debug logging
      --version Print version information
      --test Enable test mode. [FILE] required.
      --settings=<filename> Loads specified file after advancedsettings.xml replacing any settings specified
      specified file must exist in special://xbmc/system/


      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DMM-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4 HD

      Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von pclin ()

    • kodi-startup

      Quellcode

      1. Package: kodi-startup
      2. Version: 1.0-r0.0
      3. Description: Systemd service for kodi startup
      4. Systemd service for kodi startup.
      5. Section: base
      6. Priority: optional
      7. Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
      8. Architecture: mipsel
      9. OE: kodi-startup
      10. PackageArch: mips32el
      11. Depends: xinit, kodi
      Alles anzeigen
      upower

      Quellcode

      1. Package: upower
      2. Version: 0.9.14-r2.0
      3. Description: upower version 0.9.14-r2
      4. UPower is an abstraction for enumerating power devices, listening to
      5. device events and querying history and statistics.
      6. Section: base
      7. Priority: optional
      8. Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
      9. Architecture: mipsel
      10. OE: upower
      11. PackageArch: mips32el
      12. Depends: libz1 (>= 1.2.8), libdbus-glib-1-2 (>= 0.106), libsystemd0 (>= 230+git0+3a74d4fc90), libc6 (>= 2.23), libcap2 (>= 2.24), libdbus-1-3 (>= 1.10.6), libffi6 (>= 3.2.1), libpcre1 (>= 8.38), polkit (>= 0.113), libusb-1.0-0 (>= 1.0.20), libgudev-1.0-0 (>= 230), libglib-2.0-0 (>= 2.46.2), liblzma5 (>= 5.2.2)
      13. Recommends: pm-utils
      Alles anzeigen
      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DMM-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4 HD

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von pclin ()

    • Hier gibt es Kodi (Orginal.bb) im Download für Images ab 20170324 DM820/DM7080

      kodi-17.0
      Download im IHAD
      i-have-a-dreambox.com/wbb2/thread.php?threadid=194810

      gruß pclin
      Dateien
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DMM-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4 HD

      Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von pclin ()

    • Den Fehler aus Post 1 hatte ich gerade auch mal.

      Baut gerade Kodi-17.1 ist bei do_compile

      Kodi-17.1 ist durch, ist im IHAD
      i-have-a-dreambox.com/wbb2/thread.php?threadid=194810

      gruß pclin
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DMM-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4 HD

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von pclin ()

    • der native player mit dem dm images ist noch unbrauchbar Bild steht oder massive rückler, da muss
      ein bcm profi ffmpeg bcm hardware Beschleuniger noch einbauen

      aber was geht ist die e2player Lösung damit kann man filme schauen.

      Ich hab nur ein Problem nach dem Film schauen ist das kodi menu weg

      denke liegt aber noch am Problem welches ich berichtet habe das OSD accel nun anders funktioniert

      da bin ich aber Plan los kenne mich mit bcm und accel überhaupt nicht aus
    • Bei mir funktioniert mit DreamOS das bauen von kodi-platform nicht
      Keine Ahnung was da noch für ein Problem ist
      Muss da schauen damit das funktioniert

      Quellcode

      1. NOTE: recipe kodi-platform-16.0.0-r0: task do_populate_sysroot: Started
      2. ERROR: kodi-platform-16.0.0-r0 do_populate_sysroot: QA Issue: kodiplatform.pc failed sanity test (tmpdir) in path /home/makaveli/opendreambox/build/dm900/tmp-glibc/work/cortexa15hf-neon-vfpv4-oe-linux-gnueabi/kodi-platform/16.0.0-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
      3. ERROR: kodi-platform-16.0.0-r0 do_populate_sysroot: QA staging was broken by the package built above
      4. ERROR: kodi-platform-16.0.0-r0 do_populate_sysroot: Function failed: do_qa_staging
      5. ERROR: Logfile of failure stored in: /home/makaveli/opendreambox/build/dm900/tmp-glibc/work/cortexa15hf-neon-vfpv4-oe-linux-gnueabi/kodi-platform/16.0.0-r0/temp/log.do_populate_sysroot.23766
      6. NOTE: recipe kodi-platform-16.0.0-r0: task do_populate_sysroot: Failed
      7. ERROR: Task 1456 (/home/makaveli/opendreambox/meta-openembedded/meta-multimedia/recipes-mediacenter/kodi/kodi-platform_git.bb, do_populate_sysroot) failed with exit code '1'

      @babsy98
      vielleicht besteht das Problem mit DreamOS nicht
      Kann es erst später berichten
    • Aber nun haben wir ein weiteres Problem mit kodi-addon-pvr-hts_git

      Quellcode

      1. CMake Error at CMakeLists.txt:7 (find_package):
      2. | By not providing "Findkodi.cmake" in CMAKE_MODULE_PATH this project has
      3. | asked CMake to find a package configuration file provided by "kodi", but
      4. | CMake did not find one.
      5. |
      6. | Could not find a package configuration file provided by "kodi" with any of
      7. | the following names:
      8. |
      9. | kodiConfig.cmake
      10. | kodi-config.cmake
      11. |
      12. | Add the installation prefix of "kodi" to CMAKE_PREFIX_PATH or set
      13. | "kodi_DIR" to a directory containing one of the above files. If "kodi"
      14. | provides a separate development package or SDK, be sure it has been
      15. | installed.
      16. |
      Alles anzeigen
      Werde mich nun auch da ran setzten und das Problem lösen
    • Mein ersten Screenshots von Kodi-17.1 auf DM820

      Bei Video leichtes ruckeln, kein Ton, ist aber auch noch nichts eingestellt.

      Bilder
      • kodi-17.1.jpg

        179,45 kB, 1.920×1.080, 197 mal angesehen
      • kodi-17.1-3.jpg

        270,81 kB, 1.920×1.080, 211 mal angesehen
      Die zwei Gemütszustände eines Programmierers
      0 ich hab keine Ahnung was ich hier mache
      1 ICH BIN GOTT
      ---
      DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DMM-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      ---
      AudioDSP: miniDSP 2x4 HD

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von pclin ()