NFS Performance

  • Hi Leute,


    kann es sein, dass die NFS-Performance der DM520 nicht so gut ist? Versucht mal selbst eine Aufnahme auf ein NFS-Share zu machen, um es dann kurze Zeit später zeitversetzt anzuschauen.


    Was seltsamerweise funktionierte, war eine Aufnahme machen und andere wiedergeben.


    Also mir ist es nicht gelungen, egal ob ich mit dem Netzwerkbrowser oder mit der auto.network gemountet habe.


    Selbs das rumspielen mit den Paramenten hat nichts gebracht.


    Einzig das mounten über SMB/Cifs hat ein brauchbares Ergebnis geliefert.


    Ich hatte die gleichen Einstellungen an der DM7080, an der DM900


    NAS -fstype=nfs,rw,soft,udp,async,rsize=8192,wsize=8192,nolock,vers=3,retry=0 192.168.88.254:/movie/


    Habt ihr evtl. noch eine Idee dazu?


    Greetz Gerry

  • Oh sorry ganz vergessen eine QNAP TS-459 Pro II mit aktuellster FW.


    Zwei weitere DM500HD hängen auch per NFS dran ohne Probleme, aber das ist ja nich das Thema. Fürchte nur, dass an dem NFS auf der DM520 nicht so stimmig ist.


    Greetz Gerry

  • Habe die TS-251 von QNAP.
    Mit der neuen DM525 Combo läuft das Streaming über NFS bei mir tadellos.
    Einstellung in der Datei auto.gemini:
    Filme -fstype=nfs,rw,soft,udp,nolock,rsize=16384,wsize=16384 192.168.99.62:/filme

  • Hallo,


    habe leider nur ältere Qnap 119-TS
    ich verbinde meine Boxen mit den Paramter:


    XML: auto.nas
    Qnap-dreambox	-fstype=nfs,vers=3,rw.soft,tcp,retry=0 192.168.1.10:/Dreambox
    Qnap-public	-fstype=nfs,vers=3,rw.soft,tcp,retry=0 192.168.1.10:/Public
    Qnap-media	-fstype=nfs,vers=3,rw,soft,tcp,retry=0 192.168.1.10:/Multimedia
    Qnap-sonstiges 	-fstype=nfs,vers=3,rw,soft,tcp,retry=0 192.168.1.10:/Sonstiges
    Qnap-esata	-fstype=nfs,vers=3,rw,soft,tcp,retry=0 192.168.1.10:/eSATADisk1
    Qnap-usb1	-fstype=nfs,vers=3,rw,soft,tcp,retry=0 192.168.1.10:/USBDisk1
    Qnap-usb2	-fstype=nfs,vers=3,rw,soft,tcp,retry=0 192.168.1.10:/USBDisk2

    Benutze also keine Angaben mit den rsize=xxx,wsize=xxx aber ein "mount" zeigt mir das sich das System dann selbstständig das aushandelt und sich wie folgt z.B. verbindet. Und habe auch keine Probleme ;)


    Habe aber leider auch keine DM520 zum testen....


    Aber wenn es bei der einen geht, sollte es ja bei den anderen auch gleich gut oder schlecht funktionieren :thumbup:


    Code
    root@dm7080:~# mount
    ......
    192.168.1.10:/USBDisk1 on /media/nas/Qnap-usb1 type nfs rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,soft,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.10,mountvers=3,mountport=30000,mountproto=tcp,local_lock=none,addr=192.168.1.10)



    Code
    dm820 login: root
    root@dm820:~# cd /media/nas/Qnap-usb1
    root@dm820:/media/nas/Qnap-usb1# mount                  
    ....
    192.168.1.10:/USBDisk1 on /media/nas/Qnap-usb1 type nfs (rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,soft,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.10,mountvers=3,mountport=30000,mountproto=tcp,local_lock=none,addr=192.168.1.10)
    root@dm820:/media/nas/Qnap-usb1#



    MfG EgLe



    Kernel : Linux 5.4.40-1-MANJARO (LTS)
    GUI : KDE 5.70.0 / Plasma 5.18.5
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH (DRM 3.35.0, 5.4.40-1-MANJARO, LLVM 10.0.0)
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • dir ist aber schon klar das du mit so vielen mounts den memoryverbrauch fuer den nfs cache voellig unnoetig rauftreibst?


    Und gerade auf den 52x die nicht so reichlich haben ist das keine gute idee.

  • Hab an meiner QNAP noch eine Fehlerquelle gefunden.


    Nach dem deaktivieren des NFS Schreibcaches auf der QNAP funktionierte das Aufnehmen und zeitversetzte ansehen der Aufnahme auf der DM520.
    Auf der DM7080 und der DM900 gab und gibt es da witziger Weise keine Probleme.


    Gruß Gerry

  • Irgendwas schein bei den DM520 Images mit dem NFS noch nicht so gut zu laufen. dbackup mach auf einen NFS-Share keine Komprimierung nach dem Backup über CIFS /SMB funktioniert es ohne Probleme und an der DM900 welche über NFS angebunden ist funktioniert auch alles tadellos.


    Ich kann damit leben, dass die DM520 performanter ist über CIFS / SMB.


    Aber es ist schon seltsam, dass es bei der DM900 genau anders ist.


    Greetz Gerry

  • Hi,


    bin leider auch kein Freund der Systemd-Mounterei. Kämpfe immer mit der Performance an der DM520. Da ja das autofs ( auto.network ) deaktiviert wurde und man nur noch über systemd mounten kann. Habe ich immer wieder Probleme wo die Dreambox die Mount-Optionen verwirft und alle Aufnahmen beim Abspielen ruckeln. Also habe ich die wieder auf nen alten Stand zurückgesetzt, wo noch autofs also die auto.network funktionierte. Dort kann ich alle Parameter mitgeben die brauchen um eine stabile Verbindung auf die NAS zu haben.


    Die auto.network sieht so aus:


    NAS -fstype=nfs,rw,soft,tcp,async,rsize=8192,wsize=8192,nolock,vers=3,retry=0 192.168.88.254:/movie/


    Das wird offentsichtlich nicht richtig umgesetzt von systemd auch der Versuch über den Networkbrowser zu mounten schlug fehl, da die Parameter auf einmal weg waren.


    Greetz Gerry

    Edited once, last by Gerry6n ().

  • wenn diu parameter in der automounts.xml mitgegeben werden über den Netzwerkbrowser geht das genauso.


    Das einzige was nicht optimal gelöst ist das man sie mit der FB tippen muss.

  • Hallo,


    Netzwerkbrowser vergessen und das ganze gleich Händisch ander Tastatur machen incl. aller Parameter.


    https://wiki.manjaro.org/index…Use_SystemD_automount_(de)


    Und wenn man dann mal was Ändern will, oder Experimentieren will, funkt auch kein Netzwerkbrowser dazwischen....



    Alternative:
    altes Images drauf lassen, und weiterhin Autofs benutzen.
    Oder die Konkurrenz-Images auf der kleinen DM520 verwenden ohne Systemd,
    scheint wohl für systemd zu wenig resourcen zu haben incl. deiner anderen Plugins? :/

    MfG EgLe



    Kernel : Linux 5.4.40-1-MANJARO (LTS)
    GUI : KDE 5.70.0 / Plasma 5.18.5
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH (DRM 3.35.0, 5.4.40-1-MANJARO, LLVM 10.0.0)
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

    Edited once, last by EgLe ().

  • systemd hat kein resource problem :-)


    Und ich editiere immer die automounts.xml direkt, da weis ich was ich bekomme.


    Aber es führen viele Wege nach Rom ...

  • Hi Leute hab heute das schöne Wetter genutzt um die Dm520 mal zu aktualisieren. Bzw aktuell neu aufzusetzen. Dabei fiel mir auf, dass wenn ich über den Netzwerkbrowser mounte, das immer nach einem Reboot der Parameter udp in die fstab und in den systemd Mount Container eingefügt wurde. Ist das Absicht? Ich habe die Automount dann wieder gelöscht. Danach habe es händig geändert in der fstab und im Mount Container und schon wirft mir systemd kein udp mehr in den Weg


    Greetz gerry