kein HDR bei Videodateien

  • Nein, das hatte ich natürlich an. Was ich anders einstellte ist das HLG. Es war nicht zu erkennen, daß ich das auf "erzwungen" setzen müßte.
    Heißt, wenn ich den Farbraum wieder zurücksetzen würde (welcher ist Standard?) und das Plugin entferne, daß es auch ohne geht. Wäre einen Versuch wert.

    DM 800 HD se mit Merlin 3 (R.I.P)
    DM 900 UHD mit Merlin 4
    Unitymedia

  • Das kommt halt darauf an, ob das VIdeo was du geschaut hast HLG oder HDR10 ist.


    Die Samsung Software hat einen Fehler.. der TV meldet nicht, dass er HLG kann, obwohl er es kann.


    Durch den Schalter in den AV Settings vertaut e2 dann dem was der TV sagt nicht und probiert es einfach.


    Ich hatte das Samsung auch schonmal gemeldet. Aber anscheinend haben sie keine Lust das zu beheben.


    cu

  • Ich hatte das Samsung auch schonmal gemeldet. Aber anscheinend haben sie keine Lust das zu beheben.

    Dann müßtest du die anderen Probleme genauso haben wie ich. Die Box hängt direkt am TV, der Ton geht von dort in den A/V-Receiver, weil dieser kein 4k kann, sonst würde ich die Box an den Receiver hängen. Der Ton hat bei TV oder Videos immer wieder mal kurze Aussetzer. Ich tippe auf den TV. Oder daß sich Apps wie Youtube sehr komisch verhalten, jenachdem wie man sie startet (aus "Apps" oder Favoritenleiste). Ich hatte das auch mal an Samsung geschrieben, geändert hat sich nichts. Aber das gehört nicht hierhin.


    Also, ich ich hab's probiert wie du beschriebst. Ging nicht. Wenn ich das Farbraum-Plugin entferne, bleibt der gesetzte Farbraum erhalten. Also wieder installiert und auf HMDI_RGB gesetzt. Ist wohl auch das Standardformat, nehme ich an. Dann HLG = erzwungen und ein HDR-Video gestartet. Die Box schaltet den Farbraum nicht um (sieht man an der Skin) und der TV nicht auf HDR. Woher soll die Box auch wissen, auf was sie umschalten soll? Die Einstellung "EDID (Auto)" wird nicht angenommen und nicht gespeichert.

    DM 800 HD se mit Merlin 3 (R.I.P)
    DM 900 UHD mit Merlin 4
    Unitymedia

  • Hallo, seit ich die Erweiterung "Colormode" installiert habe, funktioniert bei meiner dream900 und dem LG OLED die Wiedergabe von HDR content nicht mehr.
    Ich habe Colormode wieder deinstalliert - jetzt erkennt der LG zumindest HLG HDR conent wieder (wird oben rechts kurz eingeblendet) aber die Farben sind flau und auch die Helligkeit ist zu gering.
    Getestet habe ich u.a. mit dem SES UHD Demon Channel und den "Bergrettern" im hbbtv des ZDF.
    Habt Ihr eine Idee, wo ich noch suchen kann? HDR Wiedergabe (z.B. mit AppleTV4k) funktioniert auf dem LG wunderbar - irgendwas muss ich auf der Dream900 verschossen haben.
    Wie gesagt, der LG erkennt den HLG HDR content - trotzdem fehlen die Farben.
    Ideen? Bin für jeden Hinweis dankbar :-)

  • Ich denke eher, dass du an deinem TV einfach die Farben nicht ordentlich eingestellt hast.


    Im HDR Mode muss man je nach TV die gesammte Farbkonfiguration nochmal machen.


    Und das ganze muss man sowieso für jeden HDMI Eingang getrennt einstellen.


    Eventuell gibt es einfach für die TV internen Applikationen eigene optimierte Voreinstellungen.


    Für externe Geräte kommt man um eine Aufwendige Einstellung nicht drum herum.


    Also wenn du deinen TV im non HDR Mode einmal eingestellt hast, dann ist vermutlich im HDR Mode alles anders.. sprich da musst du nochmal abgleichen.


    Das liegt aber nicht an der Box.. eher am TV.


    Und ja.. wenn man den Colorspace manuell an der Box verstellt, wird HDR nicht mehr funktionieren.


    HDR funktioniert nur im Automatischen Mode.. bzw. Itu_R_BT_2020 .. am besten das Plugin runterwerfen und die Box das selber machen lassen.


    cu

  • Hallo Ghost,
    vielen Dank für Deine ausführliche Antwort.
    Es ist aber so, dass die Einstellungen am TV für HDR so sind, wie sie meines Empfindes sein sollen - und es sah vor dem Beginn meiner Probleme anders aus. Soviel Helligkeit oder Farben (die jetzt fehlen) kann man gar nicht rauskonfigurieren ;-)


    "wenn man den Colorspace manuell an der Box verstellt, wird HDR nicht mehr funktionieren."


    Kann ich den automatischen Mode (oder Itu_R_BT_2020 ) irgendwo erzwingen? (und ja - ich kann files auf der Box editieren :-)
    Vielleicht langt die reine deinstallation nicht aus?

  • Führe doch in einem telnet oder ssh Fenster auf der Box einfach mal "journalctl -f" aus... und spiele eine HDR Sendung ab...


    Dann sollte im Logfile so etwas zu lesen sein:


    [ 1128.600047] VIDEO0: EOTF changed to eFuture/eAribStdB67 (HLG)
    [ 1128.600047] MaxContentLightLevel: 0
    [ 1128.600047] MaxFrameAverageLightLevel: 0
    [ 1128.600047] WhitePoint: 0 0
    [ 1128.600047] MinDispMasteringLuma: 0
    [ 1128.600047] MaxDispMasteringLuma: 0
    [ 1128.600047] DisplayPrimaries:
    [ 1128.600047] green -> 0 0
    [ 1128.600047] blue -> 0 0
    [ 1128.600047] red -> 0 0
    [ 1128.604743] VIDEO0: resolution changed (3840 2160)
    [ 1128.605459] HDMI: using HLG eotf


    Im falle von HLG sollte es so aussehen.. bei HDR10 steht dann nicht HLG da.. sondern HDR.


    Außerdem sollte wenn Du den TV aus schaltest.. einen Moment wartest.. und wieder einschaltest so etwas zu sehen sein:
    [ 1241.400373] SET FORMAT: display[0], format='2160p50'
    [ 1241.400952] HDMI mode
    [ 1241.401313] use EDID to detect colorspace
    [ 1241.401778] preferred colorspace: Itu_R_BT_2020_NCL
    [ 1241.402354] using 10bit output
    [ 1241.592224] VIDEO1: shared window not available
    [ 1241.592775] set current avs auto aspect to 16:9
    [ 1241.593321] HDMI: using SDR eotf


    Wenn dieses kommt.. dann schaltet die Box in den HDR Mode.. alles andere ist dann Sache des TVs....


    Und die Box selber hat dann keinen Einfluss auf die Farben.. die Hardware ändert dort nichts.


    Um noch die Frage mit dem Colorspace Plugin zu beantworten.. wenn es deinstalliert wurde, sollte nach einem Neustart der Box automatisch wieder der Auto Mode verwendet werden.


    cu

  • habe ich getestet.
    Fernsehgerät einschalten:


    Dec 11 16:26:16 dm900 kernel: HDMI: CEC recv ok!
    Dec 11 16:26:16 dm900 kernel[240]: [ 463.284132] HDMI: CEC recv ok!
    Dec 11 16:26:16 dm900 enigma2[304]: [eCec] handle message 0 -> f : 87 00 e0 91
    Dec 11 16:26:16 dm900 enigma2[304]: [eCec] Device Vendor ID 00e091 (LG)
    Dec 11 16:26:16 dm900 enigma2[304]: [eCec] --- KNOWN CEC DEVICES ---
    Dec 11 16:26:16 dm900 enigma2[304]: [eCec] |- 0 (): 00e091 (LG), power=1
    Dec 11 16:26:16 dm900 enigma2[304]: [eCec] |- 4 (Apple TV): 0010fa (Unknown), power=0
    Dec 11 16:26:16 dm900 enigma2[304]: [eCec] |- 5 (AVR-X4300H): 0005cd (Denon), power=0
    Dec 11 16:26:16 dm900 enigma2[304]: [eCec] --- KNOWN CEC DEVICES ---
    Dec 11 16:26:16 dm900 enigma2[304]: [DLNA] MediaRenderer detected: [LG] webOS TV OLED65E6D (MediaRenderer, uuid:19abb823-3dae-***-9d69-9be9befac2ad)
    Dec 11 16:26:18 dm900 kernel: HDMI: CEC recv ok!


    Umschalten auf den SES UHD TestSender:


    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] VIDEO0: EOTF changed to eFuture/eAribStdB67 (HLG)
    Dec 11 16:08:20 dm900 kernel: HDMI: using HLG eotf
    Dec 11 16:08:20 dm900 enigma2[736]: VIDEO_GET_EVENT - ok
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] MaxContentLightLevel: 0
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] MaxFrameAverageLightLevel: 0
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] WhitePoint: 0 0
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] MinDispMasteringLuma: 0
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] MaxDispMasteringLuma: 0
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] DisplayPrimaries:
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] green -> 0 0
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] blue -> 0 0
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987214] red -> 0 0
    Dec 11 16:08:20 dm900 kernel[229]: [ 8175.987632] HDMI: using HLG eotf


    Im gesamten Log finde ich keine Einträge, die etwas zu HDMI mode, EDID, colorspace oder 10bit output sagen - obwohl das aktiviert ist (erlaube 10 und 12 bit: ja).
    Seltsam, oder?

  • Wenn der Colorspace falsch wäre, würden die Treiber gar nicht in den HDR Mode.. in diesem Fall HLG schalten.


    Von seiten der Box ist das also definitiv alles korrekt so wie es ist.


    Die Ausgaben zu 10 und 12bit sieht man ggf. nur wenn die Box sich neu mit dem TV synchronisiert.. bei den Samsung TVs ist das immer nachdem man ihn aus/an geschaltet hat.


    Kann aber sein, dass das bei LG anders ist.. dann würdest du diese Ausgabe nur nach dem booten sehen wenn du "dmesg" eingibst...


    Aber wie gesagt.. das ist alles korrekt.. die Box erkennt, dass der TV HLG kann und schaltet auch in den HLG Mode.. also sagt dem TV dass der Content HDR HLG ist.


    Naja und wenn der TV selber auch sagt, dass er HDR empfängt dann ist alles in Butter.


    Wie gesagt.. die Box hat ansonsten keinen Einfluss auf die Farben... die Box könnte da nichtmal was ändern wenn wir es wollten.. weil die Hardware es nicht kann. Der Chip kann nur HDR passthrough.. also durchreichen.



    cu

  • Hallo Ghost,
    mir lässt dies Thema keine Ruhe...


    Wenn ich von einem SDR Sender auf den neuen TravelXP4k Sender umschalte, dann ist für einen Bruchteil einer Sekunde das Bild genau so, wie das HLG Bild wohl aussehen soll: farbenfroh und kontrastreich. Doch dann ändert sich das Bild sofort nach flaue Farben, wenig Kontrast.


    Ich habe jetzt einen Weg gefunden um das reproduzierbar zu machen:
    Habe mir das HLG Demo File http://4kmedia.org/travelxp-4k-hdr-hlg-sample runtergeladen und es zum einen auf die Dreambox-Platte kopiert und zum anderen auf einen USB-Stick, den ich direkt in den TV steckte.
    Das Bild von der Dream war wie oben beschrieben nicht farbenfroh - das Bild vom USB Stick war sensationell bunt und kontrastreich.
    Wenn also das Bild von der Dream nur "durchgereicht" wird - wie kann ich dann diesen Unterschied in Farbe und Kontrast erklären?
    BTW - die HDR-settings des TV sind für USB- und Dreambox-Wiedergabe identisch (das habe ich mehrfach überprüft).
    Auch schaltet der TV wie erwartet in beiden Fällen in den HLG HDR Modus.


    Was ich auch feststellen konnte ist, dass das Problem nur bei HLG auftritt. Denn ich habe das gleiche mit einem HDR10 File gemacht (z.B. http://4kmedia.org/lg-new-york-hdr-uhd-4k-demo/) und in beiden Fällen (Wiedergabe von der Dreambox-HD versus Wiedergabe vom USB-Stick im TV) ist das Bild super.
    Habt Ihr noch Ideen was ich noch testen kann, damit HLG auch so farbenfroh ist? Ist das nur bei mir so?


    DisplayPrimaries im Spoiler:

    Edited 2 times, last by Alf7 ().

  • Ich kann Dir da leider nichts zu sagen.


    Ich habe hier einen Samsung TV.. und der schaltet in den HLG Mode... und auch die Farben sehen richtig aus.


    Naja und TV interne Wiedergabe kann man nicht mit einer externen Quelle vergleichen... wer weiss wie der TV das intern handled.


    Da ist dann ja kein HDMI zwischen.


    Das was mich gerade sehr verwundert ist, dass du meinst für einen kurzen Moment sieht es okay aus...


    Das hört sich ja so an, als ist das exakt der Zeitraum den die Box erstmal selber braucht um zu erkennen, dass das HLG ist.


    Sprich bei Dir sieht das Bild solange richtig aus, wie der TV noch nicht im HLG Mode ist... und es geht erst kaputt wenn die Box ihm sagt er soll umschalten.


    HLG selber ist ja abwärtskompatibel.. sprich es sieht auch ohne HLG tauglichen TV "richtig" aus.



    cu

  • Meinen nachträglich eingefügten "Spoiler" oben hast Du gesehen? Diese "DisplayPrimaries" helfen nicht weiter, oder?
    Hatte noch weitere Tests gemacht - um auf Deine Fragen einzugehen. Ich habe die HDR10- und die HLG-Testfiles auch mal vom AppleTV4k abgespielt - der meines Wissens kein HLG kann.
    Die Wiedergabe eines HLG Files auf dem AppleTV wird ohne "HLG Flag" an den TV gesendet. Und das Bild sieht dann exakt so aus, wie von der Dreambox.
    Daraus schliesse ich, dass die HLG-Wiedergabe auf der Dream zwar vom TV als HLG erkannt wird, aber trotzdem (warum auch immer) kein farbenfrohes Bild daraus macht.
    Wer ist der schuldige? :-) LG oder Dream ;-)


    Um auf Deine Frage "Sprich bei Dir sieht das Bild solange richtig aus, wie der TV noch nicht im HLG Mode ist... und es geht erst kaputt wenn die Box ihm sagt er soll umschalten" einzugehen:
    Ja, genau so ist es. Für einen Bruchteil einer Sekunde ist der Himmer dunkelblau - und dann schwupp.... nach Einschalten des HLG Modus am TV ist er nur noch grau-blau.
    Der Fehler muss ja nicht zwangsläuftig an der Dream liegen - aber wie in meinem ersten Thread geschrieben: es ging ja vor Wochen mal auf meiner Dream...

  • Naja wenn es mal ging... bei uns gabs aber am HLG Code auch seit Wochen / Monaten keine Änderungen.


    Von daher... gabs eventuell ein Update für den LG?


    Keine Ahnung ich weiss nicht was ich da tun soll...


    Der Colorspace stimmt.. das HDMI Info Frame wird ausgegeben. Mehr kann ich nicht tun.


    cu

  • Hallo,
    bei mir auf der Dreambox 900UHD kann ich nicht bei
    dem Plugin Farbraum das hier
    Itu_R_BT_2020_NCL nur das hier


    Itu_R_BT_470_2_BG einstellen.
    Mein Fernsehen ist Samsung 55KS7090.


    woran kann das liegen.


    Danke

  • Und was ist das Problem?


    Du hast vermutlich im Samsung Menü für diesen HDMI Eingang "UHD Color" aktiviert. Wenn das aktiviert ist, gehen nur UHD Modes.


    Ich verstehe nur nicht was diese manuelle spielerei mit dem Colorspace Plugin bringen soll. Am besten lässt man das Plugin deinstalliert, und verstellt nichts.


    Dann geht es am besten.


    cu

  • Kann man m2ts die aus einer UHD/HDR Blu-ray kommt mit der Dream abspielen.
    Ist die HDR Flag in der m2ts vorhanden?

  • meine 4K mkv’s spiele ich über die videodb ab und am oled werden sie mit hdr und im büro am samsung in hd ohne abgespielt

    mfg


    OoZooN


    Support für OoZooN Images gibt es auf forum.oozoon.de , nicht hier!


    Two Beer or not two Beer, thats the Question


    Aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

  • Mein Fernseher ist ein LG OLED, der kann HDR mit meiner PS4 pro.