Serieller Log zeigt nur wirre Zeichen

  • Ich habe eine dm8k, ein Thecus N5550 mit installiertem Debian. Von der Dreambox logge ich ständig seriell mit. Dazu benutze ich einen seriell2USB-Adapter von Belkin.


    Code
    Gerätebezeichnung: dm8000
    Enigma2 Version: 2014-03-14-tarball
    Image Version: Experimental 2013-03-27
    Frontprozessor Version: V7
    Webinterface Version: 1.7.5


    Ich benutze auf der Konsole bspw. folgenden Befehl:


    Code
    nohup cat /dev/ttyUSB2 >> /media/Logs/dm8k/serLog.txt &


    Die Kernel Command Line ist angepasst und enabled:

    Code
    console=ttyS0,115200 ubi.mtd=root root=ubi0:rootfs rootfstype=ubifs rw


    Hat bisher alles wunderbar geklappt. Seit irgendwann habe ich leider nur noch wirre Zeichen im Log.


    Code
    (Ê@q²ìûõÿßßýwÿÿ~ÿ¿ï¿ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿyÜüQ#]Zâ[Ž¡©WsBN-j1™Câ)Šòc•+ù³8
    Sކ
    £ÿûûÿÿÿÿÿÿÿÿÿÿÿÿÿ¦ ³ý«Z!„ˆ:ò™ùBúB‚rþˆïïïïÿÿ­Ý™ñøÿÿÿÿ!u2Bx‘)ô
    ž1Læ ξð>œó>¿Æ!øÿõä%¦§à#ý›ÿýýþÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿq¥ñˆÛÄ+c鈩;ˆŠ!Õ. éÿKŒå¿ˆJ
    7‰!«>„‘Ê1Ì*J0s) ˆ“«'BC9sâˆ5ñ!J
    JÅ)Tb081
    BÙVˆ{!¥ž-
    9,‚–)ž!¯ÀJHB³ ä;¸ ösŽi`){J$ Q)0
    "X1ˆ"¯‡G!`HÆ!Å9kB8)JŠS!1B
    B


    Ich kann leider nicht sagen, ob dies mit dem letzten Update zusammenhängt. Habe auch schon auf ein anderes Gerät geloggt, selber Effekt.


    Kann vielleicht mal bitte jemand gegenprüfen, ob es bei ihm mit dem seriellen Loggen klappt, oder ob er auch nur wirre Zeichen sieht?


    Danke.

    Alptraumbox. :thumbsup:

    Edited once, last by Viril ().

  • Datenrate so eingestellt wie in der Dreambox-Wiki beschrieben. Lief ja vorher auch alles so.


    Wäre halt schön, wenn einer gegenprüfen kann, ob es bei ihm mit dem seriellen Loggen klappt.

    Alptraumbox. :thumbsup:

  • Ist da auch wirklich noch ein gekreutztes Nullmodenkabel dazwischen ? Oder steckt der Adapter direkt am Comport der 8000 ...

    *****************************************************************************


    ('''... Gruß Ketschuss ...''')
    DM920uHD, DM900uHD, DmONE
    Team-Member Project Merlin - we are opensource

  • Ich kann mich nur wiederholen: Lief alles so, nach Dreambox-Wiki (Reichholf) eingestellt.


    Habe nichts geändert. Anbei ein serieller Log vom 26. Mai.


    Minicom hat nicht funktioniert. Befehlszeile oben hat funktioniert.


    Muß jetzt weg.

    Files

    • seriell.txt

      (13.93 kB, downloaded 62 times, last: )

    Alptraumbox. :thumbsup:

  • Bei höheren Dataraten auch Hardware Flow Control auf RTS/CTS setzen!

  • Cisco? Router? Die Dreambox ist über einen seriell2USB-Adapter direkt mit dem Linux-Server verbunden.


    Mit den 9600 ist die Box sehr träge geworden. Booten dauert ewig. Nach jedem Umschalten kommt ein Spinner.
    Habe das Loggen jetzt deaktiviert.

    Alptraumbox. :thumbsup:

  • Cisco? Router? Die Dreambox ist über einen seriell2USB-Adapter direkt mit dem Linux-Server verbunden.


    Mit den 9600 ist die Box sehr träge geworden. Booten dauert ewig. Nach jedem Umschalten kommt ein Spinner.
    Habe das Loggen jetzt deaktiviert.


    Tja, stell auf der anderen Seite auch wieder auf 115200 und alles ist gut...

  • Per minicom (minicom -s)kannst du es einstellen. Da du ja schon geschrieben hast das minicom bei dir nicht funktionieren wollte. Ich würde es mal mit folgenden optionen testen: minicom -w -C /pfadzumlog/logdatei


    Grüße

    --
    openwrt + minicom + screen = 24/7 Bootlog

  • Minicom habe ich jetzt mit "minicom -w -C /media/Logs/dm8k/serLog.txt" ans Laufen bekommen. Command Line der Box wieder auf 115200 und minicom so eingestellt:


    Code
    | A - Serial Device : /dev/ttyUSB4
    | B - Lockfile Location : /var/lock
    | C - Callin Program :
    | D - Callout Program :
    | E - Bps/Par/Bits : 115200 8N1
    | F - Hardware Flow Control : Yes
    | G - Software Flow Control : No


    Alles paletti. Box ist nicht mehr träge


    Mit screen in den Hintergrund gelegt.


    Danke nochmal an alle.

    Alptraumbox. :thumbsup: