Dreambox im Windows Explorer finden

  • Hallo,
    Bin am verzweifeln !!!
    Ich möchte meine neu erworbene Dream 7020 HD auf meinem Laptop im Windows Explerer(Win 7) sehen - kling einfach ist es aber nicht.
    Folgendes funktioniert - ping auf die Box geht, Dreambox WebControl geht!!!
    Also was mache ich falsch ??
    Grüse aus Salzburg

  • ja hab ich - jetzt sehe ich die Box mit den Namen der IP. Wenn ich den Explorer zumache ist die Box wieder weg. Gibts eine möglichkeit die Box dauerhaft anzuzeigen ?

  • Im Explorer wählst Du "Netzlaufwerk verbinden" und gibst dort "\\IP.der.Box" ein.


    Dann wird die immer Box als Laufwerk wie jede andere Festplatte angezeigt.

  • Ich hänge mich hier mal an:


    Ich habe OE 2.0 und auf dem PC Windows 8.


    Unter Windows 7 hatte ich einen Explorer-Favoriten zur Dreambox, der jetzt nicht funktioniert:
    ftp://root@ip.der.box/usr/share/enigma2


    \\ip.der.box führt nur zu 2 Ordnern Configuration und Harddisk.
    Wie komme ich höher hinauf?


    Freundliche Grüße
    jogruber

  • Da ist der FTP-Client von Windows etwas unfähig und kann nicht richtig mit dem Startverzeichnis umgehen (wurde in OE 2.0 geändert).


    Du kannst jetzt entweder den FTP-Client wechseln (ich kann z.B. Filezilla und Cyberduck sehr empfehlen) oder aber du änderst das Startverzeichnis des FTP-Servers auf der Dreambox.
    Dazu musst du nur die Datei /etc/vsftpd.conf mit einem Unix-fähigen Editor (z.B. Notepad++, hat übrigens auch ein brauchbares FTP-Modul ;) ) öffnen und den local_root Eintrag anpassen:

    Code
    1. local_root=/


    Unter Windows7 und OE 2.0 sollten aber dieselben Probleme bestehen...

  • In dieser Datei ist bei mir (bisher) kein Eintrag local_root.

    Edited once, last by jogruber ().

  • Das versteh ich jetzt nicht.
    Ich kann die genannte Datei ja ansehen, sie enthält nur keinen Eintrag local_root

  • Meine Frage hat nichts mit der Datei zu tun.
    Wenn du als Andresse das angibst ftp://root@ip.der.box/usr/share/enigma2 solltest du auch dort landen.
    Schon mal versucht eine FTP Verbindung per Filezilla aufzubauen?

    --
    openwrt + minicom + screen = 24/7 Bootlog

  • Wo landest du denn mit ftp://root@ip.der.box/ im Explorer? Wie warst du denn an die Datei gekommen?


    Ich kann gerade nur im Merlin nachgucken und dort ist der Eintrag eben so gesetzt. Evtl. gibt es noch ne andere Config-Datei oder Option...

  • Schnello
    FTP ist ok. Aber wenn ich die URL von "/" mit FileZella in die Zwischenablage kopiere und diese Adresse in die Adresszeile des Windows Explorer einfüge, passiert gar nichts und bei einem Ordner wie "etc" erhalte ich die Fehlermeldung 550 Failed to Change Directory.


    @morphu
    da passiert gar nichts

  • Wie ich jetzt in FileZilla sehe, führt ftp://root@ip.der.box zu /home/root und dieser Ordner ist bei diesem Image leer. Man gelangt also damit nicht nach ganz oben.


    Was morphu schrieb, klingt also schon recht gut; nur gibt es den Eintrag local_root in der von ihm genannten Datei nicht.

  • Hi


    Solange der Eintrag in der vsftp.conf NICHT gesetzt ist, wirst Du immer in /home/root landen, wenn Du per ftp root@xxx eingibst
    __________


    Um über samba auf / zu kommen, hilft es in der smb.conf in der Sektion Configuration anstelle von /var ein / zu setzen

  • Falsch dein Kommentar ironisch gemeint ist: öffne die conf Datei und schreibe die Zeile (local_root=/) hinein, dann speichere die Datei und starte die Box neu.

    How can we win, when fools can be kings?

  • Nein, nein; war nicht ironisch.
    Ich hatte es vorher auch schon mal reingeschrieben, aber wahrscheinlich nicht gespeichert.

  • Hi


    kleiner Tip dazu - die Datei erst auf den PC holen, dann ändern und speichern, dann wieder zurück auf die Box...
    Und wichtig, wie oben schonmal genannt, einen sog. linuxkonformen Editor zu verwenden (notepad++ ist wohl der beste, den man kriegen kann für ohne Geld ;) ). Der Win-Editor würde das Zeilenende der Datei verändern und ein linuxbasiertes System kann das dann meist nicht mehr lesen... (zum Hintergrund warum für die, die es nicht wissen ;) )