Bugs in neueren und aktuellen CVSen

  • Hi,


    ich hab mir grade zum 1.1.2012 nochmal ein neues Image fuer die 7000er gemacht, aber da sind immer noch zwei Bugs drin die auch schon eine ganze Zeit drin zu sein scheinen.


    1. EPG
    Enigma stuerzt unentwegt ab wenn man etwas herumzapped. Zum Beispiel gestern war es so:
    In irgend ein Programm geschaltet (vorher endlich viel gezapped, weiss nicht mehr wohin) -> Absturz -> ARD -> in RTL schalten -> Absturz -> usw.
    Hab ich den EPG Cache geloescht, konnte in ich wieder Problemlos in RTL schalten. Aber irgendwann frueher oder spaeter, nach endlich viel zappen stuerzt es wieder ab.
    Das Verhalten passiert sowohl mit einem CVS von 1.1.2012, als auch schon mit einem vom 17.10.2010.
    Bei beiden ist/war der Freesat-EPG aktiviert. Ich konnte leider noch nicht testen ob es ohne Freesat EPG auch passiert. Jedoch trat das Problem auch auf ohne das ich in einen SKY UK Sender gezapped habe.


    Bei meinem aelteren CVS vom 23.03.2009 tritt das definitv nicht auf, das laeuft 100% stabil. (gut, da gabs den Freesat-EPG auch noch nicht)


    2. Rueckwaerts spulen in Aufnahme
    Auf jeden Fall mit aktuellem CVS und ich mein auch schon in dem von Oktober 2010 (das von 2009 ist definitiv auch nicht betroffen) wenn man 1x Rueckwaerts spulen drueckt sollte es theoretisch ja 8x rueckwaerts gehen. Es ist aber tatsaechlich um ein vielfaches Schneller.
    Vorwaertsspulen funktioniert richtig.


    Ich weiss noch dass es zwischen 03.2009 und 01.2012 (und wahrsch. schon 10.2010) sowohl bzgl. EPG als auch Spulen Aenderungen gab, habs mir jetzt aber nicht nochmal genau angesehen.


    Vielleicht sagen ja gerade diese Sachen jemand was
    Ich werd mir auf jeden Fall bei Gelegenheit die Aenderungen nochmal genauer ansehen

  • Hmm, sin die Änderungen im ENigma1 überhaupt noch von DMM?


    Glaube nicht, das ist doch soweit in anderen Händen, oder irre ich mich da ?(

    MfG EgLe



    Kernel : 4.19.66-1-MANJARO x86_64
    GUI : KDE 5.60.0 / Plasma 5.16.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH (DRM 3.27.0 4.19.66-1-MANJARO LLVM 8.0.1)
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Ohh, sorry, das wusste ich nicht.
    Wo waere ich den an der richtigen Adresse ?


    Ich dachte das die Leute die ab und an noch Aenderungen am E1 gemacht haben, hier im Forum auch noch unterwegs sind, siehe z.B. die Posts von dbluelle

  • http://www.dbox2-tuning.net/forum/


    Und Ja, es liegt am freesatepg - und Nein, es gibt nichts aus beim Mitloggen


    Schmeiß den Code für das freesatepg komplett raus - das schnurrt wie ein Kätzchen dann


    Kleine Anmerkung am Rande - wenn postings für Enigma1 nicht gewünscht sind - einfach die Bereiche im Board entfernen ;)

  • 1. EPG
    Enigma stuerzt unentwegt ab wenn man etwas herumzapped. Zum Beispiel gestern war es so:
    In irgend ein Programm geschaltet (vorher endlich viel gezapped, weiss nicht mehr wohin) -> Absturz -> ARD -> in RTL schalten -> Absturz -> usw.
    Hab ich den EPG Cache geloescht, konnte in ich wieder Problemlos in RTL schalten. Aber irgendwann frueher oder spaeter, nach endlich viel zappen stuerzt es wieder ab.
    Das Verhalten passiert sowohl mit einem CVS von 1.1.2012, als auch schon mit einem vom 17.10.2010.
    Bei beiden ist/war der Freesat-EPG aktiviert. Ich konnte leider noch nicht testen ob es ohne Freesat EPG auch passiert. Jedoch trat das Problem auch auf ohne das ich in einen SKY UK Sender gezapped habe.

    Hmm, bei mir funktioniert es seit über zwei Jahren problemlos mit dem Freesat-EPG, hast du evtl. noch andere Features aktiviert (z.B. MHW-EPG) ?
    Am besten postest du mal deine prepare_dream.
    Es würde trotzdem auf jeden Fall helfen, wenn du das mal ohne Freesat testen könntest.


    2. Rueckwaerts spulen in Aufnahme
    Auf jeden Fall mit aktuellem CVS und ich mein auch schon in dem von Oktober 2010 (das von 2009 ist definitiv auch nicht betroffen) wenn man 1x Rueckwaerts spulen drueckt sollte es theoretisch ja 8x rueckwaerts gehen. Es ist aber tatsaechlich um ein vielfaches Schneller.
    Vorwaertsspulen funktioniert richtig.

    Ja, das ist eine ewige Baustelle, da hat noch keiner eine wirklich zufriedenstellende Lösung gefunden... :whistling:


    dbluelle

  • dieses Weghängen habe ich auf der dbox2 auch, kommt vor wenn ich intensiv und oft Senderliste aufrufe, mit OK bestätige, wieder Senderliste aufrufe usw. dann manchmal Hänger, seit dem man EPG Cache auf 4 Wochen einstellen kann, viel weniger (!) ich habe den Fehler nun mal wieder herausprovozieren können, hier der Debug


    mrvica

  • Hallo nochmal, wollte mich nochmal melden, musste hier aber grade etwas mit dem Quoting kaempfen :~
    Alsooo:


    Hmm, bei mir funktioniert es seit über zwei Jahren problemlos mit dem Freesat-EPG, hast du evtl. noch andere Features aktiviert (z.B. MHW-EPG) ?
    Am besten postest du mal deine prepare_dream.
    Es würde trotzdem auf jeden Fall helfen, wenn du das mal ohne Freesat testen könntest.


    Hab zuerst ein Enigma OHNE Freesat kompiliert - problen war immer noch da.
    Hab mir dann anschliessend Enigmas kompiliert in denen ich immer eine Revision der epgcache.cpp zurueckgegeangen bin (natuerlich mit jeweiligen Anpassungen damit es ging) ;)


    Die Abstuerze waren da bis einschliesslich epgcache.cpp 1.114 - mit 1.113 waren sie weg!


    Der Uebeltaeter ist also definitiv die Beschraenkung des EPG-Caches auf Bouquet Sender (was ich natuerlich angeschaltet hatte).
    http://cvs.tuxbox.org/lists/tuxbox-cvs-0907/msg00082.html
    Auch die Gegenprobe hat funktioniert - bin wieder auf die aktuelle epgcache.cpp und habe die Option deaktiviert -> laeuft einwandfrei kein einziger segfault mehr seit dem.


    Ich hab jetzt nicht genauer evaluiert was genau dabei die segfaults verursacht - kann man ja evtl. im Tuxbox Forum mal noch naeher versuchen zu klaeren.
    Beim suchen meine ich auch eben dort ein, zwei Kommentare gefunden zu haben, wo jemand genau das geschrieben hatte, aber das ging dort wohl irgendwie unter weils OT war.


    Ja, das ist eine ewige Baustelle, da hat noch keiner eine wirklich zufriedenstellende Lösung gefunden... :whistling:


    dbluelle


    Ahh, ok. da bin ich auch gerade etwas am testen welche Aenderung genau das herbeigefuehrt hat (es gab ja eine Reihe Aenderungen bezueglich des Spulens).


    Ich werd mich diesbezueglich dann auch mal demnaechst im Tuxbox Forum anmelden und melden ;)


    mr_vica : Schau mal ob du auch die Option mit dem EPG-Cache und Bouquets aktiviert hast.


    Viele Gruesse


  • mr_vica : Schau mal ob du auch die Option mit dem EPG-Cache und Bouquets aktiviert hast.


    habe momentan enigma auf englisch laufen, setup->expert setup>EPG Settings, kein Haken bei "only cache EPG data from bouquets", wenn ich es aktiviere startet Enigma neu, schon nach paar Minuten, ebenso kein Haken bei "Use EPG cache for Infobar", wenn ich es aktiviere funktionieren keine Unterkanäle bei Sky Select mehr bzw. funktioniert nur ein einziges Mal und dann leuchtet grün button nicht mehr auf


    mrvica


  • Die Abstuerze waren da bis einschliesslich epgcache.cpp 1.114 - mit 1.113 waren sie weg!


    Der Uebeltaeter ist also definitiv die Beschraenkung des EPG-Caches auf Bouquet Sender (was ich natuerlich angeschaltet hatte).
    http://cvs.tuxbox.org/lists/tuxbox-cvs-0907/msg00082.html
    Auch die Gegenprobe hat funktioniert - bin wieder auf die aktuelle epgcache.cpp und habe die Option deaktiviert -> laeuft einwandfrei kein einziger segfault mehr seit dem.


    Ich habe gerade was eingecheckt, das _vielleicht_ das Problem löst.
    (Unter Umständen füllte sich da die bouquetservicelist endlos weiter und haute nach einer Weile den Speicher zu).
    Übrigens Danke für deine Mühe. :thumbup:


    dbluelle

  • habs mal getestet
    Haken bei "only cache EPG data from bouquets", kein reboot mehr (segfault) , Problem gelöst
    Haken bei "Use EPG cache for Infobar", es funktionieren keine Unterkanäle bei Sky Select nachwievor, ist eh ein anderes Problem, kann mich erinnern dass das in Merlin E1 funktioniert hat, vielleicht da mal abgucken


    mrvica