Problem mit Autores mit neuen Treibern vom 3.6.

  • Seit ich die Treiber dreambox-dvb-modules_2.6.12-5.1-brcmstb-dm800-20090603-r0_dm800.ipk upgedatet habe funktioniert die Format-Umschaltung bei MKVs nicht mehr
    korrekt. Bei 720p und 1080p... wird immer auf das Format das bei HD interlaced eingestellt ist umgeschaltet.
    Hatte das selbe Problem mal vor einiger Zeit mit anderen Treibern hier war das Problem daß ich das Paket dvb-mediasink nicht upgedated habe.


    Jetzt habe ich aber das neueste dvb-mediasink vom 4.6 und das aktuellste autores-plugin installiert und trotzdem klappt die Umschaltung nicht korrekt.


    Fehlt noch was, was upgedated werden muß?


    DANKE!!!

  • Haste neben den Treibern auch das Image/Enigma mal aktualisiert ?


    Solche Probleme kommen oft durch sowas. Es hilft nicht immer einfach nur Treiber oder so auszutauschen. Manchmal sind auch Änderungen am Enigma² oder anderen Dingen notwendig, deshalb wird ja auchd avon abgeraten immer nur einzelne Dateien upzudaten. Besser ist es gleich ein aktuelles Image zu nutzen was auch zu den Treibern passt und wo alles up-to-date ist :thumbup:


    Nutzt du ein aktuelles Image? Wenn's irgendnen altes Image ist und du jetzt hier probierst das irgendwie teilweise upzudaten, glaub dann bringt das alles nix und du bekommst wahrscheinlich mehr Probleme als du lösen kannst. Nutz nen aktuelles Image mit aktuellem Enigma² Core, dann sollte es eigentlich gehen ...


    Ausserdem solltet ihr solche Dinge hier einfach nicht posten da sie total irreführend für die Developer sind, die jetzt denken an den Treibern oder so is was kaputt. Bin mir aber ziemlich sicher das bei dir nix geht weil du nen Image nutzt was schon ein paar Monate alt ist und jetzt da irgendwelche neuen Treiber/Module installierst die nicht zu deinem 'alten' Enigma² passen und nicht 100%ig dazu kompatibel sind. Nicht ohne Grund wird davon abgeraten neue Treiber in alte Images zu installieren. Manchmal funktionierts, manchmal nicht. Formatumschaltung ist ein sehr bekanntes Problem was fast alle User haben wenn sie neue treiber in alte images installieren ...


    Indem Fall wendeste dich besser an deinen "Image-Hersteller" und fragst wann es mal nen neues Update oder Image gibt. Weil mit aktuellem CVS Image jedenfalls gibt es keine Probleme, das kommt nur durch eure Bastelei und alten Images ...

    Theorie ist, wenn man alles weiß, aber nichts funktioniert.
    Praxis ist, wenn alles funktioniert aber niemand weiß warum.

    Edited 2 times, last by Homey ().

  • Es ist mir schon klar, dass es bei älteren Images mit neuen Treiben zu Problemen kommen kann. Mein Posting ist ja auch nicht als Vorwurf eines Bugs an DMM zu sehen.


    Mir ist es nur darum gegangen ob dies ein generelles Problem bei den neuen Treiben ist oder nur auf Grund meiner "Bastelei", und ob es
    ein Info gibt was noch upzudaten ist damit es wieder funktioniert. Es hat ja genau das selbe Thema schon mal gegeben: Wird es andere Treiber für die Fernbedienung geben? und hier mußte man nur ein weiteres Packet updaten.
    Dachte es ist hier ein ähnliches Thema.


    Übrigens basiert das Image auf dem RC vom 10.3.09.


    Wenns keine Info dazu gibt

  • Quote

    Mein Posting ist ja auch nicht als Vorwurf eines Bugs an DMM zu sehen.


    Das nicht, aber es kann trotzdem zu Missverständnissen führen wenn du hier in diesem Forum schreibst das etwas mit den neuen Treibern bei dir nicht funktioniert, ohne drauf hinzuweisen das du nen altes Image benutzt und dir selber was zurecht gefummelt hast. Könntest ja wenigstens drauf hinweisen das du noch nen altes Image hast, dann wissen die Developer bescheid das es an dir liegt und nicht den Treibern :-)


    Mit einem aktuellen Image hat man diese Probleme jedenfalls nicht. Meine Vermutung ist das du auch den C++ Teil von Enigma² updaten musst und das geht halt eigentlich nur durch ein Imageupdate oder nen ganz neues Image einspielen. Probleme mit der Formatumschaltung und solchen Dingen gab es schon sehr häufig und meistens liegts daran das der C++ Teil von Enigma² nicht mit den Treibern kompatibel ist.


    Quote

    Übrigens basiert das Image auf dem RC vom 10.3.09


    Was noch schlimmer ist :D Experimental Treiber in nem Release-Candidate Image kann nicht ohne Probleme funktionieren. Die Release Images basieren auf einem total anderem Stand und da fliessen nur Features und Bugfixes ein die als 100%ig stabil gelten. Da sind viele Dinge noch nicht drin die es in den Experimental Images schon seit vielen Monaten gibt.


    Also ich würde sowas nicht machen. Nen Release Image mit nem Experimental kreuzen kann nicht gut gehen. Wenn ich Lust auf bastelei habe und auch gerne mal neue Treiber probieren will, dann flash ich mir nen experimental Image von DMM und kann's täglich updaten oder neue Treiber probieren usw usw.


    Naja, jedem das seine. Du weisst aufjedenfall woran es liegt das bei dir solche Probleme auftreten :whistling:

    Theorie ist, wenn man alles weiß, aber nichts funktioniert.
    Praxis ist, wenn alles funktioniert aber niemand weiß warum.

    Edited once, last by Homey ().

  • Also habe jetzt ein aktuelles Enigma vom 12.6. und die Probleme mit den mkvs sind immer noch da.


    Weiter werden mkvs im 720p Format die aber nur 1280x528 auf 1280x720 hochgezoomt! Obwohl auf 16:9 contemt auf Letterbox gestellt!
    Wir während des Abspielens kurz auf pan&zoom gestellt und dann wieder zurück auf Letterbox dann ist die Darstellung ok.
    Jedoch bei jedem Filmstart hin und her schalten ich auch etwas fad. Problem hat es auch vor Monaten gegeben wurde aber behoben.
    Verstehe nich warum plötzlich die "alten" bereits vor langem behoben Probleme plötzlich wieder da sind?
    @homy: klappt die Umschaltung und Dartstellung der mkvs tatsächlich korrekt?

  • Hi,


    das Problem hat nichts mit Autores zu tun.


    Das Problem ist eher, dass der damalige "Fix" andere Probleme hervorrgerufen hatte, die uns erst gar nicht aufgefallen sind.
    Durch den "Fix" wird die CPU extrem belastet... sprich alles andere wird dadurch dann langsamer.
    Wir waren zu dem Zeitpunkt aber mehr mit der DM8000 beschäftigt und bei dieser merkt man (durch die deutlich schnellere CPU) es nicht.


    Bei der DM800 merkt man das allerdings sehr deutlich, wenn ein TV Sender oder eine VIdeo mit hoher Bitrate wiedergegeben wird... dann wird die ganze GUI recht träge/zähflüssig.


    Nunja .. auf jedenfall ist dieser "Fix" daher vorläufig für die DM800 wieder rausgeflogen. Für uns ist es wichtiger, dass die Box halbwegs flüssig bedienbar bleibt.


    Da sind ein paar MKV/MP4 Dateien, die falsch gescaled werden momentan eindeutig das kleinere Übel.


    Sobald wir einen ordentlichen Fix für dieses Scaling Problem haben wird es dann neue Treiber geben.


    Sorry... aber da mussten wir Prioritäten setzen.


    cu

  • OK, ist verständlich! DANKE für die Information!


    Box läuft ansonsten bestens!


    Hoffe es wird sich eine Lösung finden!

  • Ich hoffe das ihr dieses Problem lösen könnt und es nicht in Vergessenheit geratet


    Mfg

  • Hi,


    in den aktuellen Treibern ist das aber wieder behoben!


    cu

    Wirklich?
    Sind die Treiber bereits erhältlich? Wenn ja kannst du mir eventuell das Datum nennen?
    Das wäre ja wohl superschnell gegangen :)


    Mfg

  • grad mal ne 720p mkv(daten siehe unten) getestet und die wird hier immernoch als interlaced erkannt.
    Davon ab,wird,wenn man pan & scan eingestellt hat,das bild beim umschalten(im normalen TV betrieb),erstmal in 4:3 dargestellt und dann wieder auf pan & scan gewechselt(und das jedesmal, bei jedem sender bzw. programm,das eigentlich in 4:3 gezeigt wird).
    Image:
    enigma2 2.6 dev
    Enigma Version: HEAD-Jun 25 2009
    Image Version: dev-2009-06-25
    dreambox-dvb-modules_2.6.12-5.1-brcmstb-dm800-20090625-r0



    MKV daten:


    Umschaltung auf 1080i statt 720p,siehe bild.
    [Blocked Image: http://img3.raidpic.com/22moto_0309.jpg]


    AutoResolution einstellungen:
    [Blocked Image: http://img2.raidpic.com/97screenshot.jpg]

    Edited 2 times, last by [TDA] ().

  • With this new driver it is all OK.
    - Autoresolution works perfect
    - No more delay scaling to "just scale" on 4:3 content
    - Nothing is broken 8)

  • With this new driver it is all OK.
    - Autoresolution works perfect
    - No more delay scaling to "just scale" on 4:3 content
    - Nothing is broken 8)

    Ja, klappt jetzt ohne Probleme!


    Jedoch funktioniert bei mir nun das Springen bei MKVs nicht mehr bzw. kaum mehr. Bild bleibt stehen, Box stürzt dabei aber nicht ab. Mann kann den Film beenden und neu starten.

  • Hallo!


    Leider hab ich ein neues Problem festgestellt mit den neuen Treibern. Scheinbar ist es nun absolut nicht mehr möglich eine mkv Datei welche eine DTS und eine AC3 Tonspur beinhaltet zu starten. Früher bei den alten Treibern war es noch so, dass die Datei startet aber das Bild schwarz blieb, man konnte jedoch die Audiospur auswählen und anschließend lief der Film.


    Wäre natürlich super wenn ihr auch dieses Problem noch irgendwie fixen könntet.


    Mfg