[OE2.5] Timeout-Bug in autofs

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • [OE2.5] Timeout-Bug in autofs

    Hallo,

    es ist ein Bug im autofs unter OE2.5 erkannt worden, mir ist er gar nicht aufgefallen :D

    Und zwar wenn man die automount mittels "autofs" macht, sollte sich bei nicht benutzung der Mounts diese ja nach dem
    Vorgebenen Timeout "default ja Timeout=300" sich wieder die Einbindung lösen.

    Dies ist leider nicht der Fall, der oder die Mounts bleiben solange aktiv bis die Box neu gestartet wird
    oder man manuell per systemd den autofs.service neustartet.

    Da mir dies selbst erst gar nicht aufgefallen ist habe ich es aber mal mit meinem Manjaro-Linux gegengeprüft.
    Und es ist leider wahr die Einbindungen werden nicht mehr automatisch getrennt :(

    So sieht es ja aus wenn keine automounts vorhanden sind:

    Quellcode

    1. root@dm7080:~# mount /dev/mmcblk0p1 on / type ext4 (rw,relatime,data=ordered)devtmpfs on /dev type devtmpfs (rw,relatime,mode=755)sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,relatime)devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=sysemd)cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)mqueue on /dev/mqueue type mqueue (rw,relatime)tmpfs on /var/volatile type tmpfs (rw,relatime,mode=755)tmpfs on /tmp type tmpfs (rw,relatime)fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)nfsd on /proc/fs/nfsd type nfsd (rw,relatime)/etc/auto.misc on /misc type autofs (rw,relatime,fd=6,pgrp=276,timeout=300,minproto=5,maxproto=5,indirect)-hosts on /net type autofs (rw,relatime,fd=12,pgrp=276,timeout=300,minproto=5,maxproto=5,indirect)/etc/auto.master.d/auto.dreambox on /media/dreambox type autofs (rw,relatime,fd=18,pgrp=276,timeout=60,minproto=5,maxproto=5,indirect)/etc/auto.hotplug on /autofs type autofs (rw,relatime,fd=24,pgrp=276,timeout=300,minproto=5,maxproto=5,indirect)/etc/auto.network on /media/net type autofs (rw,relatime,fd=30,pgrp=276,timeout=300,minproto=5,maxproto=5,indirect)/etc/auto.master.d/auto.nas on /media/nas type autofs (rw,relatime,fd=36,pgrp=276,timeout=60,minproto=5,maxproto=5,indirect)/dev/sda1 on /media/hdd type ext4 (rw,relatime,data=ordered)/dev/mmcblk1p1 on /media/sdcard type ext4 (rw,relatime,data=ordered)root@dm7080:~#
    Wenn ich jetzt auf ein Laufwerk meines NAS (Dreambox, PC) zugreife sieht man ja zum schluss diesen Eintrag:

    Quellcode

    1. root@dm7080:~# cd /media/nas/Qnap-usb1root@dm7080:/media/nas/Qnap-usb1# lsHorror lost+foundIsland.of.the.Condemned.2008.German.1080p.BluRay.x264-DETAiLS nakedroot@dm7080:/media/nas/Qnap-usb1# cd /root@dm7080:/# mount/dev/mmcblk0p1 on / type ext4 (rw,relatime,data=ordered)devtmpfs on /dev type devtmpfs (rw,relatime,mode=755)sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,relatime)devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)mqueue on /dev/mqueue type mqueue (rw,relatime)tmpfs on /var/volatile type tmpfs (rw,relatime,mode=755)tmpfs on /tmp type tmpfs (rw,relatime)fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)nfsd on /proc/fs/nfsd type nfsd (rw,relatime)/etc/auto.misc on /misc type autofs (rw,relatime,fd=6,pgrp=276,timeout=300,minproto=5,maxproto=5,indirect)-hosts on /net type autofs (rw,relatime,fd=12,pgrp=276,timeout=300,minproto=5,maxproto=5,indirect)/etc/auto.master.d/auto.dreambox on /media/dreambox type autofs (rw,relatime,fd=18,pgrp=276,timeout=60,minproto=5,maxproto=5,indirect)/etc/auto.hotplug on /autofs type autofs (rw,relatime,fd=24,pgrp=276,timeout=300,minproto=5,maxproto=5,indirect)/etc/auto.network on /media/net type autofs (rw,relatime,fd=30,pgrp=276,timeout=300,minproto=5,maxproto=5,indirect)/etc/auto.master.d/auto.nas on /media/nas type autofs (rw,relatime,fd=36,pgrp=276,timeout=60,minproto=5,maxproto=5,indirect)/dev/sda1 on /media/hdd type ext4 (rw,relatime,data=ordered)/dev/mmcblk1p1 on /media/sdcard type ext4 (rw,relatime,data=ordered)192.168.1.10:/USBDisk1 on /media/nas/Qnap-usb1 type nfs (rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,soft,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.10,mountvers=3,mountport=30000,mountproto=tcp,local_lock=none,addr=192.168.1.10)root@dm7080:/#
    Der Eintrag von:

    Quellcode

    1. 192.168.1.10:/USBDisk1 on /media/nas/Qnap-usb1 type nfs (rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,soft,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.10,mountvers=3,mountport=30000,mountproto=tcp,local_lock=none,addr=192.168.1.10)
    Wird leider nicht mehr ausgehängt.Unter meinem Manjaro-Linux habe ich das gleiche auch ausprobiert und da funktioniert es ohne Probleme.Könnte man das bitte mal nachprüfen und evtl. beheben das autofs auch wieder ordentlich funktioniert :?:
    MfG EgLe


    OS ="Manjaro Rolling (KDE)" Kernel: Linux 4.9.9-1-MANJARO QT: 5.8.0 KDE-Plasma: 5.9.2 KDE Frameworks: 5.31.0
    Mainboard = Intel Desktop Board DH87RL
    CPU = Intel Core I7-4770 3,40GHz mit 8GB DDR2 800 RAM
    Grafikkarte = on Board
  • Hallo Ghost,

    Wow, das sind harte Worte....

    Somit ist also OE2.5 das erste Linuxsystem das kein autofs mehr benutzen will,
    danke für die Info und offizielle Auskunft.
    MfG EgLe


    OS ="Manjaro Rolling (KDE)" Kernel: Linux 4.9.9-1-MANJARO QT: 5.8.0 KDE-Plasma: 5.9.2 KDE Frameworks: 5.31.0
    Mainboard = Intel Desktop Board DH87RL
    CPU = Intel Core I7-4770 3,40GHz mit 8GB DDR2 800 RAM
    Grafikkarte = on Board
  • Hallo gutemine,

    Ich wusste das du dich meldest :D

    Tja, bei allen anderen Linuxsysteme einschlißlich Unbuntu, Debian, Arch, Manjaro, Linux from scratch wird dies

    weiterhin funktionsfähig in Verbindung mit systemd angeboten.


    Aber das ist ja nun egal, Ghost hat gesprochen und ich bettle hier nicht um Programm das du sowieso ablehnst ;)


    Ich weiß nun woran ich bin, und somit ist dieses Thema hier für mich erledigt.....
    MfG EgLe


    OS ="Manjaro Rolling (KDE)" Kernel: Linux 4.9.9-1-MANJARO QT: 5.8.0 KDE-Plasma: 5.9.2 KDE Frameworks: 5.31.0
    Mainboard = Intel Desktop Board DH87RL
    CPU = Intel Core I7-4770 3,40GHz mit 8GB DDR2 800 RAM
    Grafikkarte = on Board
  • Du bist dir aber schon klar das ich autofs für die Dreamboxen entdeckt habe, NUR das ist schon eine handvoll von OEs her und die Zeit schreitet nun einmal fort ?

    Im aktuellen OE2.5 ist autofs auch nur mehr für das usb mounten drinnen.

    Wobei ich nicht so ganz verstehe warum man das nicht auch eliminiert und endlich alles auf /media/xxxx mounten lässt.

    systemctl disable autofs

    Dann legst du so wie auf untenstehendem Link beschrieben eine udev rule fürs usb mounten an und /autofs kann in die ewigen Jagdgründe eingehen weil der systemd fürs udev ist schon standardmässig im OE 2.5 Image drinnen und wird auch gestartet.

    axllent.org/docs/view/auto-mounting-usb-storage/

    Ich habe das schon seit OE 2.5 raus kahm so am Laufen ... aber auf mich hört ja keiner ...

    PS: das touchscreen.rules das man dort im udev rules directory findet suggeriert übrigens interessante Fragen über zukünftige Dreamboxen, aber das ist eine andere Geschichte.
    Einmal Rupert und Zurück

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von gutemine ()

  • Nunja... ob das harte Worte sind mag mal dahingestellt sein.

    Wobei ich das Posting auch ein wenig falsch gelesen habe. Ich dachte es geht um Netzwerkverbindungen.

    Für Hotplug devices benutzen wir es schon noch. Also USB-Sticks und dergleichen.

    Nunja... mal schauen ich gebs mal weiter...

    Aber auf der anderen Seite schreien doch alle nach Open Source.... dann sind da mal Fehler in Dingen die offen sind... und ... Pustekuchen.

    Wieder schreien alle wir sollen es fixen ;)

    Aber naja.. ich geh erstmal davon aus, dass es kein Fehler im Code sein wird. Vermutlich irgendwo in einer Konfig Datei ein Wert falsch... oder es fehlt etwas.

    WIrd schon werden...

    cu
  • So habt ihr die User erzogen nur noch Scharfe die nichts mehr selber machen und euch nur noch folgen mit der Hoffnung ihr wird das schon alles regeln und fixen auch wenn es open source ist, wenn man selber was macht wird es auch nicht Positiv gesehen oder wird einfach ist doch alles nur alt abgetan und was nicht von euch kommt sofort schlecht geredet von der Herde. :saint:
  • wie oft soll ich das noch erklaeren. Das netzwerkbrowser plugin speichert seine sachen in der xml aber dadurch wird nichts gemountet. In altem oe wurden aus dem xml vom plugin zeilen in der autofs cobfig erstellt. Im aktuellen oe 2.5 werden aus dem xml zeilen fuer den systemd automounter in der fstab gemacht und autofs wird nicht mehr verwendet.
    Einmal Rupert und Zurück
  • Hallo,

    ich grabe das jetzt mal wieder aus, weil ich mit dem Netzwerkbrowser keinen Zugriff auf meine HDD in meinem PC mehr habe.
    Bisher lief der mount über folgenden Eintrag in der auto.network problemlos.
    M -fstype=cifs,user=Eric\ Pfitzner,pass=testzugang,rw,iocharset=utf8 ://192.168.1.100/M

    Wie binde ich das jetzt im Netzwerkbrowser ein? Ich kann auf der Dream sowohl meinen PC als auch meine freigegebene HDD sehen. Es wird aber kein Inhalt der HDD angezeigt, weil wahrscheinlich die Anmeldung nicht funktioniert.


    Gruß
    Hilfsbereit

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Hilfsbereit ()

  • so dann ...?

    //192.168.1.100/M /media/DESKTOPPC cifs rw,x-systemd.device-timeout=15,rsize=8192,noauto,x-systemd.automount,wsize=8192,x-systemd.idle-timeout=60,soft,username=Eric\040 Pfitzner,password=pass,nofail 0 0

    sooo, ich habe das nur hinbekommen, weil ich einen neuen User in meinem Win10 angelegt habe, der keine Leerstelle enthielt. Es wäre schön, wenn das der Netzwerkbrowser das auch so handeln könnte, wie es über auto.network funktioniert hat.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Hilfsbereit ()

  • Hallo,

    hmm, langsam fange ich an den Netzwerkbrowser und systemd an zu "HASSEN"............

    In diesem Thread geht es doch eindeutig um "autofs" :!:

    Und autofs hat rein gar nichts mit dem Netzwerkbrowser und der fstab mounterei zu tun.


    Und niemand (auch nicht die die den Netzwerkbrowser jedem empfehlen) sind in der Lage mal einen gescheiten Thread zu machen
    nur für den Netzwerkbrwoser unter OE2.5 damit sich jeder seine Infos, Fragen und Fehler in einem thread zusammen suchen kann.

    Nein jeder Thread der in irgendeiner Art was mit "mounten" zu tun hat oder auch nicht (Boxtypen und Thread-Entfremdungen) finden sich Postings
    mit und über dem Netzwerkbrowser, und üb erall nur "anstöße", und wenn sich jemand wirklich damit als Anfänger beschäftigen will (neuerdings auch muss)
    findet er doch nicht wirklich Infos ohne Jahrelang durch tausende Threads zu suchen......


    Da dieser Thread mit dem Timeout-Bug DMM ja ehh egal ist und autofs nicht supportet wird,
    könnte dann mal ein Mod so nett sein und diesen Thread auch sperren oder gar löschen :?:
    MfG EgLe


    OS ="Manjaro Rolling (KDE)" Kernel: Linux 4.9.9-1-MANJARO QT: 5.8.0 KDE-Plasma: 5.9.2 KDE Frameworks: 5.31.0
    Mainboard = Intel Desktop Board DH87RL
    CPU = Intel Core I7-4770 3,40GHz mit 8GB DDR2 800 RAM
    Grafikkarte = on Board