Dreambox bootet nicht

  • Dreambox bootet nicht

    Hallo,

    ich habe meine Dreambox ausgeschaltet und am nächsten Tag wieder eingeschaltet (Gerät war Stromlos).

    Seit dem bootet die Dreambox nicht mehr. Im Display steht "Dream Multimedia booting ..." und der boot Balken ist fünf millimeter

    lang. Ich habe also die Box noch einige male geflasht über http und über Dreamup (mit Defekten sektoren wiederherstellen) immer das gleiche Ergebniss.

    Ich habe auch schon den Tuner ausgebaut und dann versucht zu starten, leider auch das gleiche Bild wie oben. Ich bekomme auch kein Bild auf dem Fernseher beim boot Vorgang. Im Hyperterminal bekomme ich dieses Ergebniss beim booten:

    (c) 2007,2008 Dream Multimedia GmbH. All rights reserved.
    Dreambox DM800
    FIRST STAGE 1.00 {BO23456}

    2ND STAGE OK, build #76 (20100419)

    0.000 - BCM board setup
    {00000126,00000126,00000125,00000124,00000123,00000133}
    0.007 - fp init
    0.008 - ca init
    0.717 - load config
    dCA: not existent, loading defaults
    0.748 - config loaded.
    * press to enter setup
    OLED found!
    BOOT #76(20100419)
    detected jffs2 blocksize: 16kb
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    +++++++++++++++++++++++++++++++++++++++++++++++++++
    dreamupd initialized
    Scanning JFFS2 FS: . done.
    /flash/bootlogo.elf
    bootlogo size: 285065
    using 1280x720p (60.00 Hz)
    Using the Small jpeg decoder library, Copyright (c) 2006, Luc Saillard <luc@sail
    lard.org>
    parsing JPEG header..
    JPEG Size: 1280x720
    /flash/vmlinux.gz
    <5>Linux version 2.6.18-7.4-dm800 (tmbinc@pepe.multimedia-labs.de) (gcc version
    <5>Linux version 2.6.18-7.4-dm800 (tmbinc@pepe.multimedia-labs.de) (gcc version
    Fetching vars from bootloader... none present, using defaults.
    board_init_once: regval=44ac6502, ddr_strap=3, 4 chips, pci_size=2
    Detected 256 MB on board
    <4>WARNING: read invalid MAC address ff:ff:ff:ff:ff:ff from flash @ 0xbffff824
    Default command line =
    root=/dev/mtdblock3 rootfstype=jffs2 rw console=null
    1 831ffed8 8303c848
    g_board_RAM_size=256MB
    Options: sata=1 enet=1 emac_1=0 no_mdio=0 docsis=0 ebi_war=0 pci=1 smp=0
    CPU revision is: 00020000
    Determined physical RAM map:
    memory: 10000000 @ 00000000 (usable)
    ---> memsize from bootloader: 148
    User-defined physical RAM map:
    node [00000000, 09400000: RAM]
    node [09400000, 06c00000: RSVD]
    <5>Reserving 108 MB upper memory starting at 09400000
    <7>On node 0 totalpages: 65536
    <7> DMA zone: 65536 pages, LIFO batch:15
    Built 1 zonelists. Total pages: 65536
    <5>Kernel command line: root=/dev/mtdblock3 rootfstype=jffs2 rw console=null
    before init RAC 0x02a00000 0x00000000
    after init RAC 0x02a0000f 0x0fff0000

    Hat jemand noch eine Idee?



    Gruß Volker

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von yoda98mnt ()

  • also in dem bootlog da oben kann man noch nix sehen weil das logging deaktiviert war im BIOS (commandline: console=null ). Da diese Kernel-Commandline da muss das logging aktiviert sein so wie man auf dem screenshot sehen kann (KERNEL COMMAND LINE), haste das erst später so eingestellt im BIOS, wenn ja mach nochmal nen bootlog. Die Settings im log und die auf dem screenshot passen jedenfalls nicht überein !?

    Und du hast die box jetzt auch mehrmals neu geflashed? Mir aktueller Software von DMM, also dreamboxupdate.com? Dann frage ich mich warum noch immer der alte 76iger Bootloader drauf ist, flashe bitte aufjedenfall originall DMM Images von wwww.dreamboxupdate.com !

    PS: Das ist auch eine Original Dreambox und kein Klon/Plagiat? Muss man leider heute schonmal fragen wenn man 800er Boxen mit so altem Bootloader sieht ...
    Theorie ist, wenn man alles weiß, aber nichts funktioniert.
    Praxis ist, wenn alles funktioniert aber niemand weiß warum.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Homey ()

  • hmm, was mich auch wundert ist das Linux Kernel 2.6.18-7.4 drauf ist, aber noch der alte 76iger Bootloader.

    Ich vermute einfach mal er hat nen Klon und installiert sich auch Klonimages oder so was. Muss man leider von ausgehen weil es gibt von DMM keine Images mit diesem Kernel und 76iger Bootloader. Und es gibt auch keinen Grund den alten Bootloader behalten zu wollen, ausser er hat nen Klon ;) Original DMM Images flasht er aufjedenfall nicht, dann wäre der bootloader auch mal geupdated worden. Der flasht sich irgendwelche modifzierten images aufjedenfall und ich kenne nur klon images die solch alte Bootloader beinhalten.

    Das so aktuelle Images nicht mit einem >1 Jahr altem Bootloader funktionieren ist eigentlich auch klar ... das kann nicht funktionieren.

    Ich hab so das Gefühl hier erzählt uns jemand nur die halbe Wahrheit ;)
    Passt aufjedenfall nix zusammen von dem was er da posted ...
    Theorie ist, wenn man alles weiß, aber nichts funktioniert.
    Praxis ist, wenn alles funktioniert aber niemand weiß warum.

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Homey ()

  • Hallo,

    ne ich habe auf jeden Fall eine Orginal Box. Da ich eine der ersten habe und damals gab es noch keine Clone Boxen.

    Warum der Bottloder so alt ist weiss ich auch nicht. Ich mache das Update mit Dreamup neu von Dreammedia geladen.

    Image das ich installiere ist dieses: dreamboxupdate.com/opendreambo…s/release-dm800-3.0.3.nfi

    Anbei noch mal der neue log und das Bild vom Boot Menu:

    Scanning JFFS2 FS: . done.
    /flash/bootlogo.elf
    bootlogo size: 285065
    using 1280x720p (60.00 Hz)
    Using the Small jpeg decoder library, Copyright (c) 2006, Luc Saillard <luc@sail
    lard.org>
    parsing JPEG header..
    JPEG Size: 1280x720
    /flash/vmlinux.gz
    <5>Linux version 2.6.18-7.4-dm800 (tmbinc@pepe.multimedia-labs.de) (gcc version
    4.4.3 (GCC) ) #1 Wed Dec 15 22:20:39 UTC 2010
    Fetching vars from bootloader... none present, using defaults.
    board_init_once: regval=44ac6502, ddr_strap=3, 4 chips, pci_size=2
    Detected 256 MB on board
    <4>WARNING: read invalid MAC address ff:ff:ff:ff:ff:ff from flash @ 0xbffff824
    Default command line =
    root=/dev/mtdblock3 rootfstype=jffs2 rw console=null
    2 831ffed8 8303c848
    g_board_RAM_size=256MB
    Options: sata=1 enet=1 emac_1=0 no_mdio=0 docsis=0 ebi_war=0 pci=1 smp=0
    CPU revision is: 00020000
    Determined physical RAM map:
    memory: 10000000 @ 00000000 (usable)
    ---> memsize from bootloader: 148
    User-defined physical RAM map:
    node [00000000, 09400000: RAM]
    node [09400000, 06c00000: RSVD]
    <5>Reserving 108 MB upper memory starting at 09400000
    <7>On node 0 totalpages: 65536
    <7> DMA zone: 65536 pages, LIFO batch:15
    Built 1 zonelists. Total pages: 65536
    <5>Kernel command line: root=/dev/mtdblock3 rootfstype=jffs2 rw console=null
    before init RAC 0x02a00000 0x00000000
    after init RAC 0x02a0000f 0x0fff0000

    (c) 2007,2008 Dream Multimedia GmbH. All rights reserved.
    Dreambox DM800
    FIRST STAGE 1.00 {BO23456}

    2ND STAGE OK, build #76 (20100419)

    0.000 - BCM board setup
    {00000126,00000126,00000125,00000124,00000123,00000133}
    0.007 - fp init
    0.008 - ca init
    0.722 - load config
    0.750 - config loaded.
    * press to enter setup
    OLED found!
    BOOT #76(20100419)
    USB: Locating Class 09 Vendor 0000 Product 0000: USB Hub
    USB wait failed.
    waiting for USB failed!
    no valid boot source found. press any key to enter setup.
    *** STOP ***
    dreamupd initialized
    Bilder
    • bootbild.JPG

      47,72 kB, 667×420, 809 mal angesehen
  • So jetzt ist der 82 er Boot Loader

    wieder drauf. Allerdigs bootet er immer noch nicht:


    (c) 2007,2008 Dream Multimedia GmbH. All rights reserved.
    Dreambox DM800
    FIRST STAGE 1.00 {BO23456}

    2ND STAGE OK, build #82 (2011-02-25)

    0.000 - BCM board setup
    {00000126,00000126,00000125,00000124,00000123,00000133}
    0.007 - fp init
    0.008 - ca init
    0.722 - load config
    0.749 - config loaded.
    * press to enter setup
    0.754 - ide init
    OLED found!
    lcd: BOOT #82
    1.078 - main control
    - read config file: /boot/secondstage.conf
    1.084 - load /boot/secondstage.conf to 834da668 (max=65535)
    detected jffs2 blocksize: 16kb
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    +++++++++++++++++++++++++++++++++++++++++++++++++++
    2.499 - jffs2 size: 3840 kb
    2.502 - network: 2.504 manual, ip address is 10.210.185.21
    2.545 - starting network
    2.551 - httpd, telnetd, dreamupd
    dreamupd initialized
    2.556 - ok. start receiving packets
    2.560 - using jffs2
    Scanning JFFS2 FS: . done.
    find_inode failed for name=secondstage.conf
    load: Failed to find inode
    2.747 - size: 0
    - failed to open /boot/secondstage.conf
    2.752 - not entering setup
    2.755 - execute script: /cf/autorun.bat
    2.759 - load /cf/autorun.bat to 834da668 (max=65535)
    2.763 - size: -1
    - failed to open /cf/autorun.bat
    2.768 - force boot: -1
    2.770 - try boot from 1:/autoexec.bat
    2.774 - execute script: /boot/autoexec.bat
    2.778 - load /boot/autoexec.bat to 834da668 (max=65535)
    2.783 - using jffs2
    2.785 - size: 38
    lcd: /flash/bootlogo.elf
    2.792 - load /flash/bootlogo.elf to 82000000 (max=16777216)
    2.797 - using jffs2
    2.825 - size: 229441
    2.827 - decompressing elf (compressed: 229441 bytes)
    2.929 - decompression ok (uncompressed: 640540 bytes)
    2.934 - loading elf image at 88000000
    3.124 - jumping to 80466da0
    3.126 - load /boot/bootlogo.jpg to a2800000 (max=1048576)
    3.132 - using jffs2
    3.183 - size: 59299
    bootlogo size: 59299
    *** BCHP: Invalid RTS setting detected. Forcing MEMC_0_CLIENT_INFO_7 (AVD_CAB_0
    ) RR to true. Please see latest 7401 RTS documentation.
    no HDMI device detected
    no HDMI mode available, reverting to 720p
    using 1280x720p (60.00 Hz)
    create surface 1280 720
    Using the Small jpeg decoder library, Copyright (c) 2006, Luc Saillard <luc@sail
    lard.org>
    parsing JPEG header..
    Virtual FB Size: 1280x720
    lcd: /flash/vmlinux.gz
    4.231 - load /flash/vmlinux.gz to 82000000 (max=16777216)
    4.236 - using jffs2
    4.459 - size: 1996963
    4.461 - decompressing elf (compressed: 1996963 bytes)
    5.272 - decompression ok (uncompressed: 4550882 bytes)
    5.277 * Quiesce...
    5.278 *** Turning off USB
    5.281 *** Quiesce network...
    5.284 - loading elf image at 88000000
    5.821 - jumping to 80382000
    <5>Linux version 2.6.18-7.4-dm800 (linux@linux) (gcc version 4.4.3 (GCC) ) #1 Th
    u Mar 24 19:24:26 CET 2011
    Fetching vars from bootloader... none present, using defaults.
    board_init_once: regval=44ac6502, ddr_strap=3, 4 chips, pci_size=2
    Detected 256 MB on board
    <4>WARNING: read invalid MAC address ff:ff:ff:ff:ff:ff from flash @ 0xbffff824
    Default command line =
    root=/dev/mtdblock3 rootfstype=jffs2 rw console=null
    2 831ffeb8 83029368
    g_board_RAM_size=256MB
    Options: sata=1 enet=1 emac_1=0 no_mdio=0 docsis=0 ebi_war=0 pci=1 smp=0
    CPU revision is: 00020000
    Determined physical RAM map:
    memory: 10000000 @ 00000000 (usable)
    ---> memsize from bootloader: 148
    User-defined physical RAM map:
    node [00000000, 09400000: RAM]
    node [09400000, 06c00000: RSVD]
    <5>Reserving 108 MB upper memory starting at 09400000
    <7>On node 0 totalpages: 65536
    <7> DMA zone: 65536 pages, LIFO batch:15
    Built 1 zonelists. Total pages: 65536
    <5>Kernel command line: root=/dev/mtdblock3 rootfstype=jffs2 rw console=null
    before init RAC 0x02a00000 0x00000000
    after init RAC 0x02a0000f 0x0fff0000
    Bilder
    • bootbild.JPG

      47,15 kB, 667×420, 595 mal angesehen
  • also da steht immernoch das deine kernel-command line mit console=NULL gesetzt ist im BIOS.

    Quellcode

    1. Kernel command line: root=/dev/mtdblock3 rootfstype=jffs2 rw console=null


    deshalb auch keinerlei brauchbaren infos in deinen logs weil das loggin in console deaktiviert ist. Da müsste aber console=ttyS0,115200 pder so stehen ...

    Ich kanns auf dem screenshot leider nicht erkennen was da hinter consol steht weil da ende ist ... das muss aber aufjedenfall geändert werden weil solang das logging bzw. console=Null ist, kann man leider nix sehen im bootlog, das hört halt genau da auf wo es gerade spannend wird und das system booten soll.

    Sag mir mal bitte die komplette Zeile in deinem BIOS die du nun bei kernel-command-line da eingetragen hast, weil ich glaub jetzt passt da gar nix mehr ;) Sind irgendwie nur mehr fehler hinzugekommen, das kann aber nicht sein daher vermute ich mal die command line ist falsch.

    100%ig sicher bin ich mir nich aber ich glaube die command line mit logging müsste im bios so aussehen:
    Kernel command line: console=ttyS0,115200 root=/dev/mtdblock3 rootfstype=jffs2 rw

    * = NULL nicht O
    Bin mir aber nich 100%g sicher (hab keine 800er mehr)

    PS: Was war jetzt das Problem mit dem Bootloader, wie hast du jetzt den aktuellen darauf bekommen und warum hats vorher nix aktuelles installiert beim flashen?

    PPS: So oder so, irgendwas wird wohl kaputt sein wenn selbst das neu flashen nicht hilft. Denke das beste wird sein sie zu DMM zu schicken nachdem du ein Ticket aufgemacht hast. Ein Bootlog wäre natürlich trotzdem noch hilfreich um schonmal vorab vlt zu erkennen woran es liegt, aber vermutlich halt ein defekt an der hardware.
    Theorie ist, wenn man alles weiß, aber nichts funktioniert.
    Praxis ist, wenn alles funktioniert aber niemand weiß warum.

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Homey ()

  • glück gehabt :)

    Wollte ich auch vorhin schonmal gefragt haben, als meine SSD Platte letzten Monat kaputt gegangen ist bootete die box auch nicht mehr.
    dann im log gesehen das es wohl probleme gibt die hdd zu erkennen. Am PC dann selbe theater also war SSD schon wieder kaputt.

    Na dann, glück gehabt :) Und sorry wegen der Klonvorwürfe, sah aber irgendwie was komisch aus ein aktuelles image mit altem bootloader, kenn ich nur von klonimages sowas. War nich böse gemeint ;)
    Theorie ist, wenn man alles weiß, aber nichts funktioniert.
    Praxis ist, wenn alles funktioniert aber niemand weiß warum.